1 2 Previous Next 13 Replies Latest reply: Aug 21, 2014 8:57 AM by Ja7 RSS

    Fresh install of ePO 5.1.1

    Ja7

      We were using ePO 4.5 on WS2003 and instead of updating several times and migrating, we decided a fresh install of 5.1.1 on WS2008 R2.

       

      All going well so far but when trying to push out the new Agent, VSE is blocking 'Prevent modification of McAfee Common Management Agent files and settings' on our current system (we need to lift this so that the new server can stick the new agent on). We have put a temporary lift of this setting in Access Protection Policies but the change is not taking effect on Windows 7 machines, even after a wake up.

      We have some old Windows XP machines we've tested this on and after a wake up, the policy applies and the setting is lifted and we're able to push out the new agent and products via the new server and remove the PC from the old server directory.

       

      The XP/W7 machines are using the same Firewall policy and GPO's and inherit the policies from the same places in ePO but there is a difference in whether the 'Prevent modification of McAfee Common Management Agent files and settings' setting becomes 'unticked'. Any siggestions why this would be please?

        • 1. Re: Fresh install of ePO 5.1.1
          andrep1

          If the old server is still up, use the transfer agent functionality. All you need to do is export the servers key and import in the other server then the servers can exchange systems. I think it should work even with ePO 4.5

          This way you don't have to push a new agent.

           

          McAfee KnowledgeBase - How to transfer/move computers from one ePO server to another

          • 2. Re: Fresh install of ePO 5.1.1
            Ja7

            Are you referring to the 'Transfer Systems' functionality?

             

            If so, I did try that early on in the process and am still greeted with "There are no registered servers with Transfer Systems enabled" when I attempt it.

            • 3. Re: Fresh install of ePO 5.1.1
              andrep1

              Correct, if you follow the kb it works. We used it to transfer when switching servers over multiple times.

              Had you followed the KB above ?You just need to import the keys and create the registered  servers, enabling transfer. It works.

              • 4. Re: Fresh install of ePO 5.1.1
                Ja7

                Apologies, hadn't seen the KB.

                 

                Having gone through most of it it, the 2 issues I'm experiencing are I can't see which ones are the the 2048-bit keys - it's not apparent which one it is - I exported and imported one key and on the new server, it says that they're 1024-bit keys.

                 

                Also, more importantly, the Test Connection is failing with "Database connection failed. Please check configuration." and I've copied the settings like for like from the same screen on the new server.

                • 5. Re: Fresh install of ePO 5.1.1
                  ansarias

                  Hello,

                   

                  Could you please check if your SA account is locked or not, If its working than try core-configauth option to test connection between ePO and DB Server.

                  • 6. Re: Fresh install of ePO 5.1.1
                    Ja7

                    The SA account is fine and I've also tried going to core-configauth and tested my SA and it's successful (although in the credentials on there by default, there's a different SA account, which I'm not sure of the password for so didn't test that).

                    • 7. Re: Fresh install of ePO 5.1.1
                      rgc

                      Hi JA7,

                       

                      For your scenario, the best way to follow the KB82126 ( How to perform a side-by-side upgrade of ePO) and direct link as below.

                       

                      McAfee KnowledgeBase - How to perform a side-by-side upgrade of ePO

                       

                      This helps to parallely maintain both ( old and New EPo) and get the work done with less impact.

                       

                      I hope this will helps, follow the steps and reply to this post with status, if you still have queries.

                       

                      Regards,

                      RGC

                      • 8. Re: Fresh install of ePO 5.1.1
                        Ja7

                        Hi rgc,

                         

                        I've followed that KB along (but only want to import the System Tree to get the systems across) but can't perform step 4 as I've not added the new ePO server as an agent handler in the old server (do I need to do this?).

                         

                        Also, surely this is going to leave me in the same predicament as before - I can add the Windows 7 PC's to the system tree but the current VSE they're gewtting from old ePO server is blocking 'Prevent modification of McAfee Common Management Agent files and settings'.

                         

                        Any suggestions?

                        • 9. Re: Fresh install of ePO 5.1.1
                          andrep1

                          Nice approach, can probably work if you are not using tags for policy and task assignment.

                          1 2 Previous Next