1 2 Previous Next 10 Replies Latest reply on Sep 16, 2015 3:55 PM by massdotvsolem

    Unable to Install Rogue System Detector

    massdotvsolem

      Initially I kicked off an "install Rogue Detector" job for all machines under the "Assigned Client Tasks" tab.  This job appeared to work, but only installed the Rogue System Detector (RSD) onto about 900 of 1600 machines in the group.   It's now more than two weeks later.

       

      Now, when I try to install onto the remaining 700 machines I get this error.

           "Unable to add Rogue Sensor deployment task to node "..." because a parent "..." already contains an Rogue Sensor install deployment task.

       

      It won't let me install even doing one at a time.   How do I get the installation to complete?  We'd like to have RSD installed everywhere.

       

      Any suggestions?

       

      -Vik

        • 1. Re: Unable to Install Rogue System Detector
          ansarias

          Hello,

           

          First of all why you are installing so many sensor on machines? you need to install one sensor in each IP subnet than only it will work. RSD is not required on all machines.

          • 2. Re: Unable to Install Rogue System Detector
            massdotvsolem

            We are installing sensors on all machines so that EPO can select two machines per subnet to be the active sensors.

             

            If we selectively install only one sensor per subnet then we must continue to monitor and maintain which machines are running Rogue Detectors in order to make sure that the sensors are active.  Allowing EPO to select which machines are the active sensors allows for more automation which means less work for staff.

            • 3. Re: Unable to Install Rogue System Detector
              ansarias

              If your database is having capacity to load such incoming RSD events than you can go ahead and do this. I'll not prefer to do this settings.

              I'll go with single server on each site/ IP subnet to make RSD sensor so there will not issue with activation.

              • 4. Re: Unable to Install Rogue System Detector
                massdotvsolem

                In our situation we have more than 300 subnets.  With our daily churn in clients (in and out of EPO), it would be a non-trivial effort to maintain one RSD per subnet.

                • 5. Re: Unable to Install Rogue System Detector
                  ansarias

                  with respect to error:

                  "Unable to add Rogue Sensor deployment task to node "..." because a parent "..." already contains an Rogue Sensor install deployment task.

                   

                  which means those machines already having RSD deployment task, I'll suggest to create a group and moved all machines and apply task to that group with time intervals and also monitor incoming Client events where you will also get error codes if machine is unable to install RSD sensor.

                  • 6. Re: Unable to Install Rogue System Detector
                    massdotvsolem

                    In our situation I don't think that is a very palatable solution.

                     

                    1. if we move to a new group and keep them there then we must
                      1. create a new group
                      2. move all settings from the current group to the new one (this is non-trivial)
                      3. move a test machine to the new group.
                      4. test the settings on the machine to confirm settings are as needed. (this is non-trivial)
                      5. move all 1400 machines to the new group
                      6. invoke the install on the remaining machines.
                    2. if we move to a new group, install RSD then move back to the old group then it does not clear the install deployment task from the original group.

                     

                    Neither of these addresses the problem that there is a pending task that never completes ( remaining in an error state for ever? ), and which stops other tasks from working.

                     

                     

                    I'd prefer to force the task to complete or remove it from the list of pending tasks.

                    • 7. Re: Unable to Install Rogue System Detector
                      ansarias

                      Ok,

                       

                      Try below option on 10 failed machines and see what happen.

                       

                      1. Select 10 machine and go to Actions.
                      2. Select Agent and Click on Run Client Task now.
                      3. A new window will open where select Product as Rouge System Detection, Task Type as Sensor Deployment and Task name select your created deployment task.
                      4. At bottom Click on Run Task Now
                      5. Now check the progress on Status if it failed than check those machines treat and client events for more details.
                      • 8. Re: Unable to Install Rogue System Detector
                        massdotvsolem

                        That is the procedure that I've been trying.  The error message is as I mentioned above.

                         

                        I may have found a way around it.  I tried deleting the RSD install task from the "assigned client tasks" tab.

                        Now it appears that I am able to get the install to run, one machine at a time without getting the error.

                        I'm waiting to see if the machines complete the task and show that the RSD is installed.

                        • 9. Re: Unable to Install Rogue System Detector
                          michaelm1983

                          did that work? - I'm getting the same issue but I don't really want to delete it as I get the message it may effect a lot of systems.

                           

                          cheers

                          1 2 Previous Next