3 Replies Latest reply on Aug 1, 2014 1:48 AM by asabban

    Using postfix on MWG

    bornheim

      I am under the impression that sending mail with Email.Send() is a one-time-try. If it does not succeed at once, the mail is lost. MWG uses a "trivial" SMTP client (as in "opposed to some store and forward facility").

       

      I found that MWG comes with a postfix installation. How about this:

      - set relayhost in main.cf

      - chkconfig --level 2345 postfix on

      - /etc/init.d/postfix start

      Then set the SMTP server to 127.0.0.1 in MWG.

       

      Would that probably work? Would that be an "unsupported configuration"?

       

      Kind regards,

      Robert

        • 1. Re: Using postfix on MWG
          asabban

          Hello,

           

          by default there is no SMTP server installed on the appliance. Most likely installing postfix will be an "unsupported configuration", however it will most likely not interfere with MWG. You need to accept that support will not provide any help when there are problems with the configuration or operation of postfix. Also when "strange" errors like memory corruption or rare crashes occur engineering may ask to re-image the device to a "default" installation before troubleshooting can be done.

           

          Besides these limitations that should work. Anyway you could setup a small postfix installation on any Linux OS that sits "close" to the MWGs, e.g. on the same switch and network to ensure mails can correctly leave MWG and are queued in case of problems with the next-hops.

           

          Best,

          Andre

          • 2. Re: Using postfix on MWG
            bornheim

            Hi Andre,

             

            Ok, I tried that and it works. :-)

             

            For reference of other people:

             

            If you are relaying to some internal host, add these lines to /etc/postfix/main.cf:

                 relayhost = [IP]

                 disable_dns_lookups = yes

            Replace IP with the IP address of your relay. Keep the square brackets!

             

            # /etc/init.d/postfix start

            # chkconfig --level 2345 postfix on


            Now go to Policy > Settings > Engines > Email notification and change "SMTP server" to 127.0.0.1 under "Default" and "Monitoring".


            You can check what is going on in /var/log/maillog


            Kind regards,

            Robert

            • 3. Re: Using postfix on MWG
              asabban

              Thank you for the feedback!

               

              Best,

              Andre