7 Replies Latest reply on Jul 24, 2014 7:34 AM by ansarias

    Cannot install agent, 'error 2: The system cannot find the file specified'

    helpdesk101

      I've got a single workstation which refuses to take the McAfee agent.   Whether I generate the file and install manually with a doman admin or attempt to push directly from ePO, the process fails.  I haven't found a thread which quite matches what I'm seeing here so I'm hoping someone can be of assistance.  This is a brand new install for the first time ever, there are no existing McAfee products or registry keys on the system.  The same installer package has worked flawlessly on a dozen other systems.

       

      Here's the FrmInst_MACHINENAME.log output:

       

      2014-06-26 10:58:47    I    #4572    Setup    Ins    Windows 6.1.7601 Service Pack 1

      2014-06-26 10:58:47    I    #4572    msiFix    Ins    Finding agent MSI product code

      2014-06-26 10:58:47    I    #4572    msiFix    Ins    Did not find installed agent MSI

      2014-06-26 10:58:47    I    #4572    Setup    Ins    Attempting to perform a setup operation

      2014-06-26 10:58:47    I    #4572    caShrLb    Ins    SOFTWARE\Network Associates\TVD\Shared Components\Framework is not present

      2014-06-26 10:58:47    I    #4572    Setup    Ins    Legacy installed=0

      2014-06-26 10:58:47    I    #4572    Setup    Ins    Installing version=4.8.0.641

      2014-06-26 10:58:47    I    #4572    Setup    Ins    Higher version installed=0

      2014-06-26 10:58:47    E    #4572    RegKey    Ins    Error trace:

      2014-06-26 10:58:47    E    #4572    Thread    Ins     [Main thread]->

      2014-06-26 10:58:47    E    #4572    Setup    Ins     [Attempting to perform a setup operation]->

      2014-06-26 10:58:47    E    #4572    RegKey    Ins     [RegOpenKeyEx,80000002,SOFTWARE\Network Associates\ePolicy Orchestrator\Application Plugins\EPOAGENT3000]->

      2014-06-26 10:58:47    E    #4572    RegKey    Ins      error 2: The system cannot find the file specified.

      2014-06-26 10:58:47    I    #4572    Setup    Ins    LangInRegistry=[]

      2014-06-26 10:58:47    I    #4572    Setup    Ins    C:\Windows\SysWOW64\msiexec.exe /i "C:\Users\username\AppData\Local\Temp\mfe88ED.tmp\MFEagent.msi" ADDLOCAL=Main,Agent TRANSFORMS=:1033.mst /qb+ /l+*v "C:\Users\username\AppData\Local\Temp\McAfeeLogs\MFEagent.msi.2014.06.26.10.58. 47.log" SITEINFO="C:\Users\username\AppData\Local\Temp\mfe88ED.tmp\SiteList.xml" PRESERVEREPOSITORIES=True FRMINSTLOGFILE="C:\Users\username\AppData\Local\Temp\McAfeeLogs\FrmInst_MACHINE NAME"

      2014-06-26 10:59:57    E    #4572    Setup    Ins    Error trace:

      2014-06-26 10:59:57    E    #4572    Thread    Ins     [Main thread]->

      2014-06-26 10:59:57    E    #4572    Setup    Ins     [Attempting to perform a setup operation]->

      2014-06-26 10:59:57    E    #4572    Setup    Ins     [Run MSI]->

      2014-06-26 10:59:57    E    #4572    Setup    Ins      error 1603: Fatal error during installation.

      2014-06-26 10:59:58    E    #4572    UI    Ins    Error trace:

      2014-06-26 10:59:58    E    #4572    Thread    Ins     [Main thread]->

      2014-06-26 10:59:58    E    #4572    UI    Ins      Fatal error during installation.

       

       

      From the FrmInst_MACHINENAME_error.log:

       

      2014-06-26 10:58:47    E    #4572    RegKey    Ins    Error trace:

      2014-06-26 10:58:47    E    #4572    Thread    Ins     [Main thread]->

      2014-06-26 10:58:47    E    #4572    Setup    Ins     [Attempting to perform a setup operation]->

      2014-06-26 10:58:47    E    #4572    RegKey    Ins     [RegOpenKeyEx,80000002,SOFTWARE\Network Associates\ePolicy Orchestrator\Application Plugins\EPOAGENT3000]->

      2014-06-26 10:58:47    E    #4572    RegKey    Ins      error 2: The system cannot find the file specified.

      2014-06-26 10:59:57    E    #4572    Setup    Ins    Error trace:

      2014-06-26 10:59:57    E    #4572    Thread    Ins     [Main thread]->

      2014-06-26 10:59:57    E    #4572    Setup    Ins     [Attempting to perform a setup operation]->

      2014-06-26 10:59:57    E    #4572    Setup    Ins     [Run MSI]->s

      2014-06-26 10:59:57    E    #4572    Setup    Ins      error 1603: Fatal error during installation.

      2014-06-26 10:59:58    E    #4572    UI    Ins    Error trace:

      2014-06-26 10:59:58    E    #4572    Thread    Ins     [Main thread]->

      2014-06-26 10:59:58    E    #4572    UI    Ins      Fatal error during installation.

       

      Clearly, the system can't find some file or something regarding that registry key, but again as noted, the rest of the systems I've run it on have no problem at all and complete promptly without error. Win7Pro x64, domain environment.  Suggestions?  Additional information I can provide?

       

      Thanks.