1 2 Previous Next 15 Replies Latest reply: Dec 3, 2014 11:27 PM by rgc RSS

    Epo migration stuck at Administrator information step

    Rudi Beeres

      Good afternoon,

       

      I'm trying to migrate Epo 4.6.6. (server 2003 32bit) to Epo 5.1 on a Server 2012 R2

      Following some articles and forum posts I first installed SQL on the new server and moved over the database.

      Now this step went flawless.

       

      I then used the upgradecompatibility tool to create to migrate.zip and moved it to the new server.

      There i used the tool again to migrate the settings. The tool is creating the McAfee ePolicy Orchestrator Application Server service. (the only service that is installed at this point)

      I run the Epo 5.1 setup until it asks me for the administrator information and the keystore encryption passphrase. I tried our global (domain) administrator account and the administrator which is used for getting into the console, but they're both denied.  Could this has something to do with the passphrase? Is this something I need from the old server? I'm not familiar with it.

      I appreciate any feedback.

       

      Regards,

      Rudi

       

      Message was edited by: helpdeskdb on 6/5/14 10:43:14 AM CDT
        • 1. Re: Epo migration stuck at Administrator information step
          meforum

          hi,

           

          could you provide us a screenshot?

           

          I didn't used th migration tool but moved epo 'by hand' - but - as far as I know ePO 5.1 upgrade asks you for your old/current ePO admin password and for a NEW keystore encryption passphrase (as this is new in ePO 5.xx) - and I think you have to type it twice.

          So if you only have ONE field for keystore passphrase - just try to leave it blank.

          • 2. Re: Epo migration stuck at Administrator information step
            Rudi Beeres

            Thank you for replying.

             

            I thought using the migration tool would be easier then doing it by hand.

            Also because of the conversion from 32 bit to 64 bit and at the same time an Epo upgrade.

             

            I tried to fill in the phrase fields as well as leaving them blank, but keep getting the message (Screen 2)

            • 3. Re: Epo migration stuck at Administrator information step
              meforum

              hi,

               

              yes - maybe using the migration tool is easier - but for me I migarted the database/server too and would like to leave the production system untached (e.g. didn't want to remove unsupported extensions or upgrade products for 5.1 support in production environment)

               

              Do you use the same database / sql server as with epo 4.6.6? Do you have some special characters for yout sql access / password? (this could cause problems)

               

              BUT - most likely : ist your default ("root") admin account really "administrator"? Not "admin" (this is epo authentication - not e.g. ActiveDirectory Authentication/user)

               

              AND: I think I remember - that when you run migration tool to create your migration.zip file - you may have to enter a passphrase to protect it's content!? This could be the passphrase above (keystore enc...).

              • 4. Re: Epo migration stuck at Administrator information step
                Rudi Beeres

                Hello,

                 

                I'm using the same database for epo 4.6.6. The database has already moved to the server where I want to do the new installation. (so it becomes a local database again)

                I don't think there is something wrong with the SQL access, while I passed the first step in the Epo 5.1 setup where it finds the database and connects with windows authentication.

                In the second step I use an Epo global administrator. I checked the account on our current Epo server. Nothing wrong with permissions here.

                 

                I also did the migration all over again and it didn't ask for the passphrase

                 

                I was just thinking that it somehow still wants to connect to the old server in that specific step. Which is not possible due to disabled services.

                Or are there services missing on the new server, while only the Application server service is installed and started?

                What is the difference between the 3 mcafee services anyway?

                 

                Thanks

                • 5. Re: Epo migration stuck at Administrator information step
                  pjw2012

                  Hi,

                   

                  Did you manage to get past this? I have exactly the same issue.

                   

                  Using the username\password I have always used for ePO and have no record of ever setting up a Keystore encryption Passphrase

                   

                  Cheers

                  • 6. Re: Epo migration stuck at Administrator information step
                    mikecel79

                    I am also having this same exact problem.  We are moving from EPO 4.6.8 to 5.1.1 and the install refuses to accept my admin password even though I know it's correct.

                    • 7. Re: Epo migration stuck at Administrator information step
                      pjw2012

                      Well ladies and gentlemen, I believe I have cracked it! 

                       

                      On mine at least, hopefully one of you can give this a go and let me know if it does indeed work.

                       

                      I went back to the very start to look at where I might have gone wrong and noticed that when I first created the migration file I accepted the default path to the ePO server (https://localhost:8443), so instead changed local host to the server name. Re-created the migration file and went back to my new server. Now my new server had an agent and virus scan installed and running (during the previous install attempt I just stopped all of the services) so I decided as a secondary step just to completely remove all McAfee products from this server.

                       

                      Ran the migration import and then setup and it worked first time, no complaints about the username and password.

                      • 8. Re: Epo migration stuck at Administrator information step
                        jbaker

                        Experiencing the same issue.

                         

                        Pjw2012 - I changed loclahost to servername and I'm still receiving the same error. I'm unable to authenticate using the epolicy orchestrator admin / password. If I start up the old server, I can log in using those credentials.

                         

                        When you retried the installation on the new server, did you do anything besides deleting the McAfee files in Program Files? Any registry changes / configuration changes?

                        Any help greatly appreciated. Every step of this migration has been a headache so far.

                        Thank you.

                        • 9. Re: Epo migration stuck at Administrator information step
                          pjw2012

                          Hi jbaker,

                           

                          I used the instructions found here: McAfee KnowledgeBase - How to manually remove ePO 5.x

                           

                          There are quite a lot of registry entries to find and remove I'm afraid. Hope this helps!

                          1 2 Previous Next