3 Replies Latest reply on Nov 24, 2014 1:47 AM by kumar.raja67

    Does anyone know what causes this error message from the orion.log?

    andrewdc

      Hi,

       

      I have a couple of ePO servers (uat & prod) running ePO 4.6.7 Build:278 on a Windows Server 2008 R2 platform. I see the following error message repeatedly from the orion log. Does anyone know what causes it and what the fix is?

       

      014-06-03 10:07:26,855 ERROR [http-8444-Processor18] server.OrionLoginModule  - Call to OrionLoginModule.authenticate() with a 'null' username and no valid client certificate found!  Just return...

      2014-06-03 10:07:26,855 WARN  [http-8444-Processor18] realm.JAASRealm  - Cannot find message associated with key jaasRealm.loginException

      javax.security.auth.login.LoginException: Login Failure: all modules ignored

      at javax.security.auth.login.LoginContext.invoke(LoginContext.java:913)

      at javax.security.auth.login.LoginContext.access$000(LoginContext.java:203)

      at javax.security.auth.login.LoginContext$4.run(LoginContext.java:690)

      at javax.security.auth.login.LoginContext$4.run(LoginContext.java:688)

      at java.security.AccessController.doPrivileged(Native Method)

      at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:687)

      at javax.security.auth.login.LoginContext.login(LoginContext.java:596)

      at org.apache.catalina.realm.JAASRealm.authenticate(JAASRealm.java:401)

      at org.apache.catalina.realm.JAASRealm.authenticate(JAASRealm.java:326)

      at org.apache.catalina.authenticator.BasicAuthenticator.authenticate(BasicAuthenti cator.java:181)

      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.ja va:528)

      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)

      at com.mcafee.orion.core.server.AjaxValve.invoke(AjaxValve.java:84)

      at com.mcafee.orion.core.server.OrionUserSetupValve.invoke(OrionUserSetupValve.jav a:41)

      at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:393)

      at com.mcafee.orion.core.server.OrionSingleSignOn.invoke(OrionSingleSignOn.java:15 1)

      at com.mcafee.orion.core.server.ClientCertValve.invoke(ClientCertValve.java:69)

      at com.mcafee.orion.core.server.ClientCertValve.invoke(ClientCertValve.java:69)

      at com.mcafee.orion.core.server.ClientCertValve.invoke(ClientCertValve.java:69)

      at com.mcafee.orion.core.server.ClientCertValve.invoke(ClientCertValve.java:69)

      at com.mcafee.orion.core.server.ParameterEncodingValve.invoke(ParameterEncodingVal ve.java:37)

      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:10 8)

      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)

      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:879)

      at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConn ection(Http11BaseProtocol.java:665)

      at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:5 28)

      at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorke rThread.java:81)

      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:6 89)

      at java.lang.Thread.run(Thread.java:745)

        • 1. Re: Does anyone know what causes this error message from the orion.log?
          kumar.raja67

          Hi Andrew,

           

          Even i am also getting the same error in orion logs. I am unable to login the EPO Console.Even all 3 EPO services running.

           

          Could you please let me know if you got any updates regarding the same issue.

           

          2014-11-24 09:22:10,099 ERROR [Thread-54] internal.LdapCacheMapper  - java.sql.SQLException: Violation of PRIMARY KEY constraint 'PK_LDAP_CACHE'. Cannot insert duplicate key in object 'dbo.OrionLdapCache'. The duplicate key value is (CTS, CTSINTBMCFAH).

          2014-11-24 09:22:18,462 ERROR [http-8444-Processor25] server.OrionLoginModule  - Call to OrionLoginModule.authenticate() with a 'null' username and no valid client certificate found!  Just return...

          2014-11-24 09:22:18,649 ERROR [http-8444-Processor24] server.OrionLoginModule  - Call to OrionLoginModule.authenticate() with a 'null' username and no valid client certificate found!  Just return...

          2014-11-24 09:22:18,883 ERROR [http-8444-Processor25] server.OrionLoginModule  - Call to OrionLoginModule.authenticate() with a 'null' username and no valid client certificate found!  Just return...

          2014-11-24 09:22:50,585 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.Rule]; using defaults.

          2014-11-24 09:22:50,631 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.Application]; using defaults.

          2014-11-24 09:22:50,631 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.Executable]; using defaults.

          2014-11-24 09:22:50,694 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.NamedNetwork]; using defaults.

          2014-11-24 09:22:50,709 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.Rule.remoteNetworks]; using defaults.

          2014-11-24 09:22:50,709 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.Rule.networkProtocols]; using defaults.

          2014-11-24 09:22:50,709 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.Rule.localNetworks]; using defaults.

          2014-11-24 09:22:50,725 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.Group.children]; using defaults.

          2014-11-24 09:22:50,725 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.Application.executables]; using defaults.

          2014-11-24 09:22:50,725 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.Rule.applications]; using defaults.

          2014-11-24 09:22:50,725 WARN  [main] hibernate.EhCacheProvider  - Could not find a specific ehcache configuration for cache named [com.mcafee.hips.catalog.model.NamedNetwork.hosts]; using defaults.

          2014-11-24 09:23:07,559 INFO  [main] startup.Catalina  - Server startup in 86603 ms

          2014-11-24 09:24:24,658 WARN  [http-8443-Processor15] [localhost].[/core]  - Exception thrown whilst processing POSTed parameters

          javax.net.ssl.SSLException: Inbound closed before receiving peer's close_notify: possible truncation attack?

          • 2. Re: Does anyone know what causes this error message from the orion.log?
            Troja

            Hi all,

            seems to be a known behavior. McAfee KB81396 describes the issue.

             

            Info about EPO 5.1.1 and Debug Logging.

            Beginning with ePO 5.1.1, this error will be seen only if you have the debug logging enabled on Orion.


            Hope this helps,

            Cheers,

            Thorsten

            • 3. Re: Does anyone know what causes this error message from the orion.log?
              kumar.raja67

              Thanks for the update.

               

              We have Restarted all 3 EPO services on the issue server. After that we able to login the console successfully.

               

              You mentioned above its a known behavior. Could you please give me the details for what reason we are getting this error.

              Or its related to any point product issues. Its very helpful in future to check the issue ASAP.

               

              Even I am not able to see the KB article. Its not visible to customer view?

               

              Regards,

               

              Kumararaja J