0 Replies Latest reply on Mar 26, 2014 3:18 PM by Scott Sadlocha

    Questions on Software Manager and Master Repository

    Scott Sadlocha

      I am hoping for a little guidance with regard to McAfee Software Manager and Master Repository. I have quite a few products showing Updates Available in Software Manager, as well as new versions of products that need to be introduced (ePO 5.1, etc.) and I am not sure of the best method to do so. If anyone could provide some explanation or point me toward some helpful resources and KB articles, I would appreciate it. Some items I have noted:

       

      • Fairly regularly, our Download Software Product List server task fails. It works occasionally, but when it fails, I see messages along the lines of: 3/19/14 1:04:01 AM  Completed: Download Software Product List (Failed to download the products list due to "Failed to connect to the Software Catalog server.") 

       

      • In Software Manager, if I find a Component that has an available version showing and I click on Update, choosing to move the older version to the Previous Branch, when I get the update done and come back, I still have an Update Available—it is just in Previous Branch now, and if I Update it there, I no longer have an older version, but rather two copies of the new version (one in Current, one in Previous)

       

      • What is the best way to progress through software? Should I update in Software Manager or Check-In there? Or, should I just be in Master Repository doing Pulls there and Check-In Package there, pointing to any location where I have downloaded a file from our download portal? How do the Master Repo and Software Manager relate to each other? It seems like some new software does not show up when I want it to and I don’t know in what order I should do things. Is there a step by step to working with these two?

       

      • Earlier today, I was in Software Manager, looking at VSE for Linux. I figured this would be a good place to work a bit, since we don’t have this product deployed yet. While in the screen for this product, I clicked on Update All. My ePO window hung, and CPU on the server hit 100% and stayed there. I waited quite a while to see if it would quit, but it never did.  I ended up restarting services to get it to come back.

       

      • A little while later, I Updated HIPS in Software Manager, another product that we don’t have deployed widely. After updating it to Current, I realized that I should have placed it in Evaluation. I went into Master Repository and moved a package to Eval. Unfortunately, I mistakenly moved the older version, which I wanted to move back to Current. I then tried moving the newer version to Eval, after which I figured I would move the older one back to Current. However, once it was done, I found that the older version was completely gone. It seems that if one version is written to a branch where another version is, they can’t co-exist? I didn’t get any kind of prompt or anything. It was just gone. Since I had no other version to work with, I just moved the newer version back to Current.

       

      • Lastly, the Update Master Repository server task is failing when I try to run it. This seems to have started after things I did earlier. I am not sure if it is related to the service stop/start, whatever locked the server up, or my HIPs package manipulation, but whenever I try to run it, I get the errors listed below. In looking at the community, I have seen that several people have run into this, but I have found no definitive answer why, or a way to resolve it. Some people mentioning clearing temp, some people say a backup was running, but none of it seems to be concrete. Any ideas as to what this is? The server task was working fine until recently, and I have tried switching to McAfeeFTP but it fails immediately.

       

       

      McAfeeHttp 3/26/14 3:53:13 PM INFO Downloading package

      Current\VSCANDAT1000\7389.000

      0\DAT\0000

       

      McAfeeHttp 3/26/14 3:53:46 PM ERROR Failed to validate repository

      McAfeeHttp. File

      C:\Windows\TEMP\naiA666.tmp\00

      000002\avvdat.ini found hash

      81537632D1A016C7452A8FEC95B

      85DA9C7752421, expected hash

      09356834BC60A2F4C1C46679621

      DC7AB042C3D63

       

       

       

      I know it is a ton of information, but I want to provide as much detail as I can. If anyone can even help me with a little of it, I would appreciate it immensely, even a point in the right direction. Thanks so much.