5 Replies Latest reply on Apr 9, 2014 4:12 PM by ChrisU

    MVT Reports Today's Dat Out of Date.

    awbattelle

      Windows 7

      VSE 8.8.0.1247

      MVT for EPO

      I noticed this problem a couple of weeks ago, but I didn't say anything because I was sure it was on McAfee's end and that they would eventually catch it.

      As you can see from the screenshot, MVT reports that my AV Dat is out of date, even though it is clearly today's dat. It does this on all WIN 7 machines. MVT says everything else is OK, except on the MVT banner, where it says "Some problems could not be fixed". Otherwise the log is clean. You'll also notice that the dat it expected to find (7374) is in fact the current dat that is loaded on the system.

      I am beginning to wonder if I am the only person that uses this tool regularly. The last three posts in this area are mine, and they all are about some MVT malfunction. Perhaps this time it is something on our Win 7 image that is causing the problem.

       

      Message was edited by: awbattelle on 3/11/14 3:12:40 PM CDT

       

      Message was edited by: awbattelle on 3/11/14 3:14:00 PM CDT
        • 1. Re: MVT Reports Today's Dat Out of Date.
          ChrisU

          Anthony, have you considered a career change into software testing?

           

          Looking at the log, MVT says it is expecting "blank" for the Dat, and so is failing the logic detect that way. I am pretty sure I know what the cause is, but I want to double check with the team first.

          • 2. Re: MVT Reports Today's Dat Out of Date.
            ChrisU

            Well, I was actually wrong on the cause, but the team pushed a content update this morning to address this.

             

            Please let me know if you still encounter the problem.

            • 3. Re: MVT Reports Today's Dat Out of Date.
              awbattelle

              I think ,maybe I should come work for you guys. I'd keep you honest.

              So, I have some good news and some bad news. The good news is, the dat probelm is resolved. Yay!

              The bad news is, if the system is Win7 and has HIPS, MVT is once again forgetting, that McAfee Registry entries are under Wow6432Node. As you can see in the screenshot, it's looking for them in the XP location.

               

              Also, the file location is incorrect. I find fwinfo.exe here C:\Program Files (x86)\McAfee\Host Intrusion Prevention\VSCore\release

              There is no "tools" directory on our Win 7 systems with HIPS.

               

              Message was edited by: awbattelle on 3/13/14 9:15:37 AM CDT
              • 4. Re: MVT Reports Today's Dat Out of Date.
                awbattelle

                I haven't checked MVT in while because I normally don't like to bang my head against the wall. but it does appear now that the issues described in this discussion have been fixed. My result was "no problems found" Session ID 50816582. And I am running the latest version of VSE and HIPS. The only thing I did notice, was that there seems to be some sort of issue with the security cert as shown in the message I received when trying to install the binary.

                "Revocation Information for the security certificate is not available. Do you want to proceed?" Which is odd, because if I examine the certificate, it does clearly state the expiration date.  Anyway, I just click Yes, and it installs normally, so, this isn't a showstopper, and MVT is once again a great tool for checking our test images and of course, for diagnostics. So rest assured, I'll be watching!

                • 5. Re: MVT Reports Today's Dat Out of Date.
                  ChrisU

                  Good to hear Anthony! Sorry for not replying earlier, things got a little hectic there at the end of March.

                   

                  Let us know if you run into any other problems!