6 Replies Latest reply on Jul 21, 2014 8:08 PM by thiffaultcanada

    Problems with Mavericks and McAfee Internet Security for Mac

    bzumwalt

      I first knew I had a problem when I saw this popup on my iMac:

       

      "System extension cannot be used. The system extension “/usr/local/McAfee/AntiMalware/Extensions/Virex.kext” was installed improperly and cannot be used. Please try reinstalling it, or contact the product’s vendor for an update."

       

      Then I checked the McAfee console and it says that Real-Time Scan is not working. The console indicated everything else was working fine. Ran Update and it worked with no problem.

       

      When I looked at My Account, it says the software on this iMac is inactive despite the fact it shows almost 2 months remaining on the subscription. I ran Update as suggested on the page to correct this, but to no avail.

       

      I ran MVT in preparation for an online chat (which hasn't happend yet) and the results said "platform not supported". So I tried to reinstall and got an error saying "an enterprise version is already installed and that I cannot install McAfee Internet Security upon the Enterprise version." I then uninstalled everything and still get the same error when I do a fresh download from My Account and attempt another install.

       

      I have another iMac and a PC which are running McAfee with no problem. Both iMacs are running Mavericks and Internet Security for Mac.

       

      Any suggestions other than wait for a response from Support?

       

      In the meantime, I have no antivirus protection and have taken the iMac offline.

       

      In all my years as a McAfee customer, I have never had to use Support. How long does is usually take them to respond to an online service request? I received an email confirmation but no information on how long or how to check status.

       

      Thanks for your help.

       

      Bob Z.

       

      Message was edited by: bzumwalt on 3/3/14 2:02:00 PM CST
        • 1. Re: Problems with Mavericks and McAfee Internet Security for Mac
          tejaswi.s

          Hi Bob,

           

          Please try the bellow mentioned steps so that we can check if it is working

           

          1. Select Go,
          2. Now click go to folder
          3. Type usr/local
          4. Check if you find any folder like McAfee
          5. If found open the folder
          6. Now check if you find any file like UninstallMSC
          7. When you open the file it will popup a terminal window
          8. Type your MAC password. { Note : Password will not be visible }
          9. Once the uninstallation is over please restart your mac and install McAfee and check if the real time scanning is working.


           

          Regards,

          Tejaswi

          • 2. Re: Problems with Mavericks and McAfee Internet Security for Mac
            bzumwalt

            Thanks Tejaswi, but the only things found in usr/local were folders named SiteAdvisor and Supportability. UninstallMSC was not found.

            • 3. Re: Problems with Mavericks and McAfee Internet Security for Mac
              pcafee

              Hello there I have the same issue. And i am getting following upon running uninstallmsc from terminal

               

              + sudo sh /usr/local/McAfee/uninstallMSC ''

              Error: Config file does not have uninstaller file path.

              + '[' RTW '!=' Eval ']'

              + rm -rf '/Library/Preferences/.com.mcafee*'

              + rm -rf '/Library/Preferences/.com.McAfee*'

              + for id in '"com.mcafee.mscui"' '"com.mcafee.ssm.fmp"'

              + pkgutil --forget com.mcafee.mscui

              No receipt for 'com.mcafee.mscui' found at '/'.

              + for id in '"com.mcafee.mscui"' '"com.mcafee.ssm.fmp"'

              + pkgutil --forget com.mcafee.ssm.fmp

              No receipt for 'com.mcafee.ssm.fmp' found at '/'.

              + '[' '' = all ']'

              + '[' 1 -eq 0 ']'

              + rm -rf '/Library/Receipts/McAfee-*'

              logout

               

              [Process completed]

              • 4. Re: Problems with Mavericks and McAfee Internet Security for Mac
                leep

                On my Mac book Pro   running OS X 10.9.2

                 

                Real  time scanning not working and getting the following pop up error ;

                 

                 

                System extension cannot be used

                The system extension “/usr/local/McAfee/AntiMalware/Extentions/Virex.kext” was installed improperly and cannot be used. please try reinstalling it, or contact the products vendor for na update.

                 

                 

                 

                uninstalled going through user/local then rebooted and tried to reinstall

                 

                but cannot reinstall from my online account ; error is

                 

                An Enterprise version of the product is already installed on your Mac. You cannot install McAfee  Internet Security upon the Enterprise version.

                 

                 

                I now have no Mcafee protection on my Mac!!!

                • 5. Re: Problems with Mavericks and McAfee Internet Security for Mac
                  Bryan Harris

                  I had this issue, here is how I got it working.

                   

                  sudo /Library/McAfee/cma/uninstall.sh

                  sudo mv /Library/Launch*/com.mcaf* /tmp

                   

                  ### reboot laptop

                   

                  sudo rm -rf /usr/local/McAfee

                   

                  Then I reinstalled both the agent and the Endpoint thing entirely from scratch.  Now the virus scanner and the malware scanner are working again.

                   

                  V/r,

                  Bryan

                  • 6. Re: Problems with Mavericks and McAfee Internet Security for Mac
                    thiffaultcanada

                    I have tried all these things and they either did not work or the files and folders are not there. I am still getting the error that the install already exists.

                     

                    any other hints?