1 2 Previous Next 11 Replies Latest reply on Oct 9, 2014 7:31 AM by frank_enser

    Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247

    ino

      Hi there,

       

      We recently installed VSE Patch 8.8.0.1247 on our ePO 5.1 installation and noticed that some of our systems don't even have the patch 8.8.0.1128 (Hotfix 3) installed, although they are frequently and recently communicating with the ePO server and all have a client task  to deploy VSE 8.8.0.1247 (Hotfix 4).

      All of the affected systems seem to be Windows 7, Windows XP or Windows Server 2008 SP2. Later devices with Windows 8, Windows 8.1 or other Server versions seem to be just fine.

      DAT and Engine versions seem to be fine on the affected systems.

       

      What can we do to track down the issue?

       

      Thanks for any help.

        • 1. Re: Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247
          frank_enser

          Hi,

           

          thats no issue. Patch 3 is exclusively for Windows 2012/Windows 8 and does not install on anything lower. See PD24224.

           

          Nachricht geändert durch frank_enser on 20.02.14 06:41:01 CST
          • 2. Re: Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247
            gtip

            I have the same problem. Did you ever find a solution? All my devices are window 7 and yet they report as having virusscan 8.8.0.975.wrk (which from everything I have read should not install on anything except windows 8), but they will not update to 8.8.0.1247.

            • 3. Re: Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247
              frank_enser

              Hi,

               

              it is a completely different question why your .975 (Patch 2) do not update to .1247 (Patch 4).

              So you must give more information:

              • Do you have a update task which involves VSE Patch 4?
              • Has the task been deployed to your endpoints?
              • Does your agent log at the endpoint say anything about that task (p.e. does the update start at all, error code, ...)?

               

              Regards,

              Frank

              • 4. Re: Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247
                gtip

                Hi Frank,

                I asked the question here as it appeared to me to be the same issue.

                We have a task which has been successfully deployed on all endpoints except those with patch 2.

                 

                 

                This is the log form an unsuccessful update:

                 

                2014-10-09 12:37:38.560I#4496Sched<<--RunTask
                2014-10-09 12:37:38.563I#2720SchedDeploy VS 8.8 including patch 4 - Last run time(local) is Thu Oct 09 12:37:24 2014
                2014-10-09 12:37:38.563I#2720Sched
                2014-10-09 12:37:38.564I#2720SchedEnd of invoking the task
                2014-10-09 12:37:39.114I#2152ManagePlugin registry change detected
                2014-10-09 12:37:39.116I#2588LpcConnMgrProcessing health check request
                2014-10-09 12:37:39.117I#2588MsgQueueRunning garbage collection
                2014-10-09 12:37:39.118I#2588MsgQueueAdding channel for message queue 1496913389 extended software id hash 474185642 client id 2088364951
                2014-10-09 12:37:39.118I#2588MsgQueueChannel added to message queue successfully
                2014-10-09 12:37:39.119I#2588LPCRegistering new LPC process
                2014-10-09 12:37:39.119I#2588LPCSuccessfully registered new LPC process, CMNUPD__3000:DEFAULT:3492
                2014-10-09 12:37:39.183I#4924UecReceived ipc data from mue
                2014-10-09 12:37:39.183I#4924UecProcessing progress information
                2014-10-09 12:37:39.183i#4924UpdaterChecking update packages from repository ePO_ASEPO.
                2014-10-09 12:37:39.184I#4924UecDone processing progress information
                2014-10-09 12:37:39.263I#4924UecReceived ipc data from mue
                2014-10-09 12:37:39.263I#4924UecProcessing progress information
                2014-10-09 12:37:39.263i#4924UpdaterInitializing update...
                2014-10-09 12:37:39.264I#4924UecDone processing progress information
                2014-10-09 12:37:39.269I#4924UecReceived ipc data from mue
                2014-10-09 12:37:39.269I#4924UecProcessing progress information
                2014-10-09 12:37:39.269i#4924UpdaterVerifying catalog.z.
                2014-10-09 12:37:39.270I#4924UecDone processing progress information
                2014-10-09 12:37:39.296I#4924UecReceived ipc data from mue
                2014-10-09 12:37:39.296I#4924UecProcessing progress information
                2014-10-09 12:37:39.297i#4924UpdaterExtracting catalog.z.
                2014-10-09 12:37:39.297I#4924UecDone processing progress information
                2014-10-09 12:37:39.321I#4924UecReceived ipc data from mue
                2014-10-09 12:37:39.321I#4924UecProcessing progress information
                2014-10-09 12:37:39.321i#4924UpdaterLoading update configuration from: catalog.xml
                2014-10-09 12:37:39.322I#4924UecDone processing progress information
                2014-10-09 12:37:40.394I#4924UecReceived ipc data from mue
                2014-10-09 12:37:40.395I#4924UecProcessing progress information
                2014-10-09 12:37:40.395i#4924UpdaterVerifying VSE880Det.mcs.
                2014-10-09 12:37:40.396I#4924UecDone processing progress information
                2014-10-09 12:37:40.441I#4924UecReceived ipc data from mue
                2014-10-09 12:37:40.442I#4924UecProcessing progress information
                2014-10-09 12:37:40.442i#4924UpdaterVerifying VSE880Det.mcs.
                2014-10-09 12:37:40.442I#4924UecDone processing progress information
                2014-10-09 12:37:40.489I#4924UecReceived ipc data from mue
                2014-10-09 12:37:40.489I#4924UecProcessing progress information
                2014-10-09 12:37:40.489i#4924UpdaterUpdate Finished
                2014-10-09 12:37:40.490I#4924UecDone processing progress information
                2014-10-09 12:37:40.494I#4924UecReceived ipc data from mue
                2014-10-09 12:37:40.502I#4924UecReceived ipc data from mue
                2014-10-09 12:37:40.502I#4924UecProcessing event information
                2014-10-09 12:37:40.502I#4924muemsgCalling HandlePostpone with TaskID:  UpdateState: 1
                2014-10-09 12:37:40.502I#4924muemsgCalling m_pUpdateInfoCallback->HandlePostpone
                2014-10-09 12:37:40.502I#4924UpdaterCMcAfeeUpdate::HandlePostpone() Entered taskid: {6EB3A532-D972-4370-860D-C143CE4B131F}
                2014-10-09 12:37:40.502I#4924UpdaterFinished calling GetPostponeMins
                2014-10-09 12:37:40.502I#4924UpdaterCMcAfeeUpdate::HandlePostpone() Exit
                2014-10-09 12:37:40.502I#4924muemsgFinished Calling m_pUpdateInfoCallback->HandlePostpone
                2014-10-09 12:37:40.502I#4924muemsgFinished Calling HandlePostpone
                2014-10-09 12:37:40.502I#4924UpdEventsDeInitializing Event Interface
                2014-10-09 12:37:40.502I#4924UpdEventsEpoEventInf Interface: Deinitialization succeeded.
                2014-10-09 12:37:40.503I#4924muemsgUpdater session finish state value =1
                2014-10-09 12:37:40.509I#4924UecDone processing event  information
                2014-10-09 12:37:40.512I#2588LpcConnMgrProcessing message queue disconnection request
                2014-10-09 12:37:40.513I#2588LPCUnregistering LPC process
                2014-10-09 12:37:40.513I#2588LPCSuccessfully unregistered LPC process, CMNUPD__3000:DEFAULT:3492
                2014-10-09 12:37:40.513I#4924UecTerminating thread
                2014-10-09 12:37:40.533I#5440UecTerminating ipc channel
                2014-10-09 12:37:40.533I#5440ipcchannelAborting IPC object connection
                2014-10-09 12:37:40.533I#5440ipcchannelClosing IPC connection
                2014-10-09 12:37:40.533I#5440ipcchannelClosing IPC server
                2014-10-09 12:37:53.500i#2716SchedThe task Deploy VS 8.8 including patch 4 is successful
                2014-10-09 12:37:53.501i#2716SchedScheduler: Task [Deploy VS 8.8 including patch 4] is finished
                2014-10-09 12:37:53.502I#2716Sched>>--ReleaseTask
                2014-10-09 12:37:53.502I#2716ManageReleasing Task Cookie=59277144
                2014-10-09 12:37:53.503I#2716Sched<<--ReleaseTask
                2014-10-09 12:37:53.503I#3356AgentRunNow task Deploy VS 8.8 including patch 4 is failed
                2014-10-09 12:37:53.504I#3356AgentRunNow task Deploy VS 8.8 including patch 4 is finished
                2014-10-09 12:37:53.504I#3356Sched>>--CSchedule::DeleteTask
                2014-10-09 12:37:53.504I#3344AgentAgent Data Channel work wakeup, processing items
                2014-10-09 12:37:55.505i#3344AgentSending the next batch of 1 data channel items
                2014-10-09 12:37:55.505I#3316AgentStarted processing a package..
                2014-10-09 12:37:55.507I#3316SpiPkgrUsing sequence number 1270
                2014-10-09 12:37:55.522i#3316AgentAgent communication session started
                2014-10-09 12:37:55.523I#3316AgentPackage type is MsgUpload
                2014-10-09 12:37:55.523i#3316AgentAgent is connecting to ePO server
                2014-10-09 12:37:55.530I#3316imutilsTrying with site: 172.16.121.87:80
                2014-10-09 12:37:55.531I#3316naInetHTTP Session initialized
                2014-10-09 12:37:55.531I#3316imsiteUpload from: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130573282755060000_1527784631.spkg
                2014-10-09 12:37:55.531I#3316imsiteUpload response target: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130573282755230000_1788059258.spkg
                2014-10-09 12:37:55.806I#3316imsiteNaInet library returned code == 13
                2014-10-09 12:37:55.806I#3316naInetHTTP Session closed
                2014-10-09 12:37:55.808i#3316AgentNo package received from ePO Server
                2014-10-09 12:37:55.809i#3316AgentAgent communication session closed
                2014-10-09 12:38:08.493i#2716SchedThe task Deploy VS 8.8 including patch 4 is deleted (ID={6EB3A532-D972-4370-860D-C143CE4B131F})
                2014-10-09 12:38:08.494I#3356Sched<<--CSchedule::DeleteTask

                I am pretty new to this, so if you can offer any advice it would be appreciated,

                 

                Cheers,

                 

                Gary

                • 5. Re: Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247
                  justav

                  Gary, have just a few PC's in my park with the same issues. got these few stuburn machines that keep doing my head in.

                  I know already that reinstalling the Agent on them has absolutely zero effect. So that I could exclude.

                  This is definitely the installer of the VSE I am afraid.

                  Cheers,

                  Maurice

                  • 6. Re: Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247
                    frank_enser

                    Ok, you try to install VSE 8.8. with patch 4 OVER an already installed patch 2?

                     

                    Two possibilities:

                    1. first deinstall VSE 8.8, that deploy VSE 8.8 Repost with Patch 4.
                    2. download and check in (into Master Repository) Patch 4 (not the complete installation file, only the patch!) and create an update client task witch deploys the Patch 4 only.
                    • 7. Re: Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247
                      justav

                      tried both options, for now only 1 worked locally on ripping it off via the Add/Remove Programs. Uninstall job out of ePO didnt do the trick either which is pretty sad.

                      Somewhere some bits fell I suppose, quickest solution for me was just use option 1 on a handfull of clients out of 18k, which is not too bad either I think.

                      It just can happen to any product => but it happens

                      • 8. Re: Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247
                        gtip

                        Thanks again Frank, I will look into it form that angle.

                        justav I appreciate the input.

                         

                        Will keep you posted if I find anything further.

                        • 9. Re: Systems with VirusScan 8.8.0.975.Wrk and 8.8.0.975.Srv don't update to 8.8.0.1128 or 8.8.0.1247
                          frank_enser

                          If you have more than a handful of those bad behaving systems, you can contact McAfee Support for the "VSE Cleaner" tool, and with a little help of EEDK you can automate the force removal of VSE via ePO. Works like a charm


                          Regards,
                          Frank

                          1 2 Previous Next