9 Replies Latest reply on Dec 24, 2014 1:18 PM by rcavey

    ESM Rebuilding

    oceballos

      Dears Colleagues

       

       

      I´m having problem deploying a Combo VM4 9.3.1 Nitrsolution to my ESX 5.1

       

      The history is as follows:

       

      - I had a Nitro 9.3.1 succesfully deployed in my Lab

      - One day I tried to log in but it was impossible, through ssh ok

      - After trying serveral things I decied to reboot

      - The consecuence is that the ESM put itself in rebuilding

      - I let the rebuilding state during 2 days.

      - Finally I decided to deleted and deploy a new one ( it was impossible to stop de server  only reboot)

      - Once the ESX was empty (datastore) of any Nitro VM  I tried to deploy the new one

      - !! Once the new VM started, the ESM is in rebuilding again!!!!

       

      Any idea?

       

      Thanks in advance.

        • 1. Re: ESM Rebuilding
          dcobes

          Not the answer you probably want, but best recommendation is to contact Support. You will most likely have to manually rebuild a few tables. There are times where your database will get stuck in a rebuild loop, in those cases the affected tables need to be moved to a temp location and instruct the system to rebuild those tables. The database rebuild usually occurs if you reboot the system incorrectly (or from a system fault eg. kernel panic), or right after an upgrade.

           

          -d

          • 2. Re: ESM Rebuilding
            oceballos

            THanks a lot dcobes for your reply, however I can´t understand how if I try to deploy a new Nitro from scratch happens the same....I´m think it is probably something in the ESX environment, not enough space for example...

            • 3. Re: ESM Rebuilding
              lichnt

              you can do guide :

              SSH to ESM:

              -step1: service cpservice stop

              Then once you're back at a prompt, confirm it has stopped by typing:

              - step 2 : ps auxf | grep cpservice

              You should only see your grep command returned. Then type:

              - step 3: cd /usr/local/ess/data/

              We will make a few backups of some database files before moving them:

              -step 4 :

              mkdir old_files

              cp ngcp.cf* old_files

              rm ngcp.cfg

              rm ngcp.cfd

              We will now start cpservice back up and a rebuild will take place if necessary:

              - step 5 : service cpservice start

              - if need can reboot ESM

              Then reboot acess ESM , it rebuid 5' , you wait, finish 5' you can login .

              • 4. Re: ESM Rebuilding
                oceballos

                THanks for your support Lichnt

                 

                However I can´t even log into the vm by ssh.....something really strange. Fortunatetly McAffe has send me a new fresh copy to start over. Let´s see if I can have further support to solve this mistery ;-)

                 

                I´ll keep yuou post it with my findings..

                 

                Thanks again.

                • 5. Re: ESM Rebuilding
                  saosiner

                  Thanks so much for your help. Lichnt

                  • 6. Re: ESM Rebuilding
                    akekung

                    Thanks Lichnt

                    (I have problem same oceballos)

                    • 7. Re: ESM Rebuilding
                      pepelepuu

                      Sounds like a new emerging bug: Bug 37936

                      Ver 9.4.3 Build 20141118

                       

                      One or more of the following we identified symptoms:

                      • ESM Browser is not responding
                      • Unable to stop cpservice. Attempted to stop in on Friday, and it was still stopping the following Monday Morning
                      • Unable to reboot
                      • even small databases always need to rebuild. Afterwards, unresponsiveness is encountered again

                       

                      When we've gotten to the point whereas, until there a fix, per McAfee Engineering, when we encounter this we have to kill cpservice

                      Open HTOP and note the PID of cpservice

                      - kill -9 %PID%

                       

                      By the way, keep an eye on the error log: (This will give you more relevant information than messages.

                      less /usr/local/ess/data/NitroError.Log

                      • 8. Re: ESM Rebuilding
                        streamer

                        Your ESM is not PoC! isn't? If so maybe you have TimeBomb version of ESM. I faced same problem twice while working on PoC ESM.

                        • 9. Re: ESM Rebuilding
                          rcavey

                          PoC??   Is that Proof of Concept?? sorry that is not a familiar one to me.   That wold suck if they offered that in an official download link... LOL