0 Replies Latest reply on Jan 27, 2014 1:35 PM by itsec

    ePO 5.1 installation SQL setup error: "unable to connect using the information you provided" - my solution

    itsec

      Hi,

       

      Just thought I would post my solution for this error as I have had a it a few times during my testing and live setup and it had me somewhat puzzled!

       

      TL:DR:               Check C:\Users\,username>\AppData\Local\Temp\2\McAfeeLogs\EPO510-Install-CustomAction  for a line  " Password has invalid characters in it."   > change password to something less complex

       

       

      Long version:

       

      My initial test setup was on a W2k8 vm using a local instance of sqlexpress.  Initially this installed fine however something happened so I started again - a total reinstall.

      This time around, I got stuck when trying to create the sql express database.  I was getting an error "unable to connect using the information you provided" .

      I then installed a full version of sql 2008  (locallay) yet I still got the same error.

       

      In both instances I was using mixed auth with a windows user a/c.

      Eventually I created a new SA a/c and managed to succesfully create the database using this sql a/c.

       

      I have just gone to create the same in our live environment but using a separate existing SQL instance and a new install of ePO 5.1 on a W2k8 vm and I received the same error.

      In all instances I was at first using my windows admin account.  I then created a sql login, tested it was ok and tried that.  Again it failed.  Interestingly I had used the same password for both my sql and windows a/c.

       

      I did a bit of digging and checked  a log file:

      C:\Users\,username>\AppData\Local\Temp\2\McAfeeLogs\EPO510-Install-CustomAction

       

      This had a line " Password has invalid characters in it."

       

      Both accounts had strong passwords using alphanumierc characters and special charachers such as *

      Although this worked (and is supported by SQL) when logging into SQL Mgmt Studio, there's obviously some issue with the installer.

       

      hope this helps someone