Why not 5.1 ?
probably the release notes of 5.x will tell you what prerequisites are. Don't forget to run the upgradetool!
If you use EEPC 6.x or 7.x you'll have to go up to 4.6.7 first in order to support the new MDE 7.1 extension, then upgrade to 5.1.0. If not, you should be able to go up directly to 5.1.0. Be aware of extension support: