6 Replies Latest reply on Dec 27, 2013 2:53 AM by sveerara

    myAgtSvc.exe stops when running update

    joe557

      Recently installed SAAS with Antivirus/Spyware/Browser protection.  Installed on Windows 8.1.  I cannot run an update.  When I do, the myAgtSvc.exe service stops running and the update stops immediately.  I've run the cleanup tool and re-installed, and still doesn't work.  When I check https://www.mcafeeasap.com, it says I have agent 6.0.0 installed, no patch 1 or 2.  Can someone help with this? 

        • 1. Re: myAgtSvc.exe stops when running update

          Hi,

           

          Please let me know the installation method which you have tried.

           

          Regards,

          Sathish.V

          • 2. Re: myAgtSvc.exe stops when running update
            joe557

            I've used the install directly to this machine method, which by the way, wouldn't work using Internet explorer 11 in windows 8.1.  I kept getting an error message about the file having been moved or renamed. 

             

            Anyway, I used Firefox after this and got the download to work.  I then ran the removal tool since I was having the problem of updating due to the myagtsvc service stopping.  After the removal tool, I rebooted, and then ran the silent install method using elevated command prompt.  Yes, I am logged in to the computer with an admin account. 

            • 3. Re: myAgtSvc.exe stops when running update
              joe557

              For the silent installation attempt, I followed these directions:  https://community.mcafee.com/thread/52024

              • 4. Re: myAgtSvc.exe stops when running update
                joe557

                I've since removed the installation using the mvsuninst.exe removal tool, and have rebooted.  It doesn't matter which installation method I try, I get the same issue.  MyAgtSvc.exe service stops when trying to do an update.  During the installation process, the Mcshield icon in the task tray appears with an exclamation mark, and then nothing else.  The service never starts up on it's own. 

                 

                Again, this is a new windows 8.1 machine, x64.  I even tried doing the last install with Windows Firewall off and disabled. 

                 

                Really appreciate any help you can provide.

                • 5. Re: myAgtSvc.exe stops when running update
                  joe557

                  I've been trying different things all day long.  I just ran a silent install but left out the "F" and "B" switches so that only the antivirus protection would install.  This seemed to work.  Afterwards, I rebooted and did a manual update, and it completed sucessfully.  I then moved the computer name into the correct policy and group name in the SAAS dashboard utility.  Ran another manual update, and the browser protection software then started to download and install.  During this process, two error messages were recieved:

                   

                  The first was a pop-up  "Error in CreateSecureObject:  Automation server can't create object"

                   

                  Second error message was within the update window and said:  "Unable to create reboot Object.  Agent Service may not be running properly"

                   

                  At this point, the install timed out, but it was nearly complete so I closed the window and did a reboot.  After reboot and ran the update again and it completed successfully. 

                   

                  I believe there is a problem with the installation package or the way the browser protection component is installed.  I hope McAfee looks in to this and that my countless hours of troubleshooting the last 24 hours helps someone else.

                  • 6. Re: myAgtSvc.exe stops when running update

                    Hi,

                     

                    Thank you for the detailed information.

                     

                    We would recommend you to call our Technical Support directly to resolve the issue, please use the below link to get the right number based on the region.

                     

                    http://www.mcafee.com/in/about/contact-us.aspx#ht=tab-techsupport

                     

                    Regards,

                    Sathish.V