6 Replies Latest reply on Dec 24, 2013 11:10 AM by feeeds

    ePO Upgrade Fails

    petguy

      I am trying to upgrade our current ePO Server from 4.5.7 to 5.0.1. I have followed all the upgrade documentation and made sure that all our installed products are supported with this new version. However, when I try to run the install, it fails with just the message saying that the install process was interrupted and that I should try again later. I'm having a hard time trying to figure out what is going on here since all of the prerequisites are being met. Does anyone have any ideas on what is causing this?

       

      If you would like more information just let me know and I'll provide it.

       

      Thanks in advance for the help.

        • 1. Re: ePO Upgrade Fails
          JoeBidgood

          There should be a mcafeelogs folder, probably in the temp folders for your user, containing amongst others an ePO501-install-msi.log.

          Can you zip up the entire folder and any subfolders and attach them here? We can take a look.

           

          Thanks -

           

          Joe

          • 2. Re: ePO Upgrade Fails
            petguy

            Thanks for the reply.

             

            I have attached the zip file containing the install logs. I was actually looking through those yesterday after I posted my original response and I notice that towards the end it says that the install process cannot connect to the local sql server. That doesn't make any sense because I know I am using all the correct settings and that I have never had issues connecting to the database in the past. Does 5.0 do something different that I don't know about?

             

            Let me know if you need anything else. Thanks again for the help. I appreciate it.

            • 3. Re: ePO Upgrade Fails
              JoeBidgood

              Okay - you're correct, in that the installer is trying to get some data from the existing ePO 4.5 database, and it's failing to do so. There could be a number of reasons for this.

              If you open the config-auth page in your ePO 4.5 server, do you see the DB instance name specified? Possibly as MSQLSERVER? If so, remove this by clearing the box, and use the Test button to see if you can still connect to the DB. If you can, hit the Apply button, restart the ePO services and make sure you can still log into the console, and if this all works, try the upgrade again.

               

              HTH -

               

              Joe

              • 4. Re: ePO Upgrade Fails
                JoeBidgood

                Just to update this - I was able to reproduce your problem by putting MSSQLSERVER in the db properties for a 4.5 server, so I'm hopeful that this is the problem and you should be able to fix it quite simply

                 

                HTH -

                 

                Joe

                • 5. Re: ePO Upgrade Fails
                  petguy

                  Hi Joe,

                   

                  Sorry for my late reply. I was out of town for the Thanksgiving holiday.

                   

                  I just tested what you suggested and it worked!! Thank you so much for this. I was banging my head against the wall with this issue. I will be sure to remember to do this little fix the next time I am upgrading our ePO server.

                   

                  Thanks again.

                  • 6. Re: ePO Upgrade Fails
                    feeeds

                    I am having the same issue upgrading my epo 4.65 server. The logs specified above are not being created, so it's rather frustrating trying to figure out what is wrong. Any other things I can check ?