6 Replies Latest reply on Oct 28, 2013 10:23 AM by joshhough

    ePolicy Orchestrator 5.0.1 Fails to Install

    joshhough

      Hi,

       

      I've just purchased McAfee Complete Data protection for a care company who use remote laptops during the weekend for On call managers. Due to the nature of the staff i really brought it for the encryption, but i figured installing the EPO might be worth it.


      I've installed a new instance of SQL Server 2008 R2 Express SP1 but every time i try and connect to it (even after restarting the server) it says that the database is not the required version. Does it not install on SQL server Express? As the installation guide implies it will install. What things could i check? The server is SBS 2011.

       

      And really, is EPO required or should i just install the encryption on the laptops.

       

      Thanks,

       

      Josh

        • 1. Re: ePolicy Orchestrator 5.0.1 Fails to Install
          rgc

          Hi,

           

          If you have purchased the product recently, and then I assume this is complete with latest versions of the product and point products. If yes,

          Then EEPC product 7.0.2 supports with EPO 5.x and moreover, these Encryption products will work only with epo managed.

           

          So, here epo plays the important role for the encryption software.

           

          For more queries about EEPC, please post to EEPC forum.

           

          Comming back to epo installation, If the install fails stating that "database is not the required version".

          The version sql 2008 R2 express or later is supported as per Kb51569 and direct link as below.

           

          https://kc.mcafee.com/corporate/index?page=content&id=KB51569

           

          If this is new installation, please make sure the instance name and open the sql configuration manager and protocols for the instance name and check the

          Name pipes and TCP/IP protocol is disabled, ( first time install by default disabled), enable it and restart the sql service ( Mandatory), which it helps to generate the dynamic port for communication.

           

          I'm assuming this could be one of the reason, which the installation is not able to continue or, I need the screenshot by the time of installation says the database issue.

           

          Which helps me to know, the installation is reaching till the database credentails page or it failed before that.....

           

          Note: Make sure, you dont have multiple versions of sql installed.


           

          Regards,

          RGC

          • 2. Re: ePolicy Orchestrator 5.0.1 Fails to Install
            Mohana

            Yes, that is good information from RGC.

             

            Check installing SQL 2008 express edn. sp2

             

            The database account you are using for installation must have been granted the server‑role of dbcreator on the targetSQL Server.

            Please check the requriments of SQL refer the KB:

            http://kc.mcafee.com/corporate/index?page=content&id=KB75766&actp=search&viewloc ale=en_US&searchid=1382949781939

             

            If you can provide screenshot of the error you are getting that will help us to identify the cause.

             

            Regards,

            Mohan

            • 3. Re: ePolicy Orchestrator 5.0.1 Fails to Install
              joshhough

              Hi,

               

              There are multiple instances of SQL server due to there being databases (in particular the database that runs the care software, plus those auto installed by SBS2011 such as Sharepoint) but there are not multiple installations.

               

              I have tried with the built in SA user account as well as the administrator account, i've also added another user and given them specifically the roles requried as per that guide and it has not made a difference. Please see attached screenshot of the error. I haven't tried installing SP2 - would you advise i try this?

               

              The key thing i want this software for is the drive encryption on boot for the laptops that are used out of the office.

               

              Thanks,

               

              Josh

              epo.png

              • 4. Re: ePolicy Orchestrator 5.0.1 Fails to Install
                Mohana

                select the desired database instance name; I think it should not include -.

                 

                Can you change with simple one and check.

                 

                 

                Regards,

                Mohan

                • 5. Re: ePolicy Orchestrator 5.0.1 Fails to Install
                  Laszlo G

                  Hi joshhough, you said you created the new SQL Express instance called McAfee, did you also create the database (ePO_SCC-1) or the ePO installer was able to create it?

                   

                  You can not only check the instance version but also the databse version. I don't thnik this should be the cause but you can right-click the ePO_SCC-1 database and run this query to check its version:

                   

                  SELECT SERVERPROPERTY('productversion'), SERVERPROPERTY ('productlevel'), SERVERPROPERTY ('edition')

                  • 6. Re: ePolicy Orchestrator 5.0.1 Fails to Install
                    joshhough

                    Hi,

                     

                    Installing SP2 resolved the issue.

                     

                    Thanks for your help,