3 Replies Latest reply on Sep 26, 2013 5:34 PM by SafeBoot

    Invalid UEFI Architecture

    elleryweber

      Hello,

       

      We are trying to get EE running on a Dell Latitude 6430u running Windows 8.1 Enterprise.

       

      The OS was installed with GPT/UEFI. We were able to deploy the EEAgent out, but it fails with the following error:

       

      ------------- <snip> ---------

       

      2013-09-26 19:38:15,675 INFO    PcSystem                             Beginning activation. Current status is inactive.

      2013-09-26 19:38:15,690 INFO    DiskManager                          Created EE partition of size 74448896

      2013-09-26 19:38:16,503 INFO    PcSystem                             Abandoning activation

      2013-09-26 19:38:17,330 ERROR   PcSystem                             Early activation error: [0xEE000007] Invalid UEFI architecture

      2013-09-26 19:38:17,330 ERROR   StatusService                        Preboot File System (PBFS) creation failed

       

      ------------- <snip> ---------

       

       

       

      I did see that EEPC requires UEFI version 2.3.1 or later. I'm running the latest Dell BIOS version (A06 9/6/2013). I can't find anywhere documented how I can confirm the version of UEFI installed, but when I updated the BIOS I found the following information which may be relevant:

       

      A06 UPDATE:

           SYSTEM BIOS: 106

           EMBEDDED CONTROLLER: A04

           GIGABIT ETHERNET: 0.D.3

           LEGACY VIDEO OROM: 2.1.3.7

           LEGACY RAID OROM: 11.2.0.1527

           INTEL MANAGEMENT ENGINE UPDATE: 8.1.40.1416

           ACPI OS SUPPORT: 0.0.0.1

           INTEL ANTITHEFT: 3.0.0.18

           SECURE BOOT SUPPORT: 2.3.1.C

       

       

      Is there any additional documentation on the error above?

       

       

      Thanks,

       

      Ellery Weber