Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
627 Views 4 Replies Latest reply: Sep 13, 2013 1:22 PM by d.naraine RSS
d.naraine Newcomer 16 posts since
Dec 12, 2012
Currently Being Moderated

Sep 9, 2013 8:32 AM

Failed to uninstall DLPE/HDLP

A mach ine in our environment got DLPE installed, but it was not supposed to recieve it. I have attempted to run a client task to uninstall, but it fails to uninstall the product. I have tried the following:

 

  1. Removed the DLPE tag from the machine, moved from one container to the uninstall container, and woke up the machine's McAfee Agent – which, of course, did nothing.
  2. Disabled the Uninstall task on the machine, and woke up its McAfee Agent again – which, as expected, didnothing.
  3. Re-enabled the Uninstall task on the machine, and woke up its McAfee Agent again.  The machine's McAfeeAgent log showed that the Uninstall task was modified, and then ran this task.  However, the uninstall process appears to have failedbecause its McAfee Agent log returned “Error occurred while uninstalling DLPAGENT9200” and “Checking for software conflicts”.

 

I am currently pending a test with the following to see if this solves my answer:

 

     1. Locate the system experiencing the uninstall issues with HDLP in the ePO system tree.

     2. Place a checkmark next to it, then go to"Actions" > "Agent" > "Run Client Task Now"

     3. Then select McAfee agent > Product Deployment > Create New Task

     4. Under products and components selectMcAfee Data Loss Prevention 9.2 (or the version you were originally trying toremove from the machine)

     5. Select "Install" for theaction.

     6. Click "Run Task Now" to complete the task. Once the install completes, reboot the machine.

     7. Once the machine has booted, confirm that HDLP is installed, and repeat steps 1-6 , except this time, select "Uninstall" under the action in the client task.

Originally when this issue started, DLPE was under Window's Add/Remove programs listing. When I clicked "Remove" within this window, the uninstaller would complain it couldn't find a .msi uninstaller file. I ran a cleanup utility and was able to remove it from the Add/Remove programs listing, but this did not remove the software.

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points