Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
1141 Views 7 Replies Latest reply: Jul 30, 2013 9:40 AM by fitzgerac RSS
hb21l6 Newcomer 3 posts since
Jul 25, 2013
Currently Being Moderated

Jul 25, 2013 4:25 AM

EPO 4.6 - Table epoAvertLatestUpdates empty?

Hello all,

 

I'm writing a new (all in one) automated systems check application that covers many different systems that we have in our business.

One of the checks is EPO..

 

In the previous 4.5 version, - I could query two tables to return our Latest DAT version, Avert's Latest DAT version and date/time it was polled.

 

 

SELECT * FROM dbo.EPOMasterCatalog WHERE ProductName='DAT' AND Branch='Current'

SELECT * FROM epoAvertLatestUpdates

 

In the new version 4.6 -  the EPOMasterCatalog still holds the our available DAT version, but EPOAvertLatestUpdates is empty??

 

Using the EPO web portal, the master repository tab shows the My Repository and Avert versions..

 

Please can anyone tell me if, EPO still stores this information locally on the Database, and where.. Or is it polled from the Avert servers and not held locally.

 

If it is polled each time from the Avert servers, how can I get the latest DAT version number from the servers.

 

Thanks in advance..

 

Dave

  • Tristan Veteran 790 posts since
    Dec 8, 2009
    Currently Being Moderated
    1. Jul 25, 2013 5:38 AM (in response to hb21l6)
    Re: EPO 4.6 - Table epoAvertLatestUpdates empty?

    I run 4.6.1 build 1192 and i get the following if i run your SELECT * FROM epoAvertLatestUpdates SQL statement from the OSQL command prompt

     

     

    -==============================

    type                                                                         

                                                                              

                                                                              

                                           

        version                                            release_date    

    ------------------------------------------------------------------------------

        -----------------------------------------------------------------------

        -----------------------------------------------------------------------

        -----------------------------------

        -------------------------------------------------- ----------------

    DAT_32                                                                       

                                                                              

                                                                              

                                           

        7145.0000                                          2013/07/23      

    ENGINE_32                                                                    

                                                                              

                                                                              

                                           

        5400.1158                                          2009/08/26      

     

    (2 rows affected)

    --===========================================

     

    I know it's a bit messy but basically the table isn't empty.

  • Laszlo G Veteran 1,213 posts since
    May 23, 2007
    Currently Being Moderated
    3. Jul 25, 2013 6:28 AM (in response to hb21l6)
    Re: EPO 4.6 - Table epoAvertLatestUpdates empty?

    I just checked the SQL query Tristan told on my SQL Management Studio Express 2005 and I got this:

     

    DAT2.PNG

     

    But on my avertlabs dashboard I have this:

     

    DAT1.PNG

     

    So it looks like the avertlabs data is not stored anymore under this table?

     

    As for the 7007 DAT file appearing at the query result this can match the patch 5 o 4 upgrade to ePO 4.6 (now I'm on ePO 4.6.6)

  • Tristan Veteran 790 posts since
    Dec 8, 2009
  • rackroyd McAfee Mentor 954 posts since
    Feb 3, 2010
    Currently Being Moderated
    6. Jul 25, 2013 8:00 AM (in response to hb21l6)
    Re: EPO 4.6 - Table epoAvertLatestUpdates empty?

    Try:

     

    SELECT ProductName, Version FROM EPOAvertContentUpdates WHERE ProductID = 'VSCANENG1000' OR ProductID = 'VSCANDAT1000'

     

    This seems to produce similar results except for the date, which is not on the avertlabs dashboard anyway.

  • fitzgerac Newcomer 10 posts since
    Mar 29, 2012
    Currently Being Moderated
    7. Jul 30, 2013 9:40 AM (in response to rackroyd)
    Re: EPO 4.6 - Table epoAvertLatestUpdates empty?

    I had the exact same problem as the original poster: We had a "HealthCheck" script that would query the EPO DB for the latest version of the DAT file. We used to get this version info from the epoAvertLatestUpdates table, but since DAT 6181, it doesn't look like EPO is using that table. As rackroyd suggested I changed our query to use EPOAverContentUpdates table, and everything is working great now.

     

    SELECT Version FROM dbo.EPOAvertContentUpdates WHERE ProductID = 'VSCANDAT1000'

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points