1 2 Previous Next 17 Replies Latest reply on Oct 7, 2013 2:41 PM by Peacekeeper

    After an update, McAfee disables all network drivers

      Hello,

      Following an update about two weeks ago, and since, I have not been able to access the internet with McAfee installed.

       

      My equipment:  Dell Inspiron 500M with XP SP3 (all WIN stuff is up to date) (yea, I know it is old... but it works, well used to work)

       

      I have tried a LOT of things, repeatedly, but the short story is:

      1) reinstalling the Dell drivers

      2) uninstaled McAfee and reinstalled McAfee

           a) of course, McAfee wouldn't really uninstall, it never does.    (I seem to have to go through this about twice a year)

           b)to completely get rid of McAfee I uninstalled it in control panel, then ran MCPR, then edited the registry to get rid of all traces.

      3)removed the HDD and scanned it using another computer with a competitor's product.

       

      I tried all this in normal mode, safe mode +networking, safe mode w/o networking

       

      The ONLY way I can get the windows drivers to stay usable is to have McAfee completely uninstalled (including ALL traces from registry) and then reinstall the network drivers from Dell. 

       

      The moment I do this, I get back a nice, reliable network connection.   Unfortunately, an unprotected one.

       

      The moment I reinstall McAfee, all network drivers are corrupted, the error indicates an invalid or missing registry key. (yes, the invalid registry key error was prior to me messing with the registry, and remains the same fail mode)

       

      I have been through multiple, painful, sessions with McAfee phone support and ATT phone support.  All of which were non-productive.  Nobody could actually walk me through the registry edits needed.   I finally just backed up the registry and then made the edits as would seem more logical.  (you can NOT just delete the word McAfee from the registry as tech support said, you have to delete the entire key at the correct level!!)

       

      Anyway, Short story, the laptop and network work fine as long as McAfee is completely removed from the system.   All issues arrose following an update that occurred about 2 weeks ago.  The issue is very repeatable.

       

      Any ideas?   I am starting to wonder if McAfee has chosen not to support anything over 8 years old. (the age of my dell driver)

       

      Thank you in advance,

      Libby

        • 1. Re: After an update, McAfee disables all network drivers
          Peter M

          Libby,

           

          There have been one or two reports of this happening here and we honestly haven't many ideas as to why it happens.  Your best advice is to contact Technical Support by phone, or online chat if phone isn't possible, it's linked under Useful Links at the top of this page and is free of charge.

           

          The only thing I can think of is to make sure that browsers have full permission in the Firewall > Internet Connections for Programs list.

           

          I have Total Protection 2013 installed only in an XP SP3 Virtual Machine, so not sure I can compare notes as it uses a virtual connection through it's host system, Vista, and in any case it works fine.

           

          Edit:  XP SP3 is suppported until its end of life next year, so that's not the reason.

           

          Message was edited by: Ex_Brit on 06/06/13 9:50:43 EDT AM
          • 2. Re: After an update, McAfee disables all network drivers

            Hi Peter,

             

            I was on the phone for a number of 3+ hour sessions.  The support person ended up sending me to the paid support line.  Somehow, that doesn't seem correct.

             

            I can make this come and go. 

             

            A  place to start would be to reply to me offline, and provide me all the registry entries your miniport driver reads, then I can go into my registry and take a peak.

             

            McAfee seems to create a miniport in the netory adaptors section for every adaptor that is already there.   It is in the creation of this miniport addition that I loose connection to the internet.  When I load McAfee, I have a connection for a short period of time, until something triggers the miniport to be added, and the miniport does not like a registry entry somewhere.

             

            If you can send me the list of registry entries and what the driver is looking for in those entries, I can try to fix this on my laptop and will share the info.  It would be useful to include in your MCPR program.  Also, it would be useful if MCPR would eliminate all McAfee registry entries, not just a select few.

             

            The drivers involved are the addition of the miniport to "Broadcom 570x Gigabit Integrated Controller" and "Dell Wireless1350 WLAN Mini-PCI Card" devices.   Since these drivers are actually from different sources, and it all started with a McAfee update, I would assume that the issue is actually in the process that adds the miniport device in your application.

             

            I hope there is some way we can work this out.   I would be glad to be on the phone with someone that actually understands what they are doing and not seemingly reading from a list of possibilities.  I understand that list resolves most of the issues, but this isn't a typical issue.

             

            Thank you very much for your help and suggestions.   I look forward to hearing from you or one of McAfee's programmers responsible for the miniport.   I don't think I can tolerate yet another multi-hour session with someone who.... lets just say isn't quite the expert they present themselves to be.

             

            Regards,

            Libby

            • 3. Re: After an update, McAfee disables all network drivers
              Peter M

              Sending you to a paid support doesn't sound quite right to me.  Did they give you a session ID #?  If so post it here in a reply.

              Meanwhile I will email someone I know in support and ask them to intervene directly in this thread.

              Also please indicate how you contacted support.

               

               

              .

               

              Message was edited by: Ex_Brit on 06/06/13 3:09:30 EDT PM
              • 4. Re: After an update, McAfee disables all network drivers
                selvan

                Hi Libby This is Selvan from McAfee Research Team. Coming to the point I need few details.

                > It would of immense help If u could take a screenshot of the device manager having the network adapters expanded.

                > Moving forward can you give me the version details of the Total protection you have installed along with the Aff ID !

                • 5. Re: After an update, McAfee disables all network drivers

                  I contacted tech support via the 800 number on your website.

                  Session ID:1132708085  (I hope...it was late and my notes are looking pretty bleak)

                  • 6. Re: After an update, McAfee disables all network drivers
                    Peter M

                    OK, thanks.  Try posting what Selvan is asking.  He is with support and should be able to help you with this problem.

                    • 7. Re: After an update, McAfee disables all network drivers

                      I will work on the screen shot.   I had Mcafee uninstalled, backed up the registry then downloaded the version from ATT.  It usually lets me use IE for a while, then it gets wierd.  It will take some time to get it back to the fail mode.   I haven't seen the extra miniport entries re-appear yet.  It doesn't seem to be as repeatable today as it was last week or the week before.  It failed almost instantly before.

                       

                      I have the before screen shot, the post install screen shot and registry dump, and am working on the info after it fails.

                       

                      I have the registry contents from when it was failing before I talked to tech support.  That has all the miniport stuff in it, if that helps.  (it is after the SW version info)

                       

                      The software versions are:

                       

                       

                      Security Center:

                      Version: 11.6

                      Build: 11.6.511

                      AFFLD: 679

                      Language: en-us

                      updated: 6/6/2013

                       

                      Virus Scan

                      Version: 15.6

                      Build: 15.6.245

                      updated: 6/6/2013

                      DAT: 7097.0000

                      Dat Date: 6/5/2013

                      Boot Dat Version: 7095.0000

                      created date: 6/3/2013

                      Engine: 5500.1093

                       

                      Firewall

                      Version: 12.6

                      Build: 12.6.186

                      updated: 6/6/2013

                       

                      Site advisor:

                      Version: 3.4

                      Build: 3.4.1.195

                      AFFLD: 679

                       

                      Clean/Shredder

                      Version: 11.6

                      Build: 11.6.164

                      updated: 6/6/2013

                       

                       

                      McAfee registry entries for miniport that reported the bad registry entry(look for bold txt): (I removed the HW ID's.replaced with x's... If you need that, should that happen privately?)

                       

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\{4D36E972-E325-11CE-BFC 1-08002BE10318}]
                      @="Network Adapters"
                      "Class"="Net"

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\{4D36E972-E325-11CE-BFC 1-08002BE10318}\Descriptions]
                      "Infrared Port"=hex(7):31,00,00,00,00,00
                      "RAS Async Adapter"=hex(7):31,00,00,00,00,00
                      "WAN Miniport (L2TP)"=hex(7):31,00,00,00,00,00
                      "WAN Miniport (PPTP)"=hex(7):31,00,00,00,00,00
                      "WAN Miniport (PPPOE)"=hex(7):31,00,00,00,00,00
                      "Direct Parallel"=hex(7):31,00,00,00,00,00
                      "WAN Miniport (IP)"=hex(7):31,00,00,00,00,00
                      "Packet Scheduler Miniport"=hex(7):31,00,00,00,32,00,00,00,33,00,00,00,00,00
                      "Broadcom 570x Gigabit Integrated Controller"=hex(7):31,00,00,00,00,00
                      "Dell Wireless 1350 WLAN Mini-PCI Card"=hex(7):31,00,00,00,00,00
                      "McAfee Core NDIS Intermediate Filter Miniport"=hex(7):31,00,00,00,32,00,00,00,\
                        33,00,00,00,00,00

                       


                      AND FURTHER DOWN THE REGISTRY.....

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP]

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0000]
                      "ClassGUID"="{4D36E972-E325-11CE-BFC1-xxxxxxxxxxxx}"
                      "Class"="Net"
                      "HardwareID"=hex(7):xxxxxxxxxxx,\
                        xxxxxxxxxxxx

                      "Driver"="{4D36E972-E325-11CE-BFC1-08002BE10318}\\0013"
                      "Mfg"="McAfee"
                      "Service"="mfendiskmp"
                      "DeviceDesc"="McAfee Core NDIS Intermediate Filter Miniport"
                      "ConfigFlags"=dword:00000000
                      "FriendlyName"="Dell Wireless 1350 WLAN Mini-PCI Card - McAfee Core NDIS Intermediate Filter Miniport"
                      "Capabilities"=dword:00000000

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0000\Device Parameters]
                      "InstanceIndex"=dword:00000001

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0000\LogConf]

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0000\Control]

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0001]
                      "ClassGUID"="{4D36E972-E325-11CE-BFC1-08002BE10318}"
                      "Class"="Net"
                      "HardwareID"=hex(7):xxxxxxxxxxxx

                      "Driver"="{4D36E972-E325-11CE-BFC1-08002BE10318}\\0014"
                      "FriendlyName"="Broadcom 570x Gigabit Integrated Controller - McAfee Core NDIS Intermediate Filter Miniport"
                      "Mfg"="McAfee"
                      "Service"="mfendiskmp"
                      "DeviceDesc"="McAfee Core NDIS Intermediate Filter Miniport"
                      "ConfigFlags"=dword:00000000
                      "Capabilities"=dword:00000000

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0001\Device Parameters]
                      "InstanceIndex"=dword:00000002

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0001\LogConf]

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0001\Control]

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0002]
                      "ClassGUID"="{4D36E972-E325-11CE-BFC1-08002BE10318}"
                      "Class"="Net"
                      "HardwareID"=hex(7):xxxxxxxxxxxx

                      "Driver"="{4D36E972-E325-11CE-BFC1-08002BE10318}\\0015"
                      "FriendlyName"="WAN Miniport (IP) - McAfee Core NDIS Intermediate Filter Miniport"
                      "Mfg"="McAfee"
                      "Service"="mfendiskmp"
                      "DeviceDesc"="McAfee Core NDIS Intermediate Filter Miniport"
                      "ConfigFlags"=dword:00000000
                      "Capabilities"=dword:00000000

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0002\Device Parameters]
                      "InstanceIndex"=dword:00000003

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0002\LogConf]

                      [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\MFE_NDISKMP\0002\Control]

                       

                      Message was edited by: libby on 6/6/13 5:23:40 PM CDT
                      • 8. Re: After an update, McAfee disables all network drivers

                        One new item.... this time (forgot to mention) I disabled the modem, since it seemed to be tied into one of the network adaptors.   Now the WAN Miniport-McAfee Core NDIS..... entry doesn't appear in the registry.

                         

                        I had disabled the other two adaptors, (one at a time) and it didn't seem to help.  as soon as I enabled them, things went bad.

                         

                        I am going to play with the laptop for a while, to make sure the craziness doesn't restart, then I will re-enable the modem and see what happens.

                        • 9. Re: After an update, McAfee disables all network drivers

                          Resolved it myself.... never heard back from the expert, but then, I was never able to get the last piece of information they needed.  I was at least hoping to get the registry keys in question so I wouldn't have to guess.  

                           

                          As it turns out, I removed McAfee, cleaned up the registry to get rid of all keys I could find that pertain to McAfee (no feedback from McAfee other than to delete the word McAfee anywhere I find it), restart.   Then remove ALL network drivers that showed the registry error.  Restart.   Reinstall the network drivers.   In the middle of that, the dell support software detected a missing driver and automatically updated it.  restart.  Then reinstalled McAfee to get the requested info, and it has been working since.

                           

                          So, the magic seems to be to restart between each step.  remove all drivers that showed an error in device manager, have the dell support software running in the background, and FULLY remove McAfee (for which there are no easy to find instructions).

                           

                          Hope this helps someone.

                          Libby

                          1 2 Previous Next