1 2 Previous Next 17 Replies Latest reply on Feb 3, 2014 4:02 AM by Phil Cowell

    Installing ePO 5. Failure.

    whoffman87

      Hello,

       

      I am trying to install ePO 5 on a Windows Server 2012 box. Its a domain controller.

       

      When I started the installation, I am greeted with the failure of the included SQL 2008 Express installation. So from using what I found on these forums, I installed SQL 2008 Express manually. Using all the defaults. (I used the SYSTEM account)

       

      I restart the ePO 5 installation:

       

      Setup Type

      ->Custom

      Choose Database Option

      ->Microsoft SQL Server

      Destination Folder

      ->Default

       

      It then searches for Domain Controllers, then proceeds to search for SQL servers. It fails to find any.

       

      "Setup was unable to get a list of SQL servers in your environment. Click Yes to search again, No to enter settings manually" (Paraphrasing)

       

      I click "No", and the Database Information dialog box comes up.

       

      Database Server:servername

      Database Name:ePO_servername

      Database Server Credentials

           Windows Authentication (Selected)

                Domain:domainname

                Username:administrator

                Password:adminpassword

      SQL server TCP port:1434/1433

       

      I get the following error:

       

      "Setup was unable to to access the SQL UDP port 1434 on the specfied SQL server. Setup requires such access to retrieve the TCP port assignment information from the SQL server"

       

      Help would be greatly appreciated.

       

      Thanks,

       

      Wes

        • 1. Re: Installing ePO 5. Failure.
          alexn

          Wes,

           

          First McAfee does not recommend installing ePO server on DC.(But compatible)

          Go to SQL Server  configuration Manager and see the SQL UDP port there.

          Restart the SQL Browser service

          Make sure that TCP/IP Pro is enabled.

           

          Remember:You will put in the same port which you will find in SQL Manager settings.

           

          Post back if it deosnt hep.

           

          Alexn

          • 2. Re: Installing ePO 5. Failure.
            whoffman87

            Alexn,

             

            In the SQL Configuration Manager, under SQL Native Client 10.0 Configuration->Client Protocols->TCP/IP, the default port is 1433.

             

            However, I did take notice that the SQL Browser Service is stopped. When I try to adjust settings it says "The service cannot be started, either becuase it is disabled or because it has no devices associated with it 0x80070422"

             

            Any advice?

             

             

            Thanks,

             

            Wes

            • 3. Re: Installing ePO 5. Failure.
              whoffman87

              Alexn,

               

              I was able to start SQL Browser Service, The Start Type was set to Disabled, I set it to Automatic. However, I still get the same error with ePO.

               

               

              Wes

              • 4. Re: Installing ePO 5. Failure.
                alexn

                Wes,

                 

                Is it SQL server 2008 sp1 Express that comes with ePO 5.0?

                 

                if yes then to easy troubleshoot SQL connection prblem is to install SQL Management studio 2008 as well.It is small tool that will give you an easy way to loginto SQL server.

                 

                Also restart SQl Server service.

                • 5. Re: Installing ePO 5. Failure.
                  whoffman87

                  Alexn,

                   

                  Yes it was the application bundled with ePO 5. I will install what you recommended and try it out. Would I have better luck with SQL 2012 Express?

                   

                   

                  Thanks,

                   

                  Wes

                  • 6. Re: Installing ePO 5. Failure.
                    alexn

                    Yes, it is tested with ePO 5.0 and provides more MDF space.(MDF is SQL Data files).After Installing SQL Managemt Studio log into SQL server.

                    If you have any Antivirus Disable it before installing ePO5.0.

                    Your windows firewall should allow ports 1433-34. Better is to turn off before running ePO setup.exe.

                     

                    On DC I have experienced that these ports are usually taken by some other aopplications so you must confirm that after restarting SQL Browser service you are getting right POrt and during epo install same port should be pop up or manaually put in that port.

                     

                    Although you can install ePO with Local admin rights but i have experienced that if your server (DC) is also part of your domain than it is far better to login as domain adin like domain\administrator and then install epo.

                     

                    Check the following before running setup again

                     

                    • Make sure that the Server name is correct.
                    • Make sure that the Instance name is correct.
                    • Make sure that TCP is enabled and working on the selected database server
                    • Any Virus scan Enterprise Rule blocking this port or firewall.

                     

                    on 6/4/13 12:28:08 PM CDT
                    • 7. Re: Installing ePO 5. Failure.
                      whoffman87

                      Alexn,

                       

                      I tried disabling the firewall completely. I also chose 47800 as the port to try an use. Still gave me an error. I uninstalled SQL 2008 Express, which was no small feat. lol. I am going to try to install SQL 2012 Express next. Do you have any advice, so that I may get this right on the first try with 2012?

                       

                      Thanks,

                       

                      Wes

                      • 9. Re: Installing ePO 5. Failure.
                        whoffman87

                        So after I install SQL 2012 Express using that guide will Mcafee just see it?

                         

                        Wes

                        1 2 Previous Next