1 2 3 Previous Next 21 Replies Latest reply on Aug 7, 2013 12:14 AM by JayMan

    Lenovo Helix failing to boot after Encrypting

    JayMan

      Hi All,

       

      This is my first time encrypting a full UEFI based device, so potentially there is something i've missed...

       

      I've got a Lenovo Helix running a clean installation of Windows 8 Enterprise x64, have installed EEPC 7.0.1 & started encrypting the disk. Upon rebooting, the device now hangs at the Lenovo start up screen & doesn't proceed. I've tried changing BIOS/UEFI settings to allow legacy booting as well as UEFI, changed boot device order from Windows Boot Manager to the SDD etc...

       

      Any idea's?

        • 1. Re: Lenovo Helix failing to boot after Encrypting
          JayMan

          Have rebuilt the laptop & let the encryption process complete fully before rebooting... Still getting the same result of an unbootable device... May have to log a support ticket...

          • 2. Re: Lenovo Helix failing to boot after Encrypting
            jmac

            It won't solve your issue, but have you tried to disable preboot auth and see if it will boot up minus the login?  I'm guessing this is just the lack of proper UEFI support from MS...

            • 3. Re: Lenovo Helix failing to boot after Encrypting
              JayMan

              I haven't tried that yet, as it means rebuilding the device again to get to a working state... I haven't had any luck getting the UEFI EETECH standalone to work either, so can't just emergency boot to change the policy on the laptop.

               

              I've got a case open with support which i'm hoping to hear back on soon.

              • 4. Re: Lenovo Helix failing to boot after Encrypting
                JayMan

                May not get an answer to this one... Had to return the eval unit to Lenovo, so unless we purchase one I'll not be able to go through with the support case

                • 5. Re: Lenovo Helix failing to boot after Encrypting
                  jmac

                  Well, we should be getting some in sometime soon to test our security template.  I'll let you know if I run into the same thing! 

                  • 6. Re: Lenovo Helix failing to boot after Encrypting
                    JayMan

                    I receive a dell xps12 eval today, haven't got to encrypting it yet.

                    However have used the mcafee uefi test tool to check for touchscreen support (it mostly worked after firmware upgrade), and have successfully booted the uefi eetech standalone also (touchscreen worked fine there also). So I'm somewhat confident eepc should work fine once I get a chance to test that later this week.

                    • 7. Re: Lenovo Helix failing to boot after Encrypting

                      Does this help?

                       

                      "Windows 8 support — This release supports Windows 8 under both legacy BIOS boot and UEFI boot processes. Under UEFI boot, EEPC fully supports Secure Boot to maintain the chain-of-trust from the firmware through to Windows. However, this release does not support Single Sign-On from fast start-up under Windows 8, and in a fast start-up scenario, the user will be required to authenticate at EEPC Pre-Boot and at Windows login"

                       

                      Also, you will onyl be able to use a WinPE4 based EETech for UEFI/Secure boot.  If you create your EETech boot disk from WinPE3 files, it will not boot.

                      • 8. Re: Lenovo Helix failing to boot after Encrypting
                        JayMan

                        Unfortunately not. We don't use the single sign on at all in our environment, and the problem is that it would get stuck at the Lenovo boot screen, not even getting to the mcafee pre-boot screen or windows boot screen.

                         

                        The eetech disk I am using was the uefi standalone files (similar to the eetech standalone floppy), so no WinPE version is involved.

                         

                        Unfortunately I didn't try booting the eetech disk before encryption. I'm thinking it's possible there is just a compatibility issue with this device.

                        • 9. Re: Lenovo Helix failing to boot after Encrypting

                          Sorry it didnt help.

                           

                          I am interested in your post and the eventual outcome, as I am tasked with creating a build for a Lenovo Helix (i5 model) also - Using SCCM 2012 SP1.

                           

                          Encryption will be essential to sign off the build - We are using v7.0.0.311.

                           

                          I have the vanilla/factory build on the model i have, so i will try manually installing that and seeing if it dies and report back.....

                           

                          I would be grateful if you could let me know if you make any progress.

                          1 2 3 Previous Next