4 Replies Latest reply on May 30, 2013 12:13 AM by ublinx

    DB move & scan engine

      Hope someone could help me out. I had a MVM 7.0 machine and needed to install a new MVM7.5 one but wanted to copy the DB over.

      So I've upgraded a cloned MVM7.0 to 7.5 so that the DB gets upgraded. Then I backed up the 7.5 DB which I restored on my new MVM7.5 freshly

      installed server. I've ran the following query to solve permission issues:

       

      exec sp_change_users_login ‘Update_One’, ‘faultline’, ‘Faultline’

       

      Now, I can login to the 7.5 portal. Users are present but I'm having an issues with the scan engines. From the log I keep getting these

       

      2013-05-28 21:10:50+04:00 | CFSEngineConfigurationDBProvider::UpdateEngine | 1 | FSScanCtrl | 0x0870 | Unable to update engine (FS75) [C57DC07B-92D0-4E9E-9FFD-CB4228F77FB5].

      2013-05-28 21:11:50+04:00 |  | 4 | FSScanCtrl | 0x0870 | No engine (FS75) [C57DC07B-92D0-4E9E-9FFD-CB4228F77FB5] in engine map.

      2013-05-28 21:11:50+04:00 |  | 1 | FSScanCtrl | 0x0870 | Could not retrieve engine settings.

      2013-05-28 21:11:50+04:00 |  | 4 | FSScanCtrl | 0x0870 | No engine (FS75) [C57DC07B-92D0-4E9E-9FFD-CB4228F77FB5] in DB.

      2013-05-28 21:11:50+04:00 |  | 1 | FSScanCtrl | 0x0870 | Data Service Exception ERROR (0x80040e14; IDispatch error #3092) : Procedure or function fsEngine_Save has too many arguments specified.

      2013-05-28 21:11:50+04:00 | CFSScanCtrlDatabase::Engine_Save | 1 |  | 0x0870 | Data Service Exception ERROR (0x80040e14; IDispatch error #3092) : Procedure or function fsEngine_Save has too many arguments specified.

       

      In the manage engines I see only the 2 engines from the v7.0. Engine running on server v7.5 is not present. How can I get MVM7.5 to detect and update it?

        • 1. Re: DB move & scan engine

          From the FCM console do you see that the database is connected?  In the tools -> preferences -> database tab is the database address correct?

           

          Do the engines check into the FCM Console?  If so, which version are they listed as?    

          • 2. Re: DB move & scan engine

            Hi, yes database is connected and address is correct too. The 7.5 engine shows up in the FCM console with the MVM 7.5 as controller.

            • 3. Re: DB move & scan engine

              The scan engine reports to the scan controller which in turn updates the engines table in the database with status information.  I would start by logging in as globaladmin to see if the engine shows in manage engines for the globaladmin.  If it does the engine may just need to be added to the organization that is attempting to manage it. 

               

              If it is not listed under manage engines for the global administrator, take a look at the engines table in the Faultline database.  Has the engine made it this far?  If not, do you have a different scan controller you can point the scan engine to?  Might be a good test to see if the engine is then populated.

               

              You might also search the registry for any lingering references to the old database. 

              • 4. Re: DB move & scan engine

                Unfortunately had already looked into the manage engines of the globaladmin and the engine is no where to be found as well. I'll have a look at the registry for the possible references to the old database.