8 Replies Latest reply on Jun 27, 2013 6:30 PM by JayMan

    Keyboard Mouse is not Working

    jaimindalwadi

      Hello..

       

      Today I came across one issue in my Dell Ultrabook xps12. Keyboard & Mouse is not working at PBS.  I have to use external usb keyboard to get authenticated.

       

      EEPC installed version: 7.0

       

      Can any one guide me to resolve this issue.

       

       

      Thanks

        • 1. Re: Keyboard Mouse is not Working

          Do you have "always enable USB" set in the machine policy? Try reversing the option, maybe it's a buggy bios.

          • 2. Re: Keyboard Mouse is not Working
            JayMan

            Out of curiousity... Does the touchscreen work during preboot on the XPS12?

             

            We are looking at getting some & would be nice if this is supported (our Samsung Slates don't support Touch in the UEFI boot unfortunately)

             

            Cheers

            • 3. Re: Keyboard Mouse is not Working
              JayMan

              I'll be able to answer my own question soon. I've got a dell xps12 eval unit for the next few weeks. Will post once i get it encrypted to let you know if my keyboard/touchpad work during pre-boot & also if touch screen works.

               

              I suspect touchscreen will work, as after updating the uefi firmware & using the mcafee uefi test utility the touchscreen was working (didn't prior to firmware upgrade). It was a little weird as the touchscreen was scaled to the full screen size, however the test application was only scaled to a quarter of the screen (so I had to touch the blank corners rather than the red buttons, other than the top left button which was in the top left corner).

              • 4. Re: Keyboard Mouse is not Working
                JayMan

                How did you go with this?

                 

                I've got my hands on a XPS12 and i'm getting the same problem. But in addition to that even the external keyboard isn't working sometimes...

                 

                If the external keyboard works, so does the touchscreen... If the external keyboard is not working, neither does the touchscreen.... I'm wondering if the pre-boot environment is actually hanging?

                • 5. Re: Keyboard Mouse is not Working
                  JayMan

                  i've tried "always enable USB" enabled & disblaed, keyboard and trackpad doesnt work on either setting.

                   

                  I've worked out more on the touchscreen thing too... if i press f12 to get boot options & select the internal disk, the touchscreen works at preboot; otherwise it doesnt work. Keyboard and trackpad dont work in either case.

                   

                  Touchscreen works in the UEFI EETECH Standalone and also the McAfee UEFI Touch Test tool, but that just supports that going to the F12 boot menu before booting to anything keeps the TouchScreen working with the McAfee products... (again, keyboard/trackpad not working in these environments).

                   

                  Unsure if this is a McAfee problem or a Dell problem?

                   

                  Message was edited by: JayMan on 25/06/13 11:48:40 PM
                  • 6. Re: Keyboard Mouse is not Working

                    The USB settings only affect the BIOS version of EEPC, the uEFI one relies on the manf provided UEFI environment having support for the absolute and simple pointer protocols. Without those, the EEPC UEFI software cannot "see" the touchscreen or mouse.

                     

                    These are essential parts of the Ultrabook standard. 

                    • 7. Re: Keyboard Mouse is not Working
                      JayMan

                      The UEFI environment obviously does have support for the protocols as it all (EEPC Pre-Boot, EETECH Standalone, McAfee UEFITabletTool) works fine when booting via the F12 boot menu. Its only when booting directly (i.e. not manually specifying the harddisk) that it doesn't work.

                       

                      As mentioned above, the keyboard & trackpad don't work in any case...

                       

                       

                      I've got a case open with Dell, but it is not looking very promising either...

                      Dell wrote:

                      Regarding the touchscreen not working during pre-boot, that is actually how it should be. As touch screens are depending on software to function, it will only work once the system has boot into Windows.

                       

                      As for the keyboard and touchpad, do you mean that they are not working in preboot but works after booting into Windows?



                      Maybe this is a sign that UEFI is just too 'new' still and we'll be force back to using legacy BIOS instead...

                       

                      Message was edited by: JayMan on 26/06/13 6:52:50 PM
                      • 8. Re: Keyboard Mouse is not Working
                        JayMan

                        I've managed to get the support case with Dell escalated to someone who can work with their Tier 3 & Engineering.

                         

                        Its very strange though, even in Legacy BIOS mode the keyboard, trackpad & USB devices work only under certain conditions.... i.e. on a clean start up (from powered off), it all works (minus touch screen obviously), however after a reboot *only* the keyboard will work, USB devices & trackpad do not...

                         

                        Also with UEFI, if you boot to the McAfee Tablet Tool without using F12 boot menu, the touchscreen works...

                         

                        I'm thinking we might need Dell & McAfee to work together to try to work this out...