5 Replies Latest reply on May 2, 2017 7:31 AM by shaneg

    Root/Admin Console PW

    shaneg

      I know, Im a knucklehead...        

       

      But somehow, I managed to 'misplace' the (new) password that I created for the Root/SU account on my WG box(es) - I can SSL into the console, and I can physically access the hardware itself but I cant for the life of me remember the Root/SU password (or the SU username) that I (may have) created once upon a time.

       

      Is a reinstall the only option here?  Or do I have other options available?

      Accessing the front end GUI is not an issue - just accessing it via the Konsole or via SSH.

      Thx

      Shane (aka Knucklehead)

        • 1. Re: Root/Admin Console PW
          sroering

          To reset the root password, use the same method as any linux box.  So long as you have physical access to the hardware and console access, you can boot into single user mode and reset roots password.  There is a KB, but you will need to login to kb.mcafee.com, then search for KB70100.

          1 of 1 people found this helpful
          • 2. Re: Root/Admin Console PW
            shaneg

            Thanks for the direction   

             

            Although the KB you provided refers to resetting the GUI password.   A quick Google search pointed me in the right direction of booting into single user mode.

             

            Thanks again!
            Shane

             

            Message was edited by: shaneg on 5/8/13 8:59:48 AM CDT
            • 3. Re: Root/Admin Console PW
              alexn

              Root password is usually  last 8 digits of your appliance MAC address have you tried?

              • 4. Re: Root/Admin Console PW
                shaneg

                Yup... Last 8 of the MAC didnt cut it - I (almost) distinctly remember changing it when I had the engineer here on site for our initial rollout.

                Problem was, I made it SO non-standard that I forgot it

                • 5. Re: Root/Admin Console PW
                  shaneg

                  I cut and paste this solution from another thread that points back to this one.
                  This was the correct solution for my issue.  It worked flawlessly!
                  Thanks Ed!

                   

                   

                  Instead of adding single to the kernel line, add init=/bin/bash and hit ENTER to go back to parent menu. (ESC will revert your change!). Then hit b to boot this kernel line.

                   

                  This will drop you directly into a shell. File system will be mounted read-only, so you have to make it writeable before you can reset the password.

                   

                  # mount -o remount,rw /

                   

                  # passwd

                   

                  You should see "passwd: all authentication tokens updated successfully."

                   

                  Because you bypassed original init service you have to take care when rebooting the appliance as normal shutdown/reboot scripts won't work.

                   

                  First make sure that all data is written to HDD with "sync", then force reboot with parameter -f:

                   

                  # sync

                   

                  # reboot -f

                   

                  Single user mode won't help you here because it will still ask for root password.

                   

                  Hope this helps someone down the line tyger