6 Replies Latest reply on Aug 12, 2013 8:16 PM by lithik

    Unable to load 8.2.0 to FWE 8.1.2

      Hello,

       

      I MUST upgrade 410D to 8.2.0 TONIGHT! SR has been opened 2 days ago, but since there hasn't been any useful advise so far from the support, I try to fix it out by myself. If I try to manualy load the package, it turns out that /vcdrom has only 200 M available, while the package is 260 M.

       

      Question: how to get rid of the old packages (7.x.x) using up the disk space, since I am not allowed to do it (operation not permitted).

       

      Please help ASAP!

       

      Thanks.

       

      Andrej.

        • 1. Re: Unable to load 8.2.0 to FWE 8.1.2
          PhilM

          Considering your urgency, I would advise that you call McAfee Support and give them the SR number. They should be able help.

           

          The only other option I can personally think of is to download new installation media from the McAfee download site and re-image from USB drive or USB CD/DVD device. You should make sure that you have a current configuration backup from your current installation. Re-image using this version first (I imagine this will re-build the /vcdrom partition with this code and remove any legacy code from the appliance). With the unit re-imaged install any patches necessary to allow you to restore the configuration backup and then upgrade it to 8.2.0. However the current version is 8.3.1P01, so I would recommend continuing until you are running this version.

           

          All that said, if I were in your position right now, I would be on the phone to McAfee.

           

          -Phil.

          • 2. Re: Unable to load 8.2.0 to FWE 8.1.2

            Phil, thank you very much for quick and honest reply.

             

            However, for various reasons I can only access the box remotely and license expiration forces me to do it now. I managed to get rid of some loaded but not installed packages, so hopefuly the download of 8.2.0 will succeed. We+ll see for the rest.

            The problem is only vcdrom partition, holding all historical packages and not allowing me to delete them (operations not permitted), since they are installed on this (active) or alternate slice. If i could get rid of just one ...

            • 3. Re: Unable to load 8.2.0 to FWE 8.1.2

              I managed to solve this particular case by unloading not yet installed 8.1.2 patches (cf package remove), thus creating additional 200 MB space on virtual partition. That was enough for upgrading to 8.2.0 and 8.2.1 and 8.2.1 P08, which I believe is the box max (410D has Celeron 440 and 1 GB mem, which I don't believe to be AMD64 compatible). The license has expired in the meantime, so this is it!

               

              However, I would still like to know, how to delete stuff from virtual partition, which is now at 99%. Since I can not expect official support due to expired license, I will not close this discussion and I'll wait for your kind answers or suggestions.

              • 4. Re: Unable to load 8.2.0 to FWE 8.1.2

                I just ran into this problem trying to upgrade from 8.3.0 to 8.3.1, and found very little help online. What I did find was a command reference card for version 7, which mentioned the "cf package" command. It only listed a few options (cf package list, cf package uninstall, and a couple of others), so I tried it out. I was able to list all the loaded packages, but when I tried uninstalling an old version 7 package, it said it wasn't uninstalled. I tried saying "cf package --help" and got the very helpful message below. I used "cf package remove package=70100" to remove the oldest one, and in short order I had plenty of space available on the /vcdrom partition.

                 

                # cf package --help

                Usage:   

                    cf package set [ server=<server> ] [ user=<user> ]

                        [ password=<password> ] [ directory=<dir> ] [ port=<port> ]

                        [ cdrom_device=<device> ] [ import_default=<ftp|https> ]

                        [ auto_import=<list|list_load|off> ] [ import_freq=<frequency> ]

                        [ auto_rollback=<on|off> ] [ run_time=<time> ]

                        [ install_pkgs=<pkg_list> ] [ uninstall_pkgs=<pkg_list> ]

                        [ admin_email=<user> ] [ email_reports = <on|off>]

                        [ cluster_member=<cluster_member>]

                    cf package list [location=[<local|remote|rollback|cdrom>]]

                    cf package query [cluster_member = <cluster_member>]

                    cf package log package=<package>

                    cf package description package=<package> [verbose=<on|off>]

                    cf package readme package=<package>

                    cf package load packages=<package>,[<package2>,... ]

                               [ source=<ftp,https,file,cdrom,usb> ] [ force=<on|off> ]

                               [ list=<yes|no> ]

                               [ user=<user> ] [ password=<password> ] [ directory=<dir> ]

                               [ server=<server>]

                              

                    cf package install [ force=<on|off> ][delay_activation=<yes|no>]

                        packages=<package1>[,<package2>, ... ] [verbose=<on|off>]

                        [disable_backup=<yes|no>]

                    cf package uninstall [ force=<on|off> ] packages=<package1>[,<package2>, ... ]

                        [verbose=<on|off>] [disable_backup=<yes|no>]

                    cf package remove package=<package>

                    cf package remove_warning

                    cf package rollback

                    cf package rollback_time

                    cf package autorun

                    cf package autoload

                   

                See the cf(1) man page for more details

                • 5. Re: Unable to load 8.2.0 to FWE 8.1.2
                  squidikus

                  I think I know the solution to your issue which is a matter or navigating via ssh to the virtual partitions directory and manualy deleting the files that you do not need there. Best to always have a test firewall to kick into the pit of death SPARTA!!!!!.  At the moment I am unsure what the directory is but they tend to be somewhere in the var directories. I have did some snooping around in there and did come across the packages etc in there.

                  Karl though looks to have your best answer there. GO KARL!!!

                  • 6. Re: Unable to load 8.2.0 to FWE 8.1.2

                    Good thinking, but the vcdrom partition is read-only or some such thing; anyway, it won't let you delete the files manually. You have to use the "cf package remove" command. It's better that way, as it keeps you from deleting packages that are in use. But yes, you have to ssh into the box as 'admin' (or whatever your login is), then say 'srole' to gain administrative rights. Then run the remove commands.