Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
2626 Views 3 Replies Latest reply: May 6, 2013 3:05 PM by Krishnan Vaidyanathan Iyer RSS
cheryl1979 Newcomer 1 posts since
Apr 11, 2013
Currently Being Moderated

Apr 11, 2013 10:36 AM

Firewall keeps turning off.

My McAfee firewall keeps turning off. Within seconds of turning it on it turns itself off again. Can anyone help me?

 

Cheryl

  • dba-g Newcomer 5 posts since
    Apr 20, 2013
    Currently Being Moderated
    1. Apr 20, 2013 2:11 PM (in response to cheryl1979)
    Re: Firewall keeps turning off.

    This worked for me (from Microsoft.com) ...

     

    Cause

    This may be caused because the “NT Service\MpsSvc” account does not have adequate permissions on the following registry key

    HKLM\SYSTEM\CurrentControlSet\Services\SharedAccess

    Solution

    1. In Registry Editor, browse to the key HKLM\SYSTEM\CurrentControlSet\Services\SharedAccess
    2. Right click SharedAccess, and click Permissions.
    3. Click Add.
    4. In the “Enter the object names to select” field, type “NT SERVICE\mpssvc”. Then click Check Names. The name should change to MpsSvc
    5. Click OK.
    6. Select Full Control in the Allow column.
    7. Click OK.

    Applies To

    Windows 7 (all versions) / Windows Vista (all versions)

     

    Then re-start the Windows firewall service, now my McAfee firewall stays 'on'.

  • bfender Newcomer 2 posts since
    May 6, 2013
    Currently Being Moderated
    2. May 6, 2013 1:31 AM (in response to cheryl1979)
    Re: Firewall keeps turning off.

    I had the same problem and suspected a virus.  This fixed my problem:

     

    Run the ESET rogue app remover below in the link below first and then run the ESET servicesrepair.exe found on the page in the second link.  After that, reboot.

     

    http://kb.eset.com/esetkb/index?page=content&id=SOLN2372

     

     

    http://kb.eset.com/esetkb/index?page=content&id=SOLN2895&actp=search&viewlocale= en_US&searchid=1367820946119

     

    At first Mcafee kept warning that the firewall was off but then it stopped and said all was fine and that the firewall was on.  When you went to the firewall settings it said it was off and if you clicked to turn it on it would blink on for a sec and then turn off again.  I tried all kinds of fixes but the one above finally worked.

     

    Message was edited by: bfender on 5/6/13 1:31:54 AM CDT
  • Krishnan Vaidyanathan Iyer Newcomer 16 posts since
    May 6, 2013
    Currently Being Moderated
    3. May 6, 2013 3:05 PM (in response to cheryl1979)
    Re: Firewall keeps turning off.

    Hi Cheyl.

     

    Please go to Services (Start>Run>type and enter "services.msc")  and check if Windows Firewall is started and set to Automatic startup.

     

    If Windows Firewall service is not started: try starting it up by right clicking and selecting the start option. (Following steps are valid only on Win Vista and 7 OS)

     

    1. If you get a message with Error code: 5 at the end--  try the suggestion from 1st reply to your post.
    2. If you get a message with Error code: 1068 at the end--  try the suggestion from 1st reply to your post and follow further..
    • In Registry Editor, browse to the key HKLM\SYSTEM\CurrentControlSet\Services\MpsSvc
    • Right click MpsSvc, and click Permissions.
    • Click Add.
    • In the “Enter the object names to select” field, type “NT SERVICE\mpssvc”. Then click Check Names. The name should change to MpsSvc
    • Click OK
    • Select Full Control in the Allow column.
    • Click OK.
    • In Registry Editor, browse to the key HKLM\SYSTEM\CurrentControlSet\Services\BFE
    • Right click BFE, and click Permissions.
    • Click Add.
    • In the “Enter the object names to select” field, type “NT SERVICE\bfe”. Then click Check Names. The name should change to BFE
    • Click OK.
    • Select Full Control in the Allow column.
    • Click OK.
    • Turn on Firewall and verify if it stays on.

     

    If Windows Firewall is started and is set to Automatic startup, then please verify if both McAfee Firewall services are running and set to Automatic start up type.

    In case, everything is fine with McAfee services too, please try doing a complete re-installation of McAfee (Do run MCPR tool).

     

    If there is any problem with the McAfee Firewall services, please do let know. Will look for further work arounds.


    Thanks and regards,

    Kris I'eR






More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points