3 Replies Latest reply on Jun 10, 2013 2:35 AM by anandeemac

    Can't Encrypt my second Mac drive

      I am working on rolling out EEMac. Currently I have a machine that completed it's encryption of it's OS drive but will not/cannot encrypt it's second drive. Here is part of the log that I think is relavant:

       

      2013-04-04 04:42:33,000 INFO    ClientPipe                           ===== Service Started =====

      2013-04-04 04:42:33,000 INFO    EpoPlugin                            epoAudit: dispatching audits to AgentHandler

      2013-04-04 04:42:34,000 INFO    EpoPlugin                            enforcePolicy: new policy store created (session 1365047716).

      2013-04-04 04:42:34,000 INFO    EpoState                             == Start of policy enforcement ==

      2013-04-04 04:42:34,000 INFO    EpoPlugin                            enforcePolicy: Dispatching enforce policy event.

      2013-04-04 04:42:34,000 INFO    EpoPlugin                            policyHandler: handling EnforcePolicy event

      2013-04-04 04:42:34,000 INFO    EpoPlugin                            policyHandler: checking for machine ID/ePO server change.

      2013-04-04 04:42:35,000 INFO    EpoPlugin                            themeHandler: theme ID change detected (old: 1, new: 30F804E2-EFB8-496A-A2D5-57FFD4D13FF8).

      2013-04-04 04:42:35,000 WARNING EpoPlugin                            themeHandler: no theme package found.

      2013-04-04 04:42:35,000 ERROR   EpoPlugin                            themeHandler: failed to unzip new theme file.

      2013-04-04 04:42:35,000 INFO    EpoPlugin                            userHandler: handling AddLocalDomainUsers event

      2013-04-04 04:42:36,000 INFO    DomainUsers                          Didn't find any new local domain users.

      2013-04-04 04:42:36,000 INFO    EpoPlugin                            userHandler: handling AddLocalDomainUsers response

      2013-04-04 04:42:37,000 INFO    EpoPlugin                            userHandler: processing user updates/requests

      2013-04-04 04:42:45,000 INFO    EpoPlugin                            userHandler: skipping user updates/requests (nothing to do)

      2013-04-04 04:42:45,000 INFO    EpoPlugin                            userHandler: handling UserUpdatesAndAcknowledgement response

      2013-04-04 04:42:54,000 INFO    MacSystem                            Updating system policy

      2013-04-04 04:42:54,000 INFO    MacSystem                            Updating preboot files

      2013-04-04 04:42:57,000 INFO    MacSystem                            Preboot files updated

      2013-04-04 04:42:58,000 INFO    MacSystem                            System policy updated

      2013-04-04 04:42:59,000 INFO    EpoState                             == End of policy enforcement ==

      2013-04-04 04:42:59,000 ERROR   MacCryptManager                      Failed to enforce policy: [0xEE12000F] Failed to find EE partition

       

      Any help would be appreciated!

       

      Edit: A new error is popping up in my Encryption Log:

       

      2013-04-04 13:39:23,000 ERROR   MacSystem                            Error updating system policy: [0xEE81000B] Unmounting ESP failed

      2013-04-04 13:39:23,000 WARNING MfeEpeMacEncryptionProviderPlugin    /BuildBot/EEMAC-S1/EEMACWIP/Epe/Provider/Plugin/Generic/Src/EpeGenSystemPolicyH andler.cpp: 353: [0xEE81000B] Unmounting ESP failed

      2013-04-04 13:39:23,000 ERROR   EpoPlugin                            userHandler: failed to process user updates/acknowledgement: [0xEE010002] [0xEE81000B] Unmounting ESP failed

       

      Also, as I forgot to provide it earlier, I am running EEMac 7.0.0.519

       

      Message was edited by: cbattlegear on 4/4/13 8:46:03 AM CDT
        • 1. Re: Can't Encrypt my second Mac drive

          Hi,

           

           

          Can you please provide the EEMac MER Report from the system where you are seeing the above issue. Please refer to product guide on how to collect MERlogs from the system. At the mean time please perform disk verification using following commands. Please refer to below steps on how to perform disk verification.

           

           

          1 Run the below command to get the disk status :

           

          $sudo diskutil verifyDisk /dev/disk0 

           

          Note :  If your mac has two disks then run above command for disk1 also. ex : $sudo diskutil verifyDisk /dev/disk1

           

           

          2. Run the below command to get the Mac OS disk volume status :

           

          $sudo diskutil verifyVolume <Volume path>

           

          ex: $sudo diskutil verifyVolume /Volumes/Macintosh HD

           

          Where volumes can Macintosh HD or DATA, etc


           

          Note :  Volume names might differ from system to system. Hence identify all the available volumes under /Volumes . run the above command for all the available disk volumes. as this will help us in idetifying whether the disks have any errors on them or not. Please copy the above comamnd output along with EEMac MER report.

           

          Regards,

          Anand Pandit.

          • 2. Re: Can't Encrypt my second Mac drive

            Ran all disk and volume verifications and they came back clean. Also here is the MERlog.

             

            Thank you for the help so far!

            • 3. Re: Can't Encrypt my second Mac drive

              EEMac 7.0 hotfix 872357 has been released to address this issue.