Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
This discussion is archived
2045 Views 9 Replies Latest reply: Apr 16, 2013 3:08 AM by mason RSS
mason Newcomer 6 posts since
Nov 27, 2012
Currently Being Moderated

Mar 26, 2013 5:57 AM

Windows 8 clients failing to communicate with epo

Hi

i am having no end of trouble trying to get the mcafee agent to communicate properly on windows 8 clients

we have it all set up and working as it should for the rest of our desktop estate, windows xp and 7, the only difference between the working and non working machines is the OS

we are using agent version 4.6.0.3122

and i push out the deployment of the agent from epo (so that bit works)

but the agent monitor throws up the below error when i do a collect and send props (or indeed any time it tries to connect to the server)

agent monitor.PNG

so this machine is not getting the correct policiesetc...

 

here is a what the log on the client says, which looks like network issues, only i dont see how that can be the case, i definitely think this is something windows 8 related

 

 

2013-03-26 10:45:51.610 I #2520 Agent Collecting IP address using Internet Manager

2013-03-26 10:45:51.610 I #2520 naInet HTTP Session initialized

2013-03-26 10:45:51.610 I #2520 imsite Connecting to site: agenthandler on port: 4434

2013-03-26 10:45:51.610 I #2520 naInet HTTP Session closed

2013-03-26 10:45:51.625 I #2520 Manage Collecting Properties

2013-03-26 10:45:51.625 I #2520 Manage Initializing Event Interface

2013-03-26 10:45:51.625 I #2520 Manage EpoEventInf Interface: Initialization succeeded.

2013-03-26 10:45:51.625 I #2520 Manage CEnforceProperties::LoadPropFiles() - Properties file not found, creating new

2013-03-26 10:45:51.703 i #2520 Manage Collecting Properties

2013-03-26 10:45:52.391 I #2520 Manage DeInitializing Event Interface

2013-03-26 10:45:52.391 I #2520 Manage EpoEventInf Interface: Deinitialization succeeded.

2013-03-26 10:45:52.406 I #2520 Agent Agent is sending properties version to the ePO Server

2013-03-26 10:45:52.406 I #4064 Agent Started processing a package..

2013-03-26 10:45:52.423 I #4064 Agent Preparing Props Version Package

2013-03-26 10:45:52.438 I #4064 Datastore Did not find setting AssignmentList in section Policy for software ID PolicyRoot

2013-03-26 10:45:52.469 I #4064 Datastore Did not find setting AssignmentList in section Policy for software ID PolicyRoot

2013-03-26 10:45:52.469 I #4064 Datastore Did not find setting AssignmentList in section Policy for software ID PolicyRoot

2013-03-26 10:45:52.469 I #4064 Agent Collecting IP address using Internet Manager

2013-03-26 10:45:52.485 I #4064 naInet HTTP Session initialized

2013-03-26 10:45:52.485 I #4064 imsite Connecting to site: agenthandler on port: 4434

2013-03-26 10:45:52.485 I #4064 naInet HTTP Session closed

2013-03-26 10:45:52.532 I #4064 SpiPkgr Using sequence number 18

2013-03-26 10:45:52.547 i #4064 Agent Agent communication session started

2013-03-26 10:45:52.563 i #4064 Agent Agent is sending PROPS VERSION package to ePO server

2013-03-26 10:45:52.563 i #4064 Agent Agent is connecting to ePO server

2013-03-26 10:45:52.563 I #4064 imutils Trying with site: agenthandler:804

2013-03-26 10:45:52.563 I #4064 naInet HTTP Session initialized

2013-03-26 10:45:52.578 I #4064 imsite  Upload from: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683524230000_3901591439.spkg

2013-03-26 10:45:52.578 I #4064 imsite  Upload response target: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683525630000_1804356440.spkg

2013-03-26 10:45:52.875 I #4064 naInet HTTP Session closed

2013-03-26 10:45:52.891 i #4064 Agent Package uploaded to ePO Server successfully

2013-03-26 10:45:52.891 I #4064 SpiPkgr Signature length is 256

2013-03-26 10:45:52.891 i #4064 Agent Agent communication session closed

2013-03-26 10:45:52.891 i #4064 Agent Agent received REQUEST PROPS package from ePO server

2013-03-26 10:45:52.891 I #4064 Agent Started processing a package..

2013-03-26 10:45:52.906 I #4064 Agent Preparing Props Package

2013-03-26 10:45:52.922 I #4064 Datastore Did not find setting AssignmentList in section Policy for software ID PolicyRoot

2013-03-26 10:45:52.922 I #4064 Datastore Did not find setting AssignmentList in section Policy for software ID PolicyRoot

2013-03-26 10:45:52.922 I #4064 Datastore Did not find setting AssignmentList in section Policy for software ID PolicyRoot

2013-03-26 10:45:52.922 I #4064 Agent Collecting IP address using Internet Manager

2013-03-26 10:45:52.922 I #4064 naInet HTTP Session initialized

2013-03-26 10:45:52.922 I #4064 imsite Connecting to site: agenthandler on port: 4434

2013-03-26 10:45:52.953 I #4064 naInet HTTP Session closed

2013-03-26 10:45:53.000 I #4064 SpiPkgr Using sequence number 19

2013-03-26 10:45:53.047 i #4064 Agent Agent is connecting to ePO server

2013-03-26 10:45:53.063 I #4064 imutils Trying with site: agenthandler:804

2013-03-26 10:45:53.063 I #4064 naInet HTTP Session initialized

2013-03-26 10:45:53.063 I #4064 imsite  Upload from: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683529060000_2422983119.spkg

2013-03-26 10:45:53.063 I #4064 imsite  Upload response target: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683530470000_3991101112.spkg

2013-03-26 10:46:56.485 I #4064 naInet failed to receive package..server is busy

2013-03-26 10:46:56.501 I #4064 imsite NaInet library returned code == 12

2013-03-26 10:46:56.532 I #4064 imutils Trying with site: agenthandler:804

2013-03-26 10:46:56.532 I #4064 naInet HTTP Session initialized

2013-03-26 10:46:56.532 I #4064 imsite  Upload from: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683529060000_2422983119.spkg

2013-03-26 10:46:56.532 I #4064 imsite  Upload response target: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683530470000_3991101112.spkg

2013-03-26 10:46:56.625 I #4064 naInet failed to receive package..server is busy

2013-03-26 10:46:56.625 I #4064 imsite NaInet library returned code == 12

2013-03-26 10:46:56.625 I #4064 imutils Trying with site:agenthandler:804

2013-03-26 10:46:56.625 I #4064 naInet HTTP Session initialized

2013-03-26 10:46:56.625 I #4064 imsite  Upload from: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683529060000_2422983119.spkg

2013-03-26 10:46:56.625 I #4064 imsite  Upload response target: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683530470000_3991101112.spkg

2013-03-26 10:46:56.750 I #4064 naInet failed to receive package..server is busy

2013-03-26 10:46:56.750 I #4064 imsite NaInet library returned code == 12

2013-03-26 10:46:56.750 I #4064 imutils Trying with site: agenthandler:804

2013-03-26 10:46:56.750 I #4064 naInet HTTP Session initialized

2013-03-26 10:46:56.750 I #4064 imsite  Upload from: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683529060000_2422983119.spkg

2013-03-26 10:46:56.750 I #4064 imsite  Upload response target: C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683530470000_3991101112.spkg

2013-03-26 10:47:30.422 E #4064 imsite Error trace:

2013-03-26 10:47:30.422 E #4064 imsite  [uploadFile,,/spipe/pkg?AgentGuid={A8252CB8-CAA8-4B92-8F49-E17DB60D01BB}&Source =Agent_3.0.0,pkg00130087683529060000_2422983119.spkg,C:\ProgramData\McAfee\Commo n Framework\Unpack,C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683530470000_3991101112.spkg]->

2013-03-26 10:47:30.422 E #4064 imsite   NaInet library returned code == -8

2013-03-26 10:47:30.422 E #4064 imsite Error trace:

2013-03-26 10:47:30.422 E #4064 imsite  [uploadFile,,/spipe/pkg?AgentGuid={A8252CB8-CAA8-4B92-8F49-E17DB60D01BB}&Source =Agent_3.0.0,pkg00130087683529060000_2422983119.spkg,C:\ProgramData\McAfee\Commo n Framework\Unpack,C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683530470000_3991101112.spkg]->

2013-03-26 10:47:30.422 E #4064 imsite   NaInet library returned code == -8

2013-03-26 10:47:30.422 E #4064 imsite Error trace:

2013-03-26 10:47:30.422 E #4064 imsite  [uploadFile,,/spipe/pkg?AgentGuid={A8252CB8-CAA8-4B92-8F49-E17DB60D01BB}&Source =Agent_3.0.0,pkg00130087683529060000_2422983119.spkg,C:\ProgramData\McAfee\Commo n Framework\Unpack,C:\ProgramData\McAfee\Common Framework\Unpack\pkg00130087683530470000_3991101112.spkg]->

2013-03-26 10:47:30.422 E #4064 imsite   The naInet library returned an error. [Parent error: NaInet library returned code == -8]

2013-03-26 10:47:30.422 I #4064 naInet HTTP Session closed

2013-03-26 10:47:30.422 I #4064 naInet HTTP Session closed

2013-03-26 10:47:30.422 I #4064 naInet HTTP Session closed

2013-03-26 10:47:30.422 I #4064 naInet HTTP Session closed

2013-03-26 10:47:30.422 e #4064 Agent Agent failed to communicate with ePO Server

2013-03-26 10:47:30.422 i #4064 Agent Agent communication session closed

2013-03-26 10:47:30.422 I #4064 Agent Setting flag to force full properties on next ASCI

2013-03-26 10:47:30.438 I #4064 Agent Agent communication failed, result=-2400

2013-03-26 10:47:30.438 I #4064 Agent Exponential retry in 1016 seconds, error=-2400(Unable to connect to ePO Server)

2013-03-26 10:47:30.438 i #4064 Agent Agent will connect to the ePO Server in 16 minutes and 56 seconds.

2013-03-26 10:49:30.705 I #2524 Agent Sending the next batch of immediate events

2013-03-26 10:49:30.705 i #2524 Agent Agent is looking for events to upload

2013-03-26 10:49:30.720 i #2524 Agent Agent uploading 10 events to ePO Server

2013-03-26 10:49:30.720 I #4064 Agent Started processing a package..

2013-03-26 10:49:30.736 I #4064 SpiPkgr Using sequence number 20

2013-03-26 10:49:30.766 i #4064 Agent Agent communication session started

2013-03-26 10:49:30.766 i #4064 Agent Agent is sending EVENT package to ePO server

2013-03-26 10:49:30.766 i #4064 Agent Agent is connecting to ePO server

2013-03-26 10:49:30.782 e #4064 Agent Agent failed to communicate with ePO Server

2013-03-26 10:49:30.782 i #4064 Agent Agent communication session closed

2013-03-26 10:49:30.782 I #4064 Agent Agent communication failed, result=-2400

2013-03-26 10:49:30.782 I #4064 Agent Exponential retry in 710 seconds, error=-2400(Unable to connect to ePO Server)

2013-03-26 10:49:30.782 i #4064 Agent Agent will connect to the ePO Server in 11 minutes and 50 seconds.

 

 

anyone have any ideas?

  • JoeBidgood McAfee SME 2,881 posts since
    Sep 11, 2009
    Currently Being Moderated
    1. Mar 26, 2013 12:10 PM (in response to mason)
    Re: Windows 8 clients failing to communicate with epo

    Please check in the server.log on the ePO server (or the agent handler if this machine is talking to an AH) at the time that the machine is trying to communicate - the "failed to receive package..server is busy" message implies that the machine is talking to ePO, but is getting a "go away" response. This can be caused by a number of things - the server.log will give us more detail.

     

    HTH -

     

    Joe




    (Please post questions to the forum, as I am unable to respond to private messages. Thanks!)



  • JoeBidgood McAfee SME 2,881 posts since
    Sep 11, 2009
    Currently Being Moderated
    3. Mar 28, 2013 2:31 PM (in response to mason)
    Re: Windows 8 clients failing to communicate with epo

    That will definitely cause problems - the AH needs to be able to access the registered LDAP servers in order to correctly handle user-based policies. Can the AH reach all the registered LDAP servers?

     

    Thanks -

     

    Joe




    (Please post questions to the forum, as I am unable to respond to private messages. Thanks!)



  • alexn Veteran 722 posts since
    Aug 9, 2012
    Currently Being Moderated
    5. Apr 4, 2013 10:24 AM (in response to mason)
    Re: Windows 8 clients failing to communicate with epo

    My suggestion is

     

    Could you change windows host file to point to your ePO server

     

    C:\Windows\System32\drivers\etc

     

    Put in IP address of your server and then domain instead of 127.0.0.1 , save it and restart your machine.

     

    Regds

     

    Alexn

     

    What you need to do:-----

     

    Apache can only handle 250 connections simulteniously, Your server gives busy message , perthaps it is time  to  set up an agent handler.

     

     

     

    Message was edited by: alexn on 4/4/13 10:24:33 AM CDT

    Post Timings: 6.00 AM to 3.00PM PDT
  • JoeBidgood McAfee SME 2,881 posts since
    Sep 11, 2009
    Currently Being Moderated
    6. Apr 4, 2013 10:25 AM (in response to mason)
    Re: Windows 8 clients failing to communicate with epo

    Are you using any user-based policies in ePO? If not then it may be something else.

    (The KB article describing what I think is happening is  KB66245.)

     

    Thanks -

     

    Joe




    (Please post questions to the forum, as I am unable to respond to private messages. Thanks!)



More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points