2 Replies Latest reply on Mar 20, 2013 8:51 AM by stephl

    ePO server update from 4.5.4 to 4.5.6 failed

      Hi,

       

      I have an issue with one of my ePO servers, I was doing the installation of version 4.5.6 from version 4.5.4 and the installation didn't displays an error but it just stops updating the status windows, I was checking the task manager and nothing was moving after an hour so I decided to stop the installation but the windows wasn't responding, at some point I had to reboot the server.

       

      Obviously the McAfee services and it's dependances don't start. The database service are working. After some digging I found that in the Jakarta service log:

       

      [2013-03-19 14:35:03] [457  javajni.c] [error] CreateJavaVM Failed

      [2013-03-19 14:35:03] [991  prunsrv.c] [error] Failed initializing java C:\PROGRA~1\McAfee\EPOLIC~1\Server\bin\bootstrap.jar

      [2013-03-19 14:35:03] [1280 prunsrv.c] [error] ServiceStart returned 2

      [2013-03-19 14:37:32] [457  javajni.c] [error] CreateJavaVM Failed

      [2013-03-19 14:37:33] [991  prunsrv.c] [error] Failed initializing java C:\PROGRA~1\McAfee\EPOLIC~1\Server\bin\bootstrap.jar

      [2013-03-19 14:37:33] [1280 prunsrv.c] [error] ServiceStart returned 2

      [2013-03-19 14:38:06] [457  javajni.c] [error] CreateJavaVM Failed

      [2013-03-19 14:38:06] [991  prunsrv.c] [error] Failed initializing java C:\PROGRA~1\McAfee\EPOLIC~1\Server\bin\bootstrap.jar

      [2013-03-19 14:38:06] [1280 prunsrv.c] [error] ServiceStart returned 2

      [2013-03-19 14:38:11] [457  javajni.c] [error] CreateJavaVM Failed

      [2013-03-19 14:38:11] [991  prunsrv.c] [error] Failed initializing java C:\PROGRA~1\McAfee\EPOLIC~1\Server\bin\bootstrap.jar

      [2013-03-19 14:38:11] [1280 prunsrv.c] [error] ServiceStart returned 2

       

      When I tried to start the Tomcat5.exe manually from the ePO directory I received the error: Service doesn't exist (translated from French). This is surely cause by the installation not finishing, I tried to restart the installation but it needs the McAfee services to run..

       

      If anyone as an idea from there to get me out of this mess I would be really appreciate..

       

      I have few options and I don't know much about tomcat either. The server is a Windows 2003 SP2. I saw some posts how to fix Tomcat server error on a Windows by copying msvcr71.dll back to the java folder but wasn't sure.

       

      I did a disaster recovery preparation with the original version: EPO4.5P0, SQL 2005 SP2  and a manual SQL backup but I would really prefer not to have to go there. It was done last friday but would use in last resort.

       

      Thanks

      Steph

       

      on 19/03/13 15:05:54 CDT