1 2 Previous Next 11 Replies Latest reply on Mar 20, 2013 1:27 PM by andyw35

    EETech Menu's have no text

      I am using UBCD4win to create a recovery disk for V7 Windows 7 laptops

      I previously have the safeboot v5 working fine, however when I try and run the EETech all the text is missing from the buttons. although pressing them does appear to work.

       

      I have followed the instructions in the EETech user guide so assume it's all set up ok. I have seen similar posts pointing to different fixes but none seem to help.

       

      I would be grateful if anyone can help me with this.

        • 1. Re: EETech Menu's have no text

          It's to do with locale. Eetech is set up only to work with the standard English version of WinPE (0409), so if you are using a different language, then the theme files will not work.

           

          Some people have (unofficially) edited the theme XML files to reflect their locale Id causing eetech to think its working on an English os.

          • 2. Re: EETech Menu's have no text

            Thanks for the reply, I am using the standard UBCD4Win build in the UK but on checking the settings after booting, it appears to be in US English mode, and can see in the xml file in EETech plugin folder that it's set to 409, should I be setting UBCD to boot to UK 809 (or EEtech to 809) which I believe is the UK version.

            Sorry this is vague but I'm new to language packs.

            I'm happy to edit the theme xml to whatever is required, failing this I am going to attempt to create a WinPe version instead but as my UBCD has so many other tools I would prefer to keep it all on one disk if possible.

            If anyone can point me in the right direction it would be appreciated.

            • 3. Re: EETech Menu's have no text

              You need to make sure they are the same, so either set your os to 0409 or your theme to match your os.

              • 4. Re: EETech Menu's have no text

                Having checked the settings, to the best of my knowledge UBCD' s user settings in the plugin\!critical\usersettings\user-settings.inf

                It is set to US,

                After googling this I must have tried 10 soloutions but it's still the same. I can see that my regional settings are US when booted up to UBCD4win and the EETech plugin is set to US

                I'm puzzled as I have over 20 other plugins and they work without incident.

                I suspect the 'theme files' you mention are the root cause, but I can find no reference to them in the literature on either Bartpe or UBCD4win's site.

                The theme.xml seems to be all pointing to US.

                • 5. Re: EETech Menu's have no text

                  The Theme files are from McAfee - they are designed only to work with the USA English vesion of WinPE. That's why you'll need to edit them if you're using anything else, or a version of the OS which does not report the same Locale codes.

                   

                  Maybe set them to 0000? It's just a guess but then they might work for any language.

                  • 6. Re: EETech Menu's have no text

                    Ok, so this is what I have tried and how I got a 'sort of' resolution:

                    Built a WinPE disk using the EETech user guide on my UK configured laptop, worked but still no text.

                    Built a VM with Win 7, setting all locale to US and installed UBCD4Win, still no text.

                    As a last resort, built  Winpe on the VM that was comnfigured with US settings, finally have a working disk with text on buttons.

                     

                    Would have liked to get it working natively in UBCD but alas never managed it.

                    I'm convinced there is some Locale setting I am missing, but as yet I've had no joy trying to find it.

                     

                    I did notice that i the Winpe User guide (p20) it asks me to 'select the language of your choice e.g english us' however I can only see the core-0409.xml and tech-0409.xlm in the win32 folder. I suspect that it's the core-0409 file I should be amending but I can't see the settings required.

                     

                    Message was edited by: andyw35 on 3/11/13 7:52:47 PM GMT

                     

                    Message was edited by: andyw35 on 3/11/13 8:02:52 PM GMT
                    • 7. Re: EETech Menu's have no text

                      Just make a copy of it called core-0809 etc for uk English, or core-0000 might work for anything (untested)

                      • 8. Re: EETech Menu's have no text

                        Thanks, would you expect this to work with UBCD, if I simply copy the core-0409.xml and rename it 0809 or 0000 in the same plugin\win32 folder

                        Does the renamed file need any configuration or will it be picked up as is.?

                        And would any other files need amending to point to this.

                        I appreciate that it is 'untested' but am happy to try anything as we are not live yet so am in no danger of losing data.

                        • 9. Re: EETech Menu's have no text

                          I'm just guessing at the moment unfortunately. :-(

                          1 2 Previous Next