4 Replies Latest reply on Feb 14, 2013 4:14 PM by tikkanenta

    Agent not fully installing through MSI

      Hello i have a EPO 4.5 server that is running fine and i followed the webpage on how to create a MSI file so i could have the agent installed through a GPO. When testing the MSI file on new computers the agent is installed but does not appear on the system tray. When i run CmdAgent.exe /s the Agent Monitor pops up, but when i click collect and send props it automatically states agent failed to collect properties. The framepkg i created this MSI from works fine and i cannot find anything in any of the log files i have found that would tell me why it is not completeing.

       

      Thanks,

      Troy

        • 1. Re: Agent not fully installing through MSI
          JoeBidgood

          Can you attach the agent log from an affected machine?

          Also - just to check - was the MSI installed with administrator rights?

           

          Thanks -

           

          Joe

          • 2. Re: Agent not fully installing through MSI

            Where would the agent log files be ive looked at so many log files today i dont remember which is which. and yes the msi does have administrator rights.

            • 3. Re: Agent not fully installing through MSI
              alexn

              c:\documents and settings\all users\applictaion data\mcafee\common framework

              c:\windows \temp\mcafeelogs

              • 4. Re: Agent not fully installing through MSI

                there were no files in any of those locations i found a log in C:\PROGRAMDATA\MCAFEE\COMMON FRAMEWORK\DB\Agent_

                 

                HELPDESKDATA.LOG

                 

                2013-02-14 11:48:53 I #2068 Logging Create XML

                2013-02-14 11:48:53 E #2068 Logging addAgentInfoToLog GUID query error 2

                2013-02-14 11:48:53 I #2068 FrmSvc START cmdline="C:\Program Files (x86)\McAfee\Common Framework\FrameworkService.exe" /Service

                2013-02-14 11:48:53 I #2068 FrmSvc register service

                2013-02-14 11:48:53 I #2068 FrmSvc Set COM launch permissions and service settings

                2013-02-14 11:48:55 I #2068 FrmSvc  result = 0

                2013-02-14 11:48:55 I #2068 FrmSvc END

                2013-02-14 11:49:00 E #628 Logging addAgentInfoToLog GUID query error 2

                2013-02-14 11:49:00 I #628 FrmSvc START cmdline="C:\Program Files (x86)\McAfee\Common Framework\FrameworkService.exe" /ServiceStart

                2013-02-14 11:49:00 I #628 FrmSvc ServiceStart

                2013-02-14 11:49:00 I #628 FrmSvc Running

                2013-02-14 11:49:04 I #2964 FrmSvc Starting Subsystem <Logging>

                2013-02-14 11:49:04 x #2964 Logging Subsystem started

                2013-02-14 11:49:07 I #2964 FrmSvc Starting Subsystem <User Space Controller>

                2013-02-14 11:49:13 I #2964 FrmSvc Starting Subsystem <Management>

                2013-02-14 11:49:13 I #1876 Manage Mangement plugin watch worker thread started

                2013-02-14 11:49:16 I #2964 Datastore Did not find setting AssignmentList in section Policy for software ID PolicyRoot

                2013-02-14 11:49:17 I #2964 LpcConnMgr Initializing lpc data

                2013-02-14 11:49:17 I #2964 LpcConnMgr Registering software id EPOAGENT3000 with a hash value of 197307931

                2013-02-14 11:49:17 I #2964 LpcConnMgr Registering software id CMNUPD__3000 with a hash value of 1496913389

                2013-02-14 11:49:17 I #2964 LpcConnMgr Starting lpc connection manager

                2013-02-14 11:49:17 I #2964 LpcConnMgr Setting up lpc server

                2013-02-14 11:49:17 I #2964 LpcConnMgr lpc server path \\.\pipe\ma_named_pipe

                2013-02-14 11:49:17 I #2964 WinLpcSvr Initializing LPC server

                2013-02-14 11:49:17 I #2964 WinLpcSvr Using randomized name \\.\pipe\ma_named_pipe53061839 for first instance "\\.\pipe\ma_named_pipe"

                2013-02-14 11:49:17 I #2964 WinLpcSvr Setting server path to \\.\pipe\ma_named_pipe53061839

                2013-02-14 11:49:17 I #2964 WinLpcSvr Starting LPC server

                2013-02-14 11:49:17 I #2964 WinLpcSvr Creating server run thread

                2013-02-14 11:49:17 I #2964 WinLpcSvr server started successfully

                2013-02-14 11:49:17 I #2964 LpcConnMgr Setting up message queue

                2013-02-14 11:49:17 I #2964 LpcConnMgr Setting up heart beat component

                2013-02-14 11:49:17 x #2964 Manage Subsystem started

                2013-02-14 11:49:20 I #2964 FrmSvc Starting Subsystem <Updater>

                2013-02-14 11:49:20 I #2964 updsubs Starting updater subsystem

                2013-02-14 11:49:20 i #2964 Updater Subsystem started

                2013-02-14 11:49:23 I #2964 FrmSvc Starting Subsystem <Scheduler>

                2013-02-14 11:49:23 I #2964 Sched >>--CSchedule::Start

                2013-02-14 11:49:23 I #2964 Sched Glbs.szMyPlatform: WNT7W:6:1:1

                2013-02-14 11:49:23 I #2964 Sched All the tasks are successfully loaded from the file

                2013-02-14 11:49:23 i #2964 Sched Scheduler is now running

                2013-02-14 11:49:23 I #2964 Sched <<--CSchedule::Start

                2013-02-14 11:49:23 I #2964 FrmSvc Service started

                 

                 

                 

                also in the msi the log file i told it to log to reads

                 

                2013-02-14 09:04:49 I #2548 msacfg cfg Install site list,C:\Windows\TEMP\{B639A4DE-A375-47D3-89C3-DDCF98D992F7},1

                2013-02-14 09:04:49 I #2548 caShrLb cfg Installed version=4.5.0.1270

                2013-02-14 09:04:49 I #2548 caShrLb cfg Product count=0

                2013-02-14 09:04:49 I #2548 caShrLb cfg Managed mode=0

                2013-02-14 09:04:49 I #2548 stlscfg cfg Replacing entire site list

                2013-02-14 09:04:49 I #2548 stlscfg cfg Deleting sitecache.bin

                2013-02-14 09:04:49 I #2548 stlscfg cfg Replacing server.xml with default

                2013-02-14 09:04:49 I #2548 stlscfg cfg Removing old compiled policy

                2013-02-14 09:04:49 I #2548 stlscfg cfg Replacing agent.ini with default

                2013-02-14 09:04:49 I #2548 Thread cfg Exit program

                2013-02-14 09:04:49 I #2548 msacfg cfg END 0