Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
1017 Views 2 Replies Latest reply: Oct 2, 2013 12:33 PM by vimalnavis RSS
krzysztof.anzorge Newcomer 19 posts since
Mar 18, 2011
Currently Being Moderated

Feb 1, 2013 4:23 AM

DLPE 9.2 : DLP Agent Status incorrect

Hi,

 

DLP Agent status isn't NONE but, I saw strange behavior.

Maybe someone from you can explain it to me.

 

Below you have steps that my customer done:

 

1. Install " HDLP_Agent_9_2_100_36" on some machines.

2. Reboot those machines after install

3. Run "DLP MA Properties Reporting Task" from ePO Server Tasks 4. "DLP: Agent Status" query shows "Agent installed - pending reboot"

5. Send many times Wake-up call to this station.

6. Run "DLP MA Properties Reporting Task" from ePO Server Tasks.

7. Status still shows " Agent installed - pending reboot" on "DLP: Agent Status" query 8. Customer logon (by RDP) to this machine 9. Send Wake-up call to this station (from ePO).

10. Run "DLP MA Properties Reporting Task" from ePO Server Tasks.

11."DLP: Agent Status" query change to "Agent is running in device control and full....".

 

Please explain to me, why ePO agent can't get full properties from DLP Agent to ePO when no one is logged-in on this machine?

Is it DLP Agent bug, or ePO Agent bug?

 

Customer environment:

ePO - 4.6.3

ePO - Agent 4.6.0.2292 (4.6.0 patch 2)

DLPE - 9.2.100.36

DLPE ePO Extension - 9.2.100.12

 

 

Krzysztof Anzorge

  • jrvane11 Newcomer 5 posts since
    May 10, 2013
    Currently Being Moderated
    1. Oct 1, 2013 7:23 AM (in response to krzysztof.anzorge)
    Re: DLPE 9.2 : DLP Agent Status incorrect

    I have the same situation.  Any explanation and fix information from the McAfee experts would be most appreciated.

     

    Cheers.

  • vimalnavis McAfee SME 204 posts since
    Feb 23, 2010
    Currently Being Moderated
    2. Oct 2, 2013 12:33 PM (in response to krzysztof.anzorge)
    Re: DLPE 9.2 : DLP Agent Status incorrect

    For new installs or upgrades the following need to complete before DLPe starts reporting the most accurate information:

    1. Agent install

    2. System Reboot

    3. User Login

    4. First ASCI after reboot

    5. Enforce policy after the ASCI

     

    DLPe gets a new policy from ePO as part of step 4. The policy gets enforced as part of step 5.

    This is needed just one time for the very first initialization.

     

    Please explain to me, why ePO agent can't get full properties from DLP Agent to ePO when no one is logged-in on this machine?

    DLPe Agent runs only when a user is logged on. What you are seeing is expected and not a bug.

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points