Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
5321 Views 1 Reply Latest reply: Jan 13, 2013 7:15 PM by rmetzger RSS
rcbutcher Newcomer 1 posts since
Jan 13, 2013
Currently Being Moderated

Jan 13, 2013 6:43 PM

Disabling scriptproxy addon solves rendering problem on IE 9 but not IE 8

We use Internet Explorer 8 as the default client for our library management system. By default we have the McAfee scriptproxy addon enabled.

One particular block of code in one particular web page delays rendering by +- 70 seconds on both IE 8 and IE 9. This code contains a table with a dropdown list with many entries.

The rendering delay seems to be caused by/related to the scriptproxy addon. Reason : On the IE 9 boxes we also have, disabling the scriptproxy addon allows the page to be rendered instantly.

 

So I have two questions :

1. Disabling the scriptproxy addon on IE 8 does not resolve the problem, but it does on IE 9. Do I need to do more to disable it on IE 8 than just disable it via the "manage addons" box ?

2. Our version of scriptproxy is 15.0.0.0. Is there a later version that fixes this problem ?

 

grateful for any feedback !

  • rmetzger Champion 566 posts since
    Jan 4, 2005

    Hi rcbutcher   ,

     

    Welcome to the forums.

     

     

    rcbutcher wrote:

     

    We use Internet Explorer 8 as the default client for our library management system. By default we have the McAfee scriptproxy addon enabled.

    One particular block of code in one particular web page delays rendering by +- 70 seconds on both IE 8 and IE 9. This code contains a table with a dropdown list with many entries.

    The rendering delay seems to be caused by/related to the scriptproxy addon. Reason : On the IE 9 boxes we also have, disabling the scriptproxy addon allows the page to be rendered instantly.

     

    So I have two questions :

    1. Disabling the scriptproxy addon on IE 8 does not resolve the problem, but it does on IE 9. Do I need to do more to disable it on IE 8 than just disable it via the "manage addons" box ?

    2. Our version of scriptproxy is 15.0.0.0. Is there a later version that fixes this problem ?

     

    Well, a better solution is to Whitelist your internal library management system.

     

    You don't say what the URL you are using, nor the VSE version(s) you have in place.

     

    With VSE v8.7i SP2 and up (preferably SP5) and VSE v8.8 you can specify a Whitelist of URLs which scriptproxy will ignore. This whitelisting process is intended just for this situation.

     

    For VSE v8.7i, you will need to use a .reg file which contains the whitelisting entry.

    For VSE v8.8, you simply list the Whitelist entries.

     

    Both versions whitelisting methods are found in the Best Practices guide (for each version).

     

    Be careful not to over-expose the whitelisting url as you may expose to much and leave open sites that may want to have scanned. This is discussed in the best practice guide, as well.

     

    Hopefully this is helpful.


    Ron Metzger

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points