2 Replies Latest reply on Jan 18, 2013 3:23 PM by prmanningham

    Mer from the command line

    prmanningham

      Hi guys, I'm writing a small batch to run the MER silentely but I cannot get the MER tool to retrieve all the logs I'm able to get using the GUI,

       

      Here's my the command line I'm using :

      \\myserver\Mer.exe /detected /save \\myserver\MER.tgz /silent
      

       

      *actual path changed

       

      My goal is to retrieve all Endpoint Encryption and Windows logs. While running the GUI I get a file of almost 30mb but with my command line retrieves a 2mb file which is not enough...

       

      Thanks in advance

       

      Ce message a été modifié par: prmanningham on 08/01/13 08:59:52 CST
        • 1. Re: Mer from the command line
          ChrisU

          Hi prmanningham,

           

          I'll ask someone from my team to look into your report. I'm not sure why there would be a difference.

           

          As a test, have tried with the /prods switch? If you know you want Endpoint Encryption specifically, try

           

          \\myserver\mer.exe /prods "Endpoint Encryption" /save \\myserver\MER.tgz /silent

           

          Info on command line switches can be found at https://kc.mcafee.com/corporate/index?page=content&id=KB59385

           

          Question: Do you have ePO in your environment? Have you looked into use ePO-MER instead?

           

          http://mer.mcafee.com/enduser/downloadepomer.aspx?lang=English

           

          Message was edited by: ChrisU on 1/8/13 3:37:35 PM CST
          1 of 1 people found this helpful
          • 2. Re: Mer from the command line
            prmanningham

            thanks just tried the ePO-MER. Checked-in the package and extension, tried to run the task to deploy MER on 2 machines and it failed with this error :

            2013-01-18 16:03:59          E          #4980          ScrptExe            Failed to copy C:\ProgramData\McAfee\Common Framework\Current\SUPPCLNT1000\ServicePack\0409\Mer.exe to C:\Program Files (x86)\McAfee\Supportability\MER for ePO\Mer.exe.  Setting bRet to FALSE

            The result is that only 2 dlls gets installed and not the actual mer.exe. If I install this manually with the .msi it works...

             

            Anyway, now I've set the policy to gather as much information as possible (8) and ran the scan task from ePO with the option to gather logs for all detected softwares.

             

            The result is the same thing, I still get a fraction of logs that I usually get from running MER manually on a machine...  (23mb vs 1.6mb)