Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
227 Views 0 Replies Latest reply: Jan 8, 2013 4:29 AM by stifi RSS
stifi Newcomer 12 posts since
Dec 28, 2012
Currently Being Moderated

Jan 8, 2013 4:29 AM

MWG 7.3.0.2 :: Progress Page not working if checking for Mime Type in the Rule

Dear all

I run into some problems enhancing the default rule for progress page taken from the ruleset library. In fact I would like to be able to have a condition which checks for the MIME type, that is, to be able to make excludes for specific MIME types. This is my rule:

 

enable-progress-page-1.jpg

 

This rule does NOT work. But it used to work in the past, I have no idea why it behaves different now. Maybe some changes somewhere in the ruleset affects also that rule. What happened is that ... nothing happens, that means, the progress page does not appear as expected for any downloads auch as application/zip. Once I remove the condition regarding the MediaType.EnsuredTypes the rule looks as following:

 

enable-progress-page-2.jpg

 

This rule works as expected. What is also working is the upper rule if it also applies to requests and not just to  responses. However, this took me into other problems on which the progress page has been displayed also for a large html file even this should not be done. I also checked for other options that MediaType.EnsuredTypes like MediaType.FromHeader, same effect.

 

Thanks for any hints, Stefan

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points