1 2 3 Previous Next 25 Replies Latest reply: Oct 10, 2013 1:01 PM by dans RSS

    epo 4.6.4 install rolling back

    smalldog

      Hi All, I install epo 4.6.4 on w2k8 R2 but have problem with rolling back (4.6.3 with the same problems). the error "the wizard was interrupted before mcafee epolicy orchestrator could be installed" Please see attach file. Thanks!

        • 1. Re: epo 4.6.4 install rolling back
          rackroyd

          Ignore these Index warnings, that's just Sql having a grumble and would not stop the installer.

           

          install:
               [echo] Install called for EPOCore (version 4.6.4.202)
               [echo] EPOCore:Install Start running SQL

          [execute-sql] WARN: Warning! The maximum key length is 900 bytes. The index 'IX_EPOPolicySettings_TypeIDName' has maximum length of 1028 bytes. For some combination of large values, the insert/update operation will fail.
          [execute-sql] WARN: Warning! The maximum key length is 900 bytes. The index 'IX_EPOPolicySettings_Name' has maximum length of 1024 bytes. For some combination of large values, the insert/update operation will fail.
          [execute-sql] WARN: Warning! The maximum key length is 900 bytes. The index 'PK_EPOAlertAliasMapping' has maximum length of 1530 bytes. For some combination of large values, the insert/update operation will fail.
          [execute-sql] WARN: Warning! The maximum key length is 900 bytes. The index 'IX_EPONotificationLog_BranchNodePath' has maximum length of 1024 bytes. For some combination of large values, the insert/update operation will fail.
          [execute-sql] WARN: Warning! The maximum key length is 900 bytes. The index 'IX_EPONotificationLog_ReceivedProductFamilies' has maximum length of 2048 bytes. For some combination of large values, the insert/update operation will fail.

           

          From the data provided this is the apparent point of failure:

           

          BUILD FAILED
          C:\PROGRA~2\McAfee\EPOLIC~1\server\extensions\installed\EPOCore\4.6.4.202\instal l.xml:20: java.sql.SQLException: Invalid column name 'tagid'.

           

          Which would suggest something very odd in the DB, as that (tagid) is not an expected column name of any ePO table as far as I know.

           

           

          Perhaps you are trying to use an existing Sql instance.

          Make sure if this is a clean install attempt that all prior instances of the ePO database are removed first.

           

           

          Rgds,

           

          Rob

          • 2. Re: epo 4.6.4 install rolling back
            smalldog

            Thanks Rob, this is fresh install. I tried remove database and reinstall that still rolling back action. Maybe reinstall OS and try again?

            • 3. Re: epo 4.6.4 install rolling back
              smalldog

              I can install epo with restore default settings on windows server 2008 R2. Thanks Rob!

              • 4. Re: epo 4.6.4 install rolling back
                kamil.wyroslak

                Hi

                I have the same problem on windows 2003 r2

                Any ideas for me?

                • 5. Re: epo 4.6.4 install rolling back
                  alexn

                  Kamil.

                  Could you run installer with

                  setup.exe DEBUGOUTPUT=2

                   

                  and from temp folder copy MSI install log, and any other error message that you will see during install. Keep watching and see where installer hanges  and then at what point it rolls back?

                   

                  Before running installer remove previous logs from temp folder.

                   

                  Also post event parser and orion logs from server DB folder.

                   

                  Let you know one thing "Roll back is same for all " but reasons are different so I wanaa see actual cause in your case.

                   

                  alexn

                  • 6. Re: epo 4.6.4 install rolling back
                    kamil.wyroslak

                    ok

                    please look my logs and picture file

                    mayby problem is my POLISH language on windows server 2003

                     

                    http://hesperos.pl/mcafeelogs.zip

                    http://hesperos.pl/error.png

                     

                     

                    thnx

                    • 7. Re: epo 4.6.4 install rolling back
                      alexn

                      One more question.

                       

                      after roll back process do you see all epo services "Stopped" or "Running" Or "Stopping".?

                      • 8. Re: epo 4.6.4 install rolling back
                        kamil.wyroslak

                        NO

                        AFTER ERROR I SEE ALL SERVICES, BUT I CANT RUN IT

                        AFTER ROLLBACK I CANT SE ANY MCAFEE SERVICES, ANY MCAFEE FOLDERS etc

                        • 9. Re: epo 4.6.4 install rolling back
                          alexn

                          I mean

                          McAfee Application Server service

                          McAfee Event Parser service

                          McAfee Apache  service

                           

                          Do you see all above them stopped, right and option to start them is grayed out?

                           

                          Could you also give a try to restart SQL  server service and SQL Browsing Service?

                          And also mention your current ePO version and the patch that you are trying to apply.

                           

                          on 5/23/13 10:32:38 AM CDT
                          1 2 3 Previous Next