1 2 Previous Next 12 Replies Latest reply on Jan 25, 2013 2:41 AM by bugsec

    Problem with EEPC on Dell Latitude 5430

    mattw2

      Has anyone had experience of using a Dell Latitude 5430 with Endpoint Encryption for PC 5.2.11 (or 5.2.5).

       

      Issue is on both XP and Windows 7, but in slightly different ways.

       

      on both the client installs and reboots the PC....

       

      on XP - comes up with an error E0020009 message "Unable to get disk partition information". This is most times it syncs with the server.

      At a seemingly random point, it doesn't come up with the error, and downloads users from server and installs the pre-boot environment and starts encrypting the drive. However, after a reboot, or next sync it either comes up with the above error again, or restarts encryption from the start (ie progress bar reverts to start).

       

      on windows 7 - successfully communicates with server, downloads users, installs pre-boot environment.

      However, each time it then syncs with the server, it appears to restart encrypting the drive... the progress bar reverts to the beginning. 

       

      Have tried the controller in both ATA and AHCI mode, same issue.

      I've re-installed OS a few times on a test system, but get same issue, and a number of others of same type with XP have same issue.  The key problem here is with XP, however.

       

      Does anyone else have experience of EEPC with Dell E5430 and able to suggest what the issue might be.

       

      I have already logged with McAfee support, and now wondering if i'll need to log an issue with Dell.

      I've also tested a Dell E6230, whch is fine. One other test i have in mind is to temporarily replace the 300GB drive with a smaller (60GB) to see what happens.

       

      thanks in advance

        • 1. Re: Problem with EEPC on Dell Latitude 5430

          Hi mattw2,

           

          When  you install the Windows OS on both machines are you using an OEM version of Windows (a Dell disk) or a retail type? I would stay away from the OEM disk. Before encryption are there any extra partitions other than the Windows partition such as Dell recovery partitions, Windows recovery partitions, etc?

           

          I would suggest to change the machine to AHCI, reformat and ensure there is only one partition on the hdd for the Windows OS, install Windows XP and fully patch it to SP3. Don't install anything extra - just the OS. Check to be sure the machine has the latest BIOS installed. I would also recommend to ensure nothing 'extra' is plugged into the machine (sd cards, external HHDs, other usb peripherals, etc) and that the machine is not on a dock.

           

          Once you have the above try to encrypt again. This will rule out anything software related and leave only issues with the machine's Hardware/BIOS.

          • 2. Re: Problem with EEPC on Dell Latitude 5430

            Hi mattw2,

             

            We're having the same issue in Windows XP. Have you had any feedback from McAfee yet? We opened a support case with Dell and hit a brick wall as they apparently don't support Windows XP on the E5430 despite supplying drivers on their website and support in ImageDirect.

             

            We've tried ATA and AHCI with our Dell supplied image. We've also tried a clean Windows XP install in ATA mode but the system wont accept the F6 driver to install in AHCI mode. We've also tried our image without the utility partition and get the same error each time.

             

            I have installed on Windows 7 and it started encrypting the drive but I didn't do a second synchronisation whci might be a way into Dell for support. I'll give that a go later this week.

            • 3. Re: Problem with EEPC on Dell Latitude 5430

              the progress bar restarting is what's meant to happen - it's showing you the progress, not how much of the drive is encrypted.

               

              We changed this in v7 as everyone seems to get confused by it.

              • 4. Re: Problem with EEPC on Dell Latitude 5430
                mattw2

                Hi Bugsec,

                 

                Unfortunately, I've cancelled our request with McAfee support, as we've decided not to progress the issue.

                 

                I'd tried the A09 BIOS that Dell released on their site earlier this month, but that did not help. And as we only have Next business Day hardware support, we would have had to pay them to log any other type of support call.

                 

                McAfee were helpful as far as they could be, but had asked if we could lend them an E5430 for testing, unfortunately we were unable to do so. 

                 

                Subsequent to my initial post, I did find that Windows 7 works fine, it does encrypt  and stay encrypted, so issue is just XP it seems. Also, as you've been told Dell aren't actively supporting XP on E5430, it could be down to that, and the drivers not being sufficient... which begs question, why release drivers at all.

                 

                So, all I can recommend is log a call with McAfee, but don't be surprised if you are asked if you can lend them a laptop for testing...

                 

                the main reason we've chosen not to progress is we're phasting out Windows XP for 7, and have sufficient older laptops we can give to people who need to use XP, and save the E5430s for our windows 7 users.

                 

                sorry.

                 

                Matt.

                • 5. Re: Problem with EEPC on Dell Latitude 5430

                  the progress bar restarting is not the issue. The issue is the error message in XP and the failure to install the pre-boot environment and encrypt the drive.

                   

                  we've tried EEPC 5.2.11 and 5.2.12 both fail on E5430 systems but work on E63xx systems with Windows XP

                  • 6. Re: Problem with EEPC on Dell Latitude 5430

                    Thanks for the update Matt

                     

                    Graham

                    • 7. Re: Problem with EEPC on Dell Latitude 5430

                      sounds like the old unaligned memory bug that a whole bunch of machines had some time ago.

                       

                      Maybe this KC will help?

                       

                      https://kc.mcafee.com/corporate/index?page=content&id=KB72826&actp=search&viewlo cale=en_US&searchid=1358873186987

                      • 8. Re: Problem with EEPC on Dell Latitude 5430

                        I've seen that one and tried downloading the attachment but the zip file although it has a size is empty. I've also tried the solution in https://kc.mcafee.com/corporate/index?page=content&id=KB73659&actp=search&viewlo cale=en_US&searchid=1358929241722 in V5.2.12 but adding the file defscm.ini into the location stated then building a new package had no effect and I didn't get the expected entries in the client log in either ATA or AHCI mode

                        • 9. Re: Problem with EEPC on Dell Latitude 5430

                          there's not much that can go wrong with the defscm.ini file soution - if it's present in the same folder as sbadmin.exe, when you create an install set it will be included. The only reason for it not to be is if someone hard coded an scm.ini into the package - something we don't reccomend or do as standard.

                           

                          The entries don't go into the client log - they go into SCM.ini on the client machine - perhaps check there?

                           

                          Maybe contact your platinum support team and ask them to make the memory test tool available to you?

                          1 2 Previous Next