6 Replies Latest reply on Dec 23, 2012 3:49 AM by Peacekeeper

    McAfee registry entry messing up VBScript even after uninstall

      I have a VBScript startup program on Windows 7 that occasionally doesn't run after installing new software, and now it's failed for the last three boots. A notification tells me the VBScript engine can't be found. A post on Microsoft's website says there are two registry entries needed for VBScript (see below image). On my computer, one of the entries isn't as it should be - the data should be C:\Windows\system32\vbscript.dll but instead it's a path to a file in a McAfee directory. I uninstalled McAfee after the free trial that came with my computer but it looks like McAfee didn't cleanly uninstall itself. As you can see from the picture, I "cannot edit" this data in the registry. Could someone tell me how to edit this data, assuming it's safe to do so, so I could get VBScript to work?

       

      UPDATE 1: I found the KnowledgeBase article at https://kc.mcafee.com/corporate/index?page=content&id=KB71660 and tried adapting "workaround 2" to my situation, but it's not possible because the only McAfee files I have are:

       

      C:\Program Files (x86)\Common Files\mcafee\Installer\mcinst

      C:\Program Files\Common Files\McAfeeFPDetect\fpdtctrs.dll

      C:\Program Files\Common Files\McAfeeFPDetect\McFPDtct

       

      There seems to be no ScriptSn to unregister.

       

      UPDATE 2: I created a plain text file at C:\Program Files\Common Files\McAfee\SystemCore\ScriptSn.20120810174448.dll so there would be something there to unregister. I still couldn't replace it with C:\Windows\system32\vbscript.dll in regedit. Then I tried at the command line:

       

      cd C:\Program Files\Common Files\McAfee\SystemCore

      regsvr32.exe /u ScriptSn.20120810174448.dll

       

      But I got a message that said:

       

      "The module "ScriptSn.2012810174448.dll" may not compatible with the verison of Windows that you're running/ Check if the module is compatible with an x86 (32-bit) or x64 (64-bit_ version of regsvr32.exe."

       

      I don't know why Windows cares that something I'm unregistering isn't compatible. It should be glad I'm trying to unregister it. ScriptSn.20120810174448.dll is still in the registry.

       

      Message was edited by: borad on 12/22/12 2:14:34 AM CST