1 2 3 Previous Next 20 Replies Latest reply on Dec 25, 2012 4:23 AM by Hayton

    McAffee Service Host stopped working

    halton

      I have gotten  two of these error messages  in the past few days and I attach the following log. Can someone tell me what it says and if it serious. I ran the virtual technition and saved the log . Just before I ran the virtual technition it updated itself and let me know that it can't continue run unless I rebooted my system is this normal?

       

       

      thank you.

       

       

      Jerry

       

      Message was edited by: halton on 12/17/12 1:44:52 PM CST
        • 1. Re: McAffee Service Host stopped working
          Hayton

          1. I keep getting Mcsvhost crashes too. I put a question down for the conference call but it's at the end of the list so if we don't get to it today it won't get dealt with for about 3 weeks (that's December for you). What the debug logs are saying is that it's an Access Violation (a pointer to a protected area of memory) but this doesn't necessarily have to be an invalid pointer in the code; I've seen this come up in hardware forums a few times where it turned out to be a failing memory module. We could always run memtest86 to do a thorough check of installed memory but it takes a long time to do the checks ....

           

          2. There's nothing in the zipped MVT log file to indicate any problem, so your installed components are okay. Which I expected (no problems with mine either).

           

          3. Yes, I encountered this when I ran MVT yesterday. I don't know why it did this, unless the app has had a major upgrade.

          • 2. Re: McAffee Service Host stopped working
            halton

            Thank you for all your help and patience in the past year.

             

             

            Best wishes to you for the coming year.

             

             

            Jerry

            • 3. Re: McAffee Service Host stopped working
              Hayton

              Hey, not so fast. We talked about this on the call, and I was supposed to ask you when you see the mcsvhost-has-crashed message. I see it most often when XP comes out of hibernation, although not always (and it happens other times without warning).

               

              Fortunately on XP I've got Dr Watson, which produces copious amounts of debug information, and that could be useful. You've got Vista, as I recall - does that have Dr Watson, or did Microsoft drop it after XP? You have also had this happen before, whereas for me it started back in November after a Security Center update.

               

              So, how often do you see it? Out of the blue and unpredictable, or most often after (or while) doing something? I've got all the important processes set to restart automatically if they fail (via msconfig) so for me it's no big deal, I just have to wait a minute or so and everything switches back on. If your processes go down and stay down, that might look like more of a problem (but you just need to tinker with the settings to change that).

               

              And no, MVT would know nothing about any of this. If it's not a memory problem it's perhaps a code bug, and MVT doesn't do any checking for those.

              • 4. Re: McAffee Service Host stopped working
                halton

                You have talked mostly about Windows XP my system is Windows Vista HomePremium. Lately I had one show up the 12th and one show up the 17th  both in December.

                 

                 

                 

                Jerry

                • 5. Re: McAffee Service Host stopped working
                  MaineNightOwl

                  my mcafee service host started giving me issues and problems back in late november 2012 when their was a mcafee security center software update, upgrade. from their i had other issues and problems with my mcafeee internet security suite so i uninstalled the entire software and used the Mcrp removal tool and a registry cleaner that deleted and cleaned out the rest of the mcafeee left over files in the registry. anyhow; i downloaded and reinstalled a fresh mcafee internet internet security . when mcafee internet security was installed completely first thing i got was a dr.watson, and dr.win error message as i use windows xp home edition and then a pop up came up on my screen saying mcafee McsvHost has encountered a problem and must close. all that meant to me is i needed to reboot my machine; to which i did. once my machine rebooted not long after that i got the same error messages and my Mcafee McsvHost closed on me, i thought but it appeared back in my windows task manager but its not working . it shows my firewall is ( green )  on the outside  but when i click open the firewall it says off and nothing works in the firewall section . next i went to control panel and clicked on services and scrollerd thru the mcafee programs . i found a service called Mcafee McMpfSvc and its showing it being disabled . i tried to enable it but its denying me access ( unable to open service McMpfsvc for  writing on local computer Error 5 Access is denied. ) .

                   

                  Is Mcafee going to come up with a fix for this or is their a work around to get all my firewall options working again properly ? can someone please contact me on here Or At My E-mail Address

                   

                  Your email address has been removed to prevent webcrawlers harvesting it for sending spam - Hayton

                   

                  Message was edited by: Hayton on 19/12/12 15:20:18 GMT
                  • 6. Re: McAffee Service Host stopped working
                    halton

                    My issues are with my operating system Windows Vista HomePremium with a 32 bit operating system.

                     

                     

                    Jerry

                    • 7. Re: McAffee Service Host stopped working
                      Hayton

                      One Vista, several XP machines. It's likely that what I see in the debug logs - Access Violation - is not dependent on the operating system. mcsvhost is trying to access a memory location that Windows has put out of bounds, so this is likely to be a programming error - perhaps a pointer to a null address. Doesn't have to be that, of course.

                       

                      @halton, do you get any automatically-generated error logs in Vista? XP gives quite a lot of info in the Dr Watson report and McAfee will be using that as a starting point. We don't have anything similar yet for Vista.

                       

                      @MaineNightOwl, McAfee locks down its processes to prevent unauthorised access or modification. mpfsvc is indeed the firewall but if you're having problems with it not turning on that's a different issue and needs a different thread to sort it out. Possibly using that registry cleaner has messed something up, they often do.

                      • 8. Re: McAffee Service Host stopped working
                        halton

                        I don't know.  If I did where would I find them?

                         

                         

                        Jerry

                        • 9. Re: McAffee Service Host stopped working
                          Hayton

                          Good point. Probably in a log file, so a .log suffix (but maybe in a .txt file), but not necessarily in Windows (where you would expect).

                           

                          The best I can suggest is, next time it happens (note the cheerful optimism) wait a few minutes and then use Windows search to find any .log or .txt files created or modified that day.

                          1 2 3 Previous Next