7 Replies Latest reply on May 1, 2013 2:58 PM by Peter M

    Can't remove mcafee

      It's been weeks since i've been wanting to remove Mcafee off my computer, and i can't do that. Right now when i try to get mcafee running i get a "white screen," and somehow

      it blocks a new anti virus i want to install on my computer. I know the firewall doesn't work either, but resolving the problem of the "white screen" is a major concern. After spending

      money on mcafee over the past years i'd really want to move away from this disabilitating program.

        • 1. Re: Can't remove mcafee
          Peter M

          The white screen is caused by something on your machine causing jscript corruption and is easily cured by the 'Blank....' link in my signature below.  However, the usualy way of getting rid of software is to uninstall it via Control Panel > Programs > Uninstall a Program (Add or Remove Programs in XP), then if you want to make sure it's all gone run the MCPR cleanup tool which is found in a FAQ listed under Useful Links at the top of this page.  Reboot and then try installing whatever it is.





          Message was edited by: Ex_Brit on 13/12/12 11:32:29 EST AM
          • 2. Re: Can't remove mcafee

            I, too, need to remove McAfee.  It's been a nightmare. I am running McAfee Cox Security Suite, and it absolutely will not allow me to uninstall it.  The reason I want to is that every time an alert comes up, it can't be removed.  It sits on my screen covering whatever else I am trying to do.  Can't minimize, can't close it.


            I tried Add/Remove Programs, but when I click the final Remove button, every single time, nothing happens.  The button is dead.  So I tried removing McAfee services from the startup using msconfig.  I can uncheck them, but I get a message that I don't have access. 


            I am the only user.  I am the administrator.  I've tried this in Safe Mode logged in as administrator.  No go.  Similarly, I thought I'd just remove it from the Registry using Regedit.  I get a message that I don't have permission!  If I don't, who the **** does?  Excuse my asterisks.  It's ridiculous that I should have to reimage my machine just to remove a program.  In my opinion, McAfee is acting just like a virus.


            Run as administrator doesn't work.  I can't change anything on my McAfee settings.  If I turn off the Firewall, it just says it's still on.  I used to like McAfee.  Now I just want it off.  I've searched forums, and all the normal things don't work.  Even gutting my registry.


            I am running Windows XP Home SP3 with all updates on a Toshiba Satellite laptop.  If I click the litle McAfee shield in the task bar--which I can never, ever get to go away--it says I'm running the Cox Security Suite Powered by McAfee.  Cox has nothing on it.   If I click the About link within the McAfee interface, a blank, white pop-up comes up.  If I try to return the suite to defaults, the stupid alert that covers 1/5 of my screen comes up.  The button on it never work.  I can't get my work done like this.  McAfee has hobbled my computer.


            Help someone please?


            Message was edited by: ddd1 on 5/1/13 12:35:37 PM CDT



            Message was edited by: ddd1 addendum:  When I use Windows Remove Programs interface, and I click on Remove, I get a warning pop-up that I still have an active subscription.  It asks me to confirm that I want to remove the program or cancel.  Only the Cancel button works.  The Remove button is dead.  Just wanted to be clear. on 5/1/13 12:40:20 PM CDT
            • 3. Re: Can't remove mcafee
              Peter M

              Blank interfaces or inoperable buttons are usually a sign of corruption or an out-of-date system.  Assuming Microsoft Update is current, have you been running any registry cleaners lately as this is pretty normal behaviour if so?  See if the cleaner has a reverse or a restore setting.


              As I stated in my post above the second to last link in my signature has several steps you can try to solved the problem ('Blank'....).


              If you can't remove McAfee the normal way, there is always the removal tool which you can download to your desktop and run from there.  It's linkid under Useful Links at the top of this page.


              If all else fails, Technical Support is free and available by phone or online chat and linked also under Useful Links.

              • 4. Re: Can't remove mcafee
                Peter M

                Another factor to look at is Internet Explorer.  Even if you don't use it as your default browser, McAfee does, so make sure you have IE8 installed and set to its default settings.   It doesn't have to be your default browser, just be up to date (plus all its add-ons of course).

                • 5. Re: Can't remove mcafee

                  I can hardly believe it, but minutes after posting my plea for help above, I found the McAfee removal tool.  (I've been searching for about a year and had even bought a new laptop because I couldn't use this one with the alert windows blocking everything.)


                  The instructions said that it is important to remove the McAfee software first using the Windows Add/Remove Programs interface. Since that did not work for me (dead Remove button) no matter how many times I tried it in Safe or Normal mode, I tried the MCPR tool anyway. 


                  Lo and behold!  It worked.  Or seems to have.  I had to use Regedit to get rid of the Mcafeeupdater entry, but the rest seems to be gone.  I am relieved.  The link to the tool is here:




                  I'll update this entry if there is any aftermath.

                  • 6. Re: Can't remove mcafee

                    Yup, I had been completely up to date and kept things clean.  I have updates set to automatic for Windows and McAfee.  I missed the Useful Links in the red menu bar above, since I'd been looking at the side bar and thought the ones above were more generic.  MCPR was a lifesaver.

                    • 7. Re: Can't remove mcafee
                      Peter M

                      Glad you are OK now.