Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
1335 Views 5 Replies Latest reply: Nov 30, 2012 5:43 PM by nick.olson RSS
nick.olson Newcomer 13 posts since
Nov 1, 2012
Currently Being Moderated

Nov 30, 2012 10:57 AM

MWG 7.3 User Interface Certificate Import Problem

Good Morning,

 

For the past week or so I've been trying to get the User Interface Certificate import to work on MWG 7.3  (Not for SSL scanner, but so we stop getting prompted for bad cert whenever we log into the user interface)

 

I've generated a new private key and CSR in OpenSSL then took the CSR to our Internal CA (a MS AD Certificate Services Server).

Something like "openssl req -nodes -newkey rsa:2048 -keyout mwg.key -out mwg.csr"

 

I Downloaded the cert and cert chain in Base64 from the CA.

 

I then try to import the cert at Configuration -> User Interface -> User Interface Certificate.

I clicked Import and browsed to the Cert and Private Key

 

Clicked OK and I get the error "Error importing certificate: No Certificate or Private Key Found"

 

 

I've tried several times generating new certs and trying to get them to import but without any luck getting it to import.

I have even tried installing the cert directly from the CA to IE then exporting it.

Also tried generating a self signed cert and having the CA sign it and reimport it but that also didnt work.

 

 

There has to be something silly that I am missing.  Any ideas?

 

Any help would be greatly appreciated.

 

Thanks!

Attachments:
  • jont717 Champion 291 posts since
    Jan 4, 2011
    Currently Being Moderated
    1. Nov 30, 2012 12:00 PM (in response to nick.olson)
    Re: MWG 7.3 User Interface Certificate Import Problem

    I don't think you are missing anything.  I am having the exact same problem.

     

    I am going to call McAfee and see what the issue is.  Has to be something with the changes on 7.3. 

  • jont717 Champion 291 posts since
    Jan 4, 2011

    I have a case open and they are leading to the same issue.  My key file is just as yours.  It does not have RSA at the top or bottom. 

     

    I am trying to convert it. 

  • jont717 Champion 291 posts since
    Jan 4, 2011

    I got my private key to work.

     

    Used the command:

     

    openssl rsa -in File.key -out File.pem

     

    then:

     

    openssl rsa -in File.pem -des3 -out FileNew.pem  <---this allowed me to set a password

     

    Sweet!

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points