3 Replies Latest reply on Nov 27, 2012 2:08 PM by PhilM

    SG565 Unable to get DHCP address from new cable BB device

    PhilM

      I apologise if this initial post is light on diagnostic detail, but I had to come into the office and do some real work.

       

      I've been running an SG565 at home for probably 4 years (a kind gift from the guys at the former Secure Computing UK outfit, before they became part of McAfee) on my cable broadband service. Setup and configuration was a doddle - simply connect port B of the SG to the Ethernet port on the supplied cable modem and configure port B to use DHCP to obtain an address. This has worked flawlessly until today.

       

      My ISP has been rolling out a nationwide infrastructure upgrade in the UK which has resulted in a trebling of my connection speed. However, in order to facilitate this they had to send me a new device as my old cable modem didn't support the new speeds. My new "SuperHub" (as it is called) arrived today. It is one of these consolidated modem/router/firewall/wireless devices (and it is actually made by Netgrear). I connected it in place of my old cable modem and went through the prescribed activation process. This was all done using a laptop connected directly to the SuperHub and everything was hunky-dory. An online speed test showed I was getting my new speed and I was happy with the results.

       

      Fortunately the ISP has recognised the more technically inclined who have their own infrastructure and don't need all of the additional functionality over and above the physical connectivity to the broadband service. So, accessing the device's GUI, I located the option to revert to basic 'cable modem' mode and it went through an obligatory re-boot. Once it had re-booted and with my laptop still connected I ran the ipconfig /release & ipconfig /renew commands and this resulted in my laptop now having a public IP address, rather than the private address it had previously been issued with.

       

      OK, I thought; time to connect everything back up again. Re-booting the cable device again, I then also logged into my SG and re-booted that also. After a short while I was able to access the SG internally, but when I looked at the Network Configuration screen it claimed that port B was still "waiting" for its IP address to be assigned. Approximately 5 minutes later the entire cluster of LEDs on the front panel started flashing in unison.

       

      For the time being I have put the external device back into "Hub" mode and the SG is perfectly happy about that - it has been able to get a 192.168 DHCP address from the hub, but this currently means that I have a double NAT environment to contend with (which will interfer with my IPSec VPN tunnels), but at least it works.

       

      I will take another look when I get home to see if I can extract anything of use from the SG's logs. But if anyone can think of what may have happened, and why, I'd be very grateful to hear from them.

       

      Many thanks in advance.

      -Phil.

        • 1. Re: SG565 Unable to get DHCP address from new cable BB device
          PhilM

          Don't worry - looks like I've sorted it.

           

          Maybe it was down to me being a little premature. Having returned home, I decided to put the ISP-supplied device back into simple cable modem mode and after it re-booted I then switched it off for 15 minutes.

           

          I have a recollection of these devices almost 'pairing' themselves with the first MAC address they find. This, of course, was my laptop (when I did all the tests). So, I'm guessing that when I swapped the Ethernet cables over so that the SG was connected to it instead of my laptop, it issued a DHCP request and the cable modem was telling it to take a hike. However, switching it off for a period of time is normally enough to flush out any recollection of the previously-connected MAC address (I think this also why some consumer cable Firewall/Routers often have an option to spoof the MAC address).

           

          Anyway, after re-booting the SG I saw more familiar behaviour from the LEDs on the front panel, and when I checked the diagnostics I can now see that Port B has a public IP address assigned to it.

           

          Panic over!

           

          -Phil.

          • 2. Re: SG565 Unable to get DHCP address from new cable BB device

            Good to hear.

             

            Out of interest what is the model of the netgear cable modem/bridge/router ?

             

            I might try to do the same with mine.....if the firmware allows it.

            I was not aware of this option on my netgear cable device.

            • 3. Re: SG565 Unable to get DHCP address from new cable BB device
              PhilM

              That is a good question. It is only by digging around online that I discovered this myself.

               

              The device itself is supplied by the UK ISP Virgin Media and goes by the name "Super Hub".

               

              http://help.virginmedia.com/system/selfservice.controller?CMD=VIEW_ARTICLE&ARTIC LE_ID=345044&CURRENT_CMD=SEARCH&CONFIGURATION=1002&PARTITION_ID=1&USERTYPE=1&LAN GUAGE=en&COUNTY=us&VM_CUSTOMER_TYPE=Cable

               

              Compared to my old cable modem, it's a bit of a beast. Whereas the old CM was about 1/3rd the size of my SG565 (and happily sat on top of it), the Super Hub is probably as big, if not bigger, than the SG and the way the ports are oriented is clearly designed to stand up (rather than lie down). This required a bit of a re-shuffle as I didn't have sufficient clearance to put the SH where my old CM had previously sat.

               

              The GUI has been heavily modified to suit the target consumer audience, so the landing page only contains a couple of key options. There is, however, an advanced settings link (not hidden away) which you can select and this then changes the GUI into something more like you would expect to see.

               

              When you swtich it into modem/bridge/passthrough mode, you are left with an even more minimal GUI which only provides options to change the admin password or to switch it back into full Super Hub/router mode. As far as I know the firmware releases are pushed (I don't recall seeing a manual upgrade option on this device) and I held off upgrading my broadband connection because I was aware that it wasn't until a couple of months ago the firmware was released to allow this modem mode to be invoked.