9 Replies Latest reply: Oct 15, 2012 1:02 PM by samd RSS

    Run Client Task Now never seems to work

    samd

      I have a task for deploying Patch 2 for 8.8 of McAfee.  However it seems I can never get the Run Client Task Now to work. This has happened before where the Run Client Task Now doesn't work and I have to resort to letting it deploy itself at the next enforcement.  It's a bit frustrating as I also use this method sometimes to deploy a new version of the agent and this doesn't work. I end up using the Deploy Agent instead, which does work.  So I'm not understanding why I'm having this problem with the Run Client Task Now functionality.

       

       

      Thursday, October 11, 2012 2:15:22 PM  Info  Agent  Agent is connecting to ePO server

      Thursday, October 11, 2012 2:15:22 PM  Info  Agent  Agent communication session started

      Thursday, October 11, 2012 2:15:23 PM  Info  Agent  Agent communication session closed

      Thursday, October 11, 2012 2:15:23 PM  Info  Agent  Package uploaded to ePO Server successfully

      Thursday, October 11, 2012 2:15:25 PM  Info  Agent  Agent communication session closed

      Thursday, October 11, 2012 2:15:25 PM  Info  Agent  No package received from ePO Server

      Thursday, October 11, 2012 2:15:25 PM  Info  Agent  Agent is connecting to ePO server

      Thursday, October 11, 2012 2:15:25 PM  Info  Agent  Agent communication session started

      Thursday, October 11, 2012 2:15:25 PM  Info  Agent  Sending the next batch of 1 data channel items

      Thursday, October 11, 2012 2:15:53 PM  Info  Scheduler  Scheduler: Invoking task [VirusScan 8.8.0.849 (patch 2) install]...

      Thursday, October 11, 2012 2:15:53 PM  Info  Scheduler  Added a new task VirusScan 8.8.0.849 (patch 2) install to Scheduler's task list

      Thursday, October 11, 2012 2:15:55 PM  Info  Agent  Agent communication session closed

      Thursday, October 11, 2012 2:15:55 PM  Info  Agent  No package received from ePO Server

      Thursday, October 11, 2012 2:15:55 PM  Info  Agent  Agent is connecting to ePO server

      Thursday, October 11, 2012 2:15:55 PM  Info  Agent  Agent communication session started

      Thursday, October 11, 2012 2:15:55 PM  Info  Agent  Sending the next batch of 1 data channel items

      Thursday, October 11, 2012 2:16:23 PM  Info  Updater  Unable to find a valid repository.

      Thursday, October 11, 2012 2:16:24 PM  Info  Updater  Update process failed.

      Thursday, October 11, 2012 2:16:54 PM  Info  Agent  Agent communication session closed

      Thursday, October 11, 2012 2:16:54 PM  Info  Agent  No package received from ePO Server

      Thursday, October 11, 2012 2:16:54 PM  Info  Agent  Agent is connecting to ePO server

      Thursday, October 11, 2012 2:16:54 PM  Info  Agent  Agent communication session started

      Thursday, October 11, 2012 2:16:54 PM  Info  Agent  Sending the next batch of 1 data channel items

      Thursday, October 11, 2012 2:17:18 PM  Info  Agent  Agent is looking for events to upload

      Thursday, October 11, 2012 2:17:22 PM  Info  Scheduler  The task VirusScan 8.8.0.849 (patch 2) install is deleted (ID={F8ADF0BA-433B-47DD-8C08-222A6F15BE66})

      Thursday, October 11, 2012 2:17:50 PM  Info  Management  Enforcing Policies for McAfee Agent

      Thursday, October 11, 2012 2:17:50 PM  Info  Agent  Agent Started Enforcing policies

      Thursday, October 11, 2012 2:17:54 PM  Info  Agent  Next policy enforcement in 5 minutes

      Thursday, October 11, 2012 2:17:54 PM  Info  Agent  Agent finished Enforcing policies

      Thursday, October 11, 2012 2:17:54 PM  Info  Management  Enforcing Policies for EPOAGENT3000

      Thursday, October 11, 2012 2:17:54 PM  Info  Management  Enforcing Policies for EPOAGENT3000META

      Thursday, October 11, 2012 2:17:54 PM  Info  Management  Enforcing Policies for VIRUSCAN8800

        • 1. Re: Run Client Task Now never seems to work
          alexn

          Hi,

          Verify the correct domain credentials here.

          Click Menu>System Tree Actions>New systems

           

          Check your domain, user name and password here.

          • 2. Re: Run Client Task Now never seems to work
            samd

            I don't save domain credentials as most systems are in a domain and some are not.  By the way a product deployment you don't enter a username and password.

             

            I notice this line from what I poste. Is this the problem?

             

            Thursday, October 11, 2012 2:16:23 PM  Info  Updater  Unable to find a valid repository.

             

            Message was edited by: samd on 10/11/12 3:18:46 PM EDT
            • 3. Re: Run Client Task Now never seems to work
              jenny

              Unable to find a valid repository indicates a problem... could you please post McScript.log ?

              also what version of McAfee Agent are you using ?

              • 4. Re: Run Client Task Now never seems to work
                samd

                Actually Mcafee support figured this out by looking at the mcscript.log file as mentioned.  I hadn't opened the port on our firewall for "Agent-to-server communication" I had only opened the one for "Agent-to-server communication secure".  Not sure why I didn't open that port but it was seen in the log file.

                 

                Also learned that you cannot use a client task to install Mcafee if Mcafee already exists because of Mcafee protectiing itself. However I should be able to update the agent using a client task. Currently it's updating the agent now but the task ends up showing a failure. Still troubleshooting.

                  I get return code 33 in mcscript.log when I try to install the agent via a client task. This is even with a forceinstall.

                 

                2012-10-12 12:22:31     I     #5544     ScrptMgr     Starting framework update.  Stopping framework services.

                2012-10-12 12:22:31     I     #5544     ScrptExe     Running "C:\ProgramData\McAfee\Common Framework\Current\EPOAGENT3000\Install\0409\FramePkg.exe" /forceinstall /UseLanguage=0409  /Install=Agent /Silent

                2012-10-12 12:22:31     I     #5544     ScrptExe     Running "C:\ProgramData\McAfee\Common Framework\Current\EPOAGENT3000\Install\0409\FramePkg.exe" /forceinstall /UseLanguage=0409  /Install=Agent /Silent

                2012-10-12 12:22:31     I     #5544     ScrptExe     Did not match searched path

                2012-10-12 12:22:31     I     #5544     ScrptExe     Executing "C:\ProgramData\McAfee\Common Framework\Current\EPOAGENT3000\Install\0409\FramePkg.exe" /forceinstall /UseLanguage=0409  /Install=Agent /Silent

                2012-10-12 12:22:31     I     #5544     ScrptExe     Attempting to run OnExit section on current script

                2012-10-12 12:22:31     I     #5544     ScrptMain     Run script return code: 33

                2012-10-12 12:22:31     I     #5544     ScrptMain     McAfee Update Engine is exiting with return code: 1

                2012-10-12 12:22:31     I     #5544     naInet     HTTP Session closed

                2012-10-12 12:22:31     I     #5544     MueEep     Invoking events withEventId " 0" Severity " 0" Productid " EPOAGENT3000" Locale " 0409" UpdateType " N/A" UpdateError " 0" New Version " N/A" Date Time " N/A" Script Id" 19462"

                 

                Message was edited by: samd on 10/12/12 12:29:16 PM EDT
                • 5. Re: Run Client Task Now never seems to work
                  jenny

                  If VSE 8.8 Patch 2 is already installed on your client machine and you run the client task Now to deploy the product once again, it will show in the client task log that the deployment has failed.

                   

                  "I get return code 33 in mcscript.log when I try to install the agent via a client task. This is even with a forceinstall."

                   

                  you cannnot forceinstall McAfee Agent by using a client task. However you might be using Deploy Agent from the Actions menu in ePO system tree. if the agent installation is failing with the forceinstall, it might be helpful to look into the McAfee Agent.log file to find out the error.

                  • 6. Re: Run Client Task Now never seems to work
                    samd

                    So the run client task can't be used for agents? The Mcafee support person said I could do this. I wish they would make this impossible for me to do if it won't work. Why not a message like "The agent is already is installed" or something like that.

                    • 7. Re: Run Client Task Now never seems to work
                      jenny

                      if you use Run client Task Now for deploying the same version/patch of McAfee Agent which is already installed on the client machine, it will not work and the deployment will fail. it will not indicate that the product is already installed on the machine. this can be seen by looking at the Agent Status Monitor that the task did try to run and the update finished. but nothing was installed as the product was already in there.

                      • 8. Re: Run Client Task Now never seems to work
                        jenny

                        there is a known issue with Run client task now feature in McAfee Agent 4.6 Patch 2 in case if you are using this version. please have a look at this Kb article

                        https://kc.mcafee.com/corporate/index?page=content&id=KB75516

                         

                        Message was edited by: jenny on 10/12/12 4:25:42 PM CDT
                        • 9. Re: Run Client Task Now never seems to work
                          samd

                          Thanks Jenny. It seems the Run client task will continue to remain an unused feature.

                           

                          Not sure why a a service pack would be released without this feature working but looks like there's a way around it.

                           

                          Message was edited by: samd on 10/15/12 1:49:11 PM EDT

                           

                          Message was edited by: samd on 10/15/12 2:02:00 PM EDT