3 Replies Latest reply: Oct 11, 2012 5:39 PM by cgrim RSS

    Authorization in MVM 7.0.7 ?

    schanghp

      Does anyone have experience this with new mvm scan engine? this is version 7.0 and logs show seems to be im not authorized to comunicated with the Controller?

       

      2012-10-10 22:45:16+00:00 |  | 4 | ScanEngineSvc | 0x0DFC | FSScanEngine: Log=0, LogXML=0, ThreadPool_Debug=0

      2012-10-10 22:45:16+00:00 |  | 4 | ScanEngineSvc | 0x0DFC | Re-posting EngineStatus...

      2012-10-10 22:45:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: HTTP 401 header received - read the body...

      2012-10-10 22:45:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: CHTTPClient::receive_body - [chunked on]

      2012-10-10 22:45:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: CHTTPClient::receive_body - [chunked] bytes read [5]

      2012-10-10 22:45:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: message in chunked mode: reading [0] bytes for chunk

      2012-10-10 22:45:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: stream finished.

      2012-10-10 22:45:17+00:00 |  | 1 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: Unable to send POST request. Requested resource was not found (return code 401)

      2012-10-10 22:45:23+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource returns (0xa0fbf062)[E_ENGINE_HTTP_SEND_FAIL]

      2012-10-10 22:45:23+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostEngineStatus returns (0xa0fbf062)[E_ENGINE_HTTP_SEND_FAIL]

      2012-10-10 22:46:16+00:00 |  | 4 | ScanEngineSvc | 0x0DFC | FSScanEngine: Log=0, LogXML=0, ThreadPool_Debug=0

      2012-10-10 22:46:16+00:00 |  | 4 | ScanEngineSvc | 0x0DFC | Re-posting EngineStatus...

      2012-10-10 22:46:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: HTTP 401 header received - read the body...

      2012-10-10 22:46:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: CHTTPClient::receive_body - [chunked on]

      2012-10-10 22:46:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: CHTTPClient::receive_body - [chunked] bytes read [5]

      2012-10-10 22:46:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: message in chunked mode: reading [0] bytes for chunk

      2012-10-10 22:46:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: stream finished.

      2012-10-10 22:46:17+00:00 |  | 1 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: Unable to send POST request. Requested resource was not found (return code 401)

      2012-10-10 22:46:23+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource returns (0xa0fbf062)[E_ENGINE_HTTP_SEND_FAIL]

      2012-10-10 22:46:23+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostEngineStatus returns (0xa0fbf062)[E_ENGINE_HTTP_SEND_FAIL]

      2012-10-10 22:47:16+00:00 |  | 4 | ScanEngineSvc | 0x0DFC | FSScanEngine: Log=0, LogXML=0, ThreadPool_Debug=0

      2012-10-10 22:47:16+00:00 |  | 4 | ScanEngineSvc | 0x0DFC | Re-posting EngineStatus...

      2012-10-10 22:47:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: HTTP 401 header received - read the body...

      2012-10-10 22:47:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: CHTTPClient::receive_body - [chunked on]

      2012-10-10 22:47:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: CHTTPClient::receive_body - [chunked] bytes read [5]

      2012-10-10 22:47:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: message in chunked mode: reading [0] bytes for chunk

      2012-10-10 22:47:17+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: stream finished.

      2012-10-10 22:47:17+00:00 |  | 1 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource: Unable to send POST request. Requested resource was not found (return code 401)

      2012-10-10 22:47:23+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostResource returns (0xa0fbf062)[E_ENGINE_HTTP_SEND_FAIL]

      2012-10-10 22:47:23+00:00 |  | 2 | ScanEngineSvc | 0x0DFC | CommHTTP::PostEngineStatus returns (0xa0fbf062)[E_ENGINE_HTTP_SEND_FAIL]

       

       

       

      Any ideas?

        • 1. Re: Authorization in MVM 7.0.7 ?

          Hi schanghp,

           

          Where is the scan controller installed, and is the engine setup to properly point to it?  I'm guessing by your first sentence that you have other scan engines / scan controllers that don't have this problem?  Is the engine on an MVM Appliance?  Can you telnet to the ScanController from the Engine ( on Port 3803)?

           

          -Cathy

          • 2. Re: Authorization in MVM 7.0.7 ?
            schanghp

            Hi Cathy

             

            Yes I have the scan controller on a separate server and other engines connected to it and they don’t have this problem.

             

            No the MVM engine is not an appliance is full installation..

             

            I can telnet to port 3803 and 3801 just the ip of the controller is being natted vs using the real ip.

             

            We think the firewall rules are setup wrong, since they are setup as unidirectional instead of bidirectional. So only the controller can initiate the communication to the engine.

             

            Do you think that could be the problem?

             

            Thanks

             

            Sheriy

            • 3. Re: Authorization in MVM 7.0.7 ?

              Hi Sheriy,

               

              Yes,  SC <-> SE must talk bidirectional on 3803... then the FCAgent <-> FCM on 3801...

               

              Let me know if that solves it for you.

               

              Have a great day!
              Cathy