3 Replies Latest reply: Jun 6, 2013 2:11 PM by Ex_Brit RSS

    Can't uninstall mcafee for mac


      I having an issue with a handful of MACs trying to get the older 1.1 version off and installing 1.2.  The uninstall of 1.1 fails in EPO, so I manually go to the mac and go to the directory /usr/local/McAfee and run ./uninstallMSC.  This gives a message "

      admin previleges are requires touninstall Mcafee Security".   I run chmod +x uninstalMSC and execute sudo ./uninstallMSC and the same error persists.  It does not prompt for the user password prior to running.   I have also done sudo su and then at an   administrative command prompt executed ./uninstallMSC with no luck. 


      Anyone else seen this or have an idea of how to fix?  The mac is experience no other problem outside of Mcafee that is known.

        • 1. Re: Can't uninstall mcafee for mac

          I am unable to reproduce the issue.  With 1.1 installed I can run sudo ./uninstallMSC and it will uninstall correctly.  I can also just run ./uninstallMSC and it will prompt for my credentials.  I would say verify that the account you are using has administrative rights, but if sudo su is working for you it sounds like you are.


          The uninstallMSC file is just a bash script; you might try working through it line by line in an administrative shell to see where it breaks and go from there.


          Also, I have updated several machines to v1.2 without uninstalling v1.1 so that may be an option for you.

          • 2. Re: Can't uninstall mcafee for mac

            From what I've gathered from your post is that you're trying to uninstall the previous version of McAfee and install the latest one? One tool I've used in the past has been AppRemover (a free tool that is now available for Mac computers), it thoroughly removes any security software on a computer (works best for someone in your case that wants to remove an old antivirus and replace it with another). You can download it at www.appremover.com, hopefully this helps!

            • 3. Re: Can't uninstall mcafee for mac

              Old thread and assumed solved, locking.