6 Replies Latest reply on Sep 27, 2012 11:05 AM by hem

    EPO 4.6.3 /  Agent Deployment Expired

      I have a brand new server with EPO 4.6.3 installed, ADS sync enabled, and populated with systems.  I tried to deploy agents to multiple systems, but am having no luck.  I have installed other EPO servers before, and have not had this issue.

      I have seen versions of this same problem posted in the community before but they are old, archived, and hold no answers. Anyone that has any new info about what this might be, any help would be appreciated.

       

      The server task log says:

      Server Task Log Information        

      Name:          Deploy McAfee Agent            

      Source:          Server Task            

      Start Date:          9/24/12 2:39:07 PM            

      Duration:          5 minutes            

      User Name:          admin            

      Status:          Failed

       

      Log messages:

       

       

       

                                  9/24/12 2:39:07 PM                                                                    Started: Deploy McAfee Agent to systems task                   
                                  9/24/12 2:39:07 PM                                                                    Deploying one agent                   
                                  9/24/12 2:44:32 PM                                                                    Completed: 0                   
                                  9/24/12 2:44:32 PM                                                                    Failed: 0                   
                                  9/24/12 2:44:32 PM                                                                    Expired: 1                   
                                  9/24/12 2:44:32 PM                                                                    Deploy McAfee Agent

       

      Things I have checked:

       

      1. Nothing listed in the subtasks tab at all

      2. Checked event viewer on server, no errors reported for EPO

      3. Can Ping and Resolve system names in System tree from the server itself, so I know it sees them on the network from and OS Level

      4. Ran MS Network Monitor 3.4 to check network traffic between server and system. The cap file shows absolutely NO traffic coming from the server destined to said system (all systems that I tried to deploy to had the same result)

      5. Have tried this from the EPO console running on the server itself and my system, same result.

       

      System Info:

      O/S MS Server 2008 R2 SP1 x64 running on VM ESXi 5.0.0 623860

      SQL 2008 R2 x64

      EPO 4.6.3

       

       

       

       

      Thanks!

        • 1. Re: EPO 4.6.3 /  Agent Deployment Expired
          hem

          Are the machines meeting environmental requirement as per KB#:KB56386)?

          • 2. Re: EPO 4.6.3 /  Agent Deployment Expired

            Hem,

             

            Yes they all meet those requirements.  I have many machines that are currently using being managed by another server and they can have agents deployed to them with no problems at all.

            When I try to deploy agents from this server, it seems to have a problem.

             

            Any other ideas?

             

            Thanks

            • 3. Re: EPO 4.6.3 /  Agent Deployment Expired
              hem

              Please deploy the agent on one machine (select the machine=>Action=>deploy agent) and post server.log and Orion log.

              • 4. Re: EPO 4.6.3 /  Agent Deployment Expired

                Hem,

                 

                Thanks again for your help.  I redeployed and agent and here are the logs

                 

                ORION LOG

                2012-09-26 14:52:55,600 ERROR [mfs:pool-2-thread-7] scheduler.Engine  - Deploy McAfee Agent] failed with exception

                java.util.concurrent.ExecutionException: com.mcafee.orion.core.cmd.CommandException: No agent deployments were successful

                at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222)

                at java.util.concurrent.FutureTask.get(FutureTask.java:83)

                at com.mcafee.orion.scheduler.Engine.runTasks(Engine.java:348)

                at com.mcafee.orion.scheduler.engine.EngineTask.run(EngineTask.java:57)

                at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)

                at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)

                at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)

                at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (ScheduledThreadPoolExecutor.java:98)

                at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(ScheduledThreadPoolExecutor.java:180)

                at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Schedu ledThreadPoolExecutor.java:204)

                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java: 886)

                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)

                at java.lang.Thread.run(Thread.java:662)

                Caused by: com.mcafee.orion.core.cmd.CommandException: No agent deployments were successful

                at com.mcafee.epo.computermgmt.ui.command.PushAgentCommand.invoke(PushAgentCommand .java:745)

                at com.mcafee.orion.core.cmd.CommandInvoker.invoke(CommandInvoker.java:989)

                at com.mcafee.orion.core.cmd.CommandInvoker.invokeCommand(CommandInvoker.java:762)

                at com.mcafee.orion.core.cmd.CommandInvoker.invoke(CommandInvoker.java:751)

                at com.mcafee.orion.core.cmd.CommandInvoker.invoke(CommandInvoker.java:723)

                at com.mcafee.orion.scheduler.chainable.Chain.invokeChain(Chain.java:289)

                at com.mcafee.orion.scheduler.chainable.Chain.invokeChain(Chain.java:230)

                at com.mcafee.orion.scheduler.chainable.Chain.invoke(Chain.java:42)

                at com.mcafee.orion.core.cmd.CommandInvoker.invoke(CommandInvoker.java:989)

                at com.mcafee.orion.core.cmd.CommandInvoker$AsyncCommandRunner.call(CommandInvoker .java:900)

                at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)

                at java.util.concurrent.FutureTask.run(FutureTask.java:138)

                ... 3 more

                 

                 

                SERVER LOG: (nothing for today 9/26, but here is the stuff from 9/24 and previous)

                 

                20120920154815 I #03480 NAISIGN  RSA BSAFE Crypto-C Micro Edition FIPS 140-2 Module 3.0.0.1

                20120920154815 I #03480 NAIMSRV  Initializing server...

                20120920154815 I #03480 NAIMSRV  Database initialization: Starting.

                20120920154815 I #03480 EPODAL   Microsoft SQL Server 2008 R2 (RTM) - 10.50.1600.1 (X64)

                20120920154815 I #03480 EPODAL    Apr  2 2010 15:48:46

                20120920154815 I #03480 EPODAL    Copyright (c) Microsoft Corporation

                20120920154815 I #03480 EPODAL    Standard Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1) (Hypervisor)

                20120920154815 I #03480 NAIMSRV  Database initialization: Succeeded.

                20120920154815 I #03480 NAIMSRV  Policy Manager initialization: Starting.

                20120920154815 I #03480 NAIMSRV  Policy Manager initialization: Succeeded.

                20120920154815 I #03480 NAIMSRV  Server state at startup: Enabled

                20120920154815 I #03480 NAIMSRV  Reading Updated Server configuration data from database..

                20120920154815 I #03480 NAIMSRV  Siteinfo.INI version update, old = , new = 6163

                20120920154815 I #03480 NAIMSRV  Siteinfo.ini default site changed, old = , new = Current

                20120920154815 I #03480 NAIMSRV  Siteinfo.ini master site server changed, old = , new = ITAS07

                20120920154815 I #03480 NAIMSRV  Siteinfo.ini DNS name changed, old = , new = ITAS07.co.el-dorado.ca.us

                20120920154815 I #03480 NAIMSRV  Siteinfo.ini last known IPaddr changed, old = , new = 172.23.250.242

                20120920154815 I #03480 NAIMSRV  Siteinfo.ini HTTP port changed, old = 0, new = 80

                20120920154815 I #03480 NAIMSRV  Siteinfo.ini Agent ping port changed, old = 0, new = 8081

                20120920154815 W #03480 NAIMSRV  Cannot find any ePO agent policy NAP

                20120920154815 I #03480 NAIMSRV  Checking to see if the ePO server is available.  We will try 12 times.

                20120920154816 I #03480 NAIMSRV  The Agent Handler successfully connected to the ePO server.

                20120920154816 I #03480 MCUPLOAD Successfully disabled CA trust options.

                20120920154816 I #03480 MCUPLOAD Successfully disabled CA trust options.

                20120920154816 I #03480 MCUPLOAD Successfully disabled CA trust options.

                20120920154816 I #03480 NAIMSRV  Unloading server private keys

                20120920154816 I #03480 NAIMSRV  ePolicy Orchestrator server started.

                20120920154816 I #03480 mod_eporepo Database initialization: Starting.

                20120920154816 I #03480 mod_eporepo Database initialization: Succeeded.

                20120920154816 I #03808 NAIMSRV  Notify Message - "SiteListChanged"

                20120920154847 I #03808 NAIMSRV  Notify Message - "PolicyGeneratedPluginChanged"

                20120920155016 I #04004 mod_eporepo Background processing of repository changes starting

                20120920155017 I #03808 NAIMSRV  Notify Message - "SiteListChanged"

                20120920155017 I #03808 NAIMSRV  Reading Updated Server configuration data from database..

                20120920155017 I #03808 NAIMSRV  Siteinfo.INI version update, old = 6163, new = 6660

                20120920155017 I #04004 mod_eporepo Background processing of repository changes ended

                20120920155031 I #04004 mod_eporepo Background processing of repository changes starting

                20120920155032 I #03808 NAIMSRV  Notify Message - "SiteListChanged"

                20120920155032 I #04004 mod_eporepo Background processing of repository changes ended

                20120920155046 I #04004 mod_eporepo Background processing of repository changes starting

                20120920155047 I #03808 NAIMSRV  Notify Message - "SiteListChanged"

                20120920155047 I #04004 mod_eporepo Background processing of repository changes ended

                20120920155101 I #04004 mod_eporepo Background processing of repository changes starting

                20120920155102 I #04004 mod_eporepo Background processing of repository changes ended

                20120920155116 I #04004 mod_eporepo Background processing of repository changes starting

                20120920155117 I #03808 NAIMSRV  Notify Message - "SiteListChanged"

                20120920155117 I #03808 NAIMSRV  Reading Updated Server configuration data from database..

                20120920155117 I #03808 NAIMSRV  Siteinfo.INI version update, old = 6660, new = 6666

                20120920155117 I #04004 mod_eporepo Background processing of repository changes ended

                20120920155131 I #04004 mod_eporepo Background processing of repository changes starting

                20120920155132 I #03808 NAIMSRV  Notify Message - "SiteListChanged"

                20120920155132 I #04004 mod_eporepo Background processing of repository changes ended

                20120920161013 I #02184 NAISIGN  RSA BSAFE Crypto-C Micro Edition FIPS 140-2 Module 3.0.0.1

                20120920161014 I #02184 NAIMSRV  Initializing server...

                20120920161014 I #02184 NAIMSRV  Database initialization: Starting.

                20120920161016 E #02184 EPODAL   COM Error: 0x80004005

                20120920161016 E #02184 EPODAL   File: .\ePOData_Connection.cpp(508)

                20120920161016 E #02184 EPODAL   Function: DAL2_CConnection::GetConnection

                20120920161016 E #02184 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120920161016 E #02184 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120920161016 E #02184 EPODAL   COM Error: 0x80004005

                20120920161016 E #02184 EPODAL   File: .\ePOData_Connection.cpp(525)

                20120920161016 E #02184 EPODAL   Function: DAL2_CConnection::GetConnection

                20120920161016 E #02184 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120920161016 E #02184 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120920161016 E #02184 EPODAL   COM Error: 0x80004005

                20120920161016 E #02184 EPODAL   File: .\ePOData_Connection.cpp(309)

                20120920161016 E #02184 EPODAL   Function: DAL2_CConnection::Init

                20120920161016 E #02184 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120920161016 E #02184 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120920161016 E #02184 EPODAL   DAL2_CConnection::Init: Error 0x80004005 returned from credentials callback. Database NOT available

                20120920161016 E #02184 NAIMSRV  Database initialization: Failed (hr=0x80004005).

                20120920161016 E #02184 NAIMSRV  Initialize Data Abstraction Layer Failed.

                20120920161016 E #02184 NAIMSRV  Failed to check if the ePO server is running.  The server name or user is invalid.  Returning false.

                20120920161016 I #02184 NAIMSRV  Failed to connect to the ePO server.  The Agent Handler does not require the ePO server to be running, but it will exchange information if it is running.

                20120920161016 I #02184 NAIMSRV  Shutting down server...

                20120920161016 E #02432 NAIMSRV  dataChannelDAO_Init: Caught SQL com error 0x80004002 Msg=No such interface supported, Desc=(null), Source=(null)

                20120920161016 E #02432 NAIMSRV  dataChannelDAO_Init: Caught SQL com error 0x80004002 Msg=No such interface supported, Desc=(null), Source=(null)

                20120920161016 I #02184 NAIMSRV  Releasing File Locks...

                20120920161016 I #02184 NAIMSRV  Cleaning up temp directory...

                20120920161016 I #02184 NAIMSRV  ePolicy Orchestrator server stopped.

                20120920161016 I #02184 mod_eporepo Database initialization: Starting.

                20120920161016 E #02184 EPODAL   COM Error: 0x80004005

                20120920161016 E #02184 EPODAL   File: .\ePOData_Connection.cpp(508)

                20120920161016 E #02184 EPODAL   Function: DAL2_CConnection::GetConnection

                20120920161016 E #02184 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120920161016 E #02184 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120920161016 E #02184 EPODAL   COM Error: 0x80004005

                20120920161016 E #02184 EPODAL   File: .\ePOData_Connection.cpp(525)

                20120920161016 E #02184 EPODAL   Function: DAL2_CConnection::GetConnection

                20120920161016 E #02184 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120920161016 E #02184 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120920161016 E #02184 EPODAL   COM Error: 0x80004005

                20120920161016 E #02184 EPODAL   File: .\ePOData_Connection.cpp(309)

                20120920161016 E #02184 EPODAL   Function: DAL2_CConnection::Init

                20120920161016 E #02184 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120920161016 E #02184 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120920161016 E #02184 EPODAL   DAL2_CConnection::Init: Error 0x80004005 returned from credentials callback. Database NOT available

                20120920161016 E #02184 mod_eporepo Database initialization: Failed (hr=0x80004005).

                20120920161016 E #02184 mod_eporepo Failed to connect to database, shutting down repository module, system error 0x80004005

                20120924120505 I #02144 NAISIGN  RSA BSAFE Crypto-C Micro Edition FIPS 140-2 Module 3.0.0.1

                20120924120506 I #02144 NAIMSRV  Initializing server...

                20120924120506 I #02144 NAIMSRV  Database initialization: Starting.

                20120924120509 E #02144 EPODAL   COM Error: 0x80004005

                20120924120509 E #02144 EPODAL   File: .\ePOData_Connection.cpp(508)

                20120924120509 E #02144 EPODAL   Function: DAL2_CConnection::GetConnection

                20120924120509 E #02144 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120924120509 E #02144 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120924120509 E #02144 EPODAL   COM Error: 0x80004005

                20120924120509 E #02144 EPODAL   File: .\ePOData_Connection.cpp(525)

                20120924120509 E #02144 EPODAL   Function: DAL2_CConnection::GetConnection

                20120924120509 E #02144 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120924120509 E #02144 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120924120509 E #02144 EPODAL   COM Error: 0x80004005

                20120924120509 E #02144 EPODAL   File: .\ePOData_Connection.cpp(309)

                20120924120509 E #02144 EPODAL   Function: DAL2_CConnection::Init

                20120924120509 E #02144 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120924120509 E #02144 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120924120509 E #02144 EPODAL   DAL2_CConnection::Init: Error 0x80004005 returned from credentials callback. Database NOT available

                20120924120509 E #02144 NAIMSRV  Database initialization: Failed (hr=0x80004005).

                20120924120509 E #02144 NAIMSRV  Initialize Data Abstraction Layer Failed.

                20120924120509 E #02144 NAIMSRV  Failed to check if the ePO server is running.  The server name or user is invalid.  Returning false.

                20120924120509 I #02144 NAIMSRV  Failed to connect to the ePO server.  The Agent Handler does not require the ePO server to be running, but it will exchange information if it is running.

                20120924120509 I #02144 NAIMSRV  Shutting down server...

                20120924120509 E #02404 NAIMSRV  dataChannelDAO_Init: Caught SQL com error 0x80004002 Msg=No such interface supported, Desc=(null), Source=(null)

                20120924120509 E #02404 NAIMSRV  dataChannelDAO_Init: Caught SQL com error 0x80004002 Msg=No such interface supported, Desc=(null), Source=(null)

                20120924120509 I #02144 NAIMSRV  Releasing File Locks...

                20120924120509 I #02144 NAIMSRV  Cleaning up temp directory...

                20120924120509 I #02144 NAIMSRV  ePolicy Orchestrator server stopped.

                20120924120509 I #02144 mod_eporepo Database initialization: Starting.

                20120924120509 E #02144 EPODAL   COM Error: 0x80004005

                20120924120509 E #02144 EPODAL   File: .\ePOData_Connection.cpp(508)

                20120924120509 E #02144 EPODAL   Function: DAL2_CConnection::GetConnection

                20120924120509 E #02144 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120924120509 E #02144 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120924120509 E #02144 EPODAL   COM Error: 0x80004005

                20120924120509 E #02144 EPODAL   File: .\ePOData_Connection.cpp(525)

                20120924120509 E #02144 EPODAL   Function: DAL2_CConnection::GetConnection

                20120924120509 E #02144 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120924120509 E #02144 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120924120509 E #02144 EPODAL   COM Error: 0x80004005

                20120924120509 E #02144 EPODAL   File: .\ePOData_Connection.cpp(309)

                20120924120509 E #02144 EPODAL   Function: DAL2_CConnection::Init

                20120924120509 E #02144 EPODAL   Source: Microsoft OLE DB Provider for SQL Server

                20120924120509 E #02144 EPODAL   Description: Cannot open database "ePO4_ITAS07" requested by the login. The login failed.

                20120924120509 E #02144 EPODAL   DAL2_CConnection::Init: Error 0x80004005 returned from credentials callback. Database NOT available

                20120924120509 E #02144 mod_eporepo Database initialization: Failed (hr=0x80004005).

                20120924120509 E #02144 mod_eporepo Failed to connect to database, shutting down repository module, system error 0x80004005

                • 5. Re: EPO 4.6.3 /  Agent Deployment Expired
                  Laszlo G

                  It looks like you can have an SQL problem, as if ePO couldn't connect to the database and so not being able to write down data when deploying to a new agent...?

                   

                  You can try to update your credentials under https://your_epo_server:8443/core/config, writing down your user password again (and new user or domain if changed), then test, apply and reboot.

                  • 6. Re: EPO 4.6.3 /  Agent Deployment Expired
                    hem

                    Yeah, I see the issue with DB connectivity issue. Please validate \core\config page, restart the ePO services and try to push the agent.

                     

                    Message was edited by: hem on 27/9/12 9:35:04 PM IST