9 Replies Latest reply on Sep 15, 2012 2:50 PM by exbrit

    Cannot reinstall McAfee - Blank installer

      A while ago I was forced to uninstall McAfee Internet Security because the firewall was intermittantly preventing any sort of browser use. That has since been fixed via an update but now that I am trying to reinstall McAfee, I can't. I have tried via the CD, but just get a blank window. Tried via the downloader, but after another blank screen and a period of inactivity get the message "We’re having trouble installing your McAfee software. Click OK and wait a moment while we fix the issue. Once fixed, we will automatically continue your installation from where it left off." I click OK but nothing gets fixed.

       

      The problem appears to be due to Javascript not working, because when I attempt to visit update.microsoft.com I'm met with a blank screen, Google appears without a logo, I can't use most sites. Another blank screen if I attempt to use System Restore. I had to download Firefox just to login to this site because I couldn't on IE. I've read previous solutions regarding resetting IE, but I've tried this and it's still not working. I'm running Windows XP, IE8.

        • 1. Re: Cannot reinstall McAfee - Blank installer
          exbrit

          Is this XP SP3?  A blank webpage or screen is usually caused by either non-standard fonts being installed, in which case uninstalling them usually cures the situation, or the fact that Internet Explorer is not set to it's defaults.

           

          Open Internet Explorer and go to Tools/Internet Options/Advance and click 'Reset'.  Apply and OK.

           

          Close and reopen IE and go to Tools/Add-ons and make sure the ones you need are enabled.

           

          Webpages and the McAfee installer should now work, howerver I recommend the following.

           

          Go to Control Panel > Add or Remove Programs and uninstall anything McAfee then run the MCPR cleanup tool listed under Useful Links at the top of this page or here:  http://download.mcafee.com/products/licensed/cust_support_patches/MCPR.exe

           

          Reboot and then run the McAfee Preinstall Tool:  http://download.mcafee.com/products/licensed/cust_support_patches/McPreInstall.e xe

           

          Then reinstall your product, not from the CD, but from your online account, which must exist since you had McAfee installed before:  https://home.mcafee.com/secure/protected/login.aspx?

           

          Message was edited by: Ex_Brit on 14/09/12 6:39:21 EDT AM
          • 2. Re: Cannot reinstall McAfee - Blank installer

            Yep, XP SP 3. Thanks for the suggestions, but no luck. I reset IE (again), downloaded the MCPR tool, but upon running it I got the following message:

             

            MCAFEE CLEANUP

            September 13, 2012 22:22:17

            INFO   Silent mode activated.

            INFO   Cleanup will be scheduled and run.

            INFO   Product MFP to be removed from system.

            INFO   Product Auth to be removed from system.

            INFO   Product EMproxy to be removed from system.

            INFO   Product FWdiver to be removed from system.

            INFO   Product McSvcHost to be removed from system.

            INFO   Product HW to be removed from system.

            INFO   Product MAS to be removed from system.

            INFO   Product MAT to be removed from system.

            INFO   Product MBK to be removed from system.

            INFO   Product MCPR to be removed from system.

            INFO   Product McProxy to be removed from system.

            INFO   Product VUL to be removed from system.

            INFO   Product MHN to be removed from system.

            INFO   Product MNA to be removed from system.

            INFO   Product MOBK to be removed from system.

            INFO   Product MPFP to be removed from system.

            INFO   Product MPFPCU to be removed from system.

            INFO   Product MPS to be removed from system.

            INFO   Product SHRED to be removed from system.

            INFO   Product MPSCU to be removed from system.

            INFO   Product MQC to be removed from system.

            INFO   Product MQCCU to be removed from system.

            INFO   Product MSAD to be removed from system.

            INFO   Product MSHR to be removed from system.

            INFO   Product MSK to be removed from system.

            INFO   Product MSKCU to be removed from system.

            INFO   Product MWL to be removed from system.

            INFO   Product NMC to be removed from system.

            INFO   Product RedirSvc to be removed from system.

            INFO   Product VS to be removed from system.

            INFO   Product MSC to be removed from system.

            INFO   Start trust.

            INFO   MfeApTrustLegacyProcessStart return FALSE.

            INFO   Disable AP and wait for 5 seconds.

            INFO   Task Scheduler service started.

            WINERR IPersistFile::Save() failed. Error: 0x8007007a

            FAIL   Error while running cleanup using Task Scheduler.

            INFO   End trust.

             

            Regardless, I continued on. Rebooted, ran the Preinstall Tool. I got a warning saying it would delete all temporary files etc., clicked OK and let it run. At least I presumed it did. The window minimised and disappeared after a while with no message saying success/failure so I presume it ran okay. Attempted reinstall, same blank screen, same error message.

            Also, I don't know if this makes any difference or not, but Windows Media Player won't start either.

            • 3. Re: Cannot reinstall McAfee - Blank installer
              exbrit

              Some more questions.  Are you doing all this while signed in as an Admin-level user?  (It wont work with limited user accounts).

               

              Is IE8 the final version and not any beta version?  I would imagine it's not but thought I'd ask.    It sounds to me like your system isn't all that it should be.   Do you have the XP SP3 Installation Disk so that a format and reinstallation can be done in the worst case scenario?

               

              Another thought is that some kind of infection is causing this crazy behaviour.

               

              Run RootkiRemover, Stinger and then Malwarebytes Free listed in the last link in my signature below.   The latter one can be installed, updated and run all in 'Safe Mode with Networking' if necessary, assuming you can connect to the Internet in that mode of course.

              • 4. Re: Cannot reinstall McAfee - Blank installer

                Yep, made sure I was logged in as admin. There are two user level accounts and neither have access to admin functions.

                IE8, that's a strange one. When I go into the usual Help -> About menu, it comes up as Internet Explorer 8 but underneath is listed;

                 

                Version:

                Cipher Strength:

                Product ID:

                 

                all as above, blank! Also, there are 2 buttons in said window, OK and System Info - I can click on both, but nothing happens. Only when I use the X does it close. I downloaded MalwareBytes when I saw this happen first, it removed 40~ threats, but their removal seemed to have no effect. I'm after trying RootkitRemover, got the following result:

                 

                 

                Rootkit Remover v0.8.7

                McAfee Labs.

                 

                 

                Initializing...

                Initialization complete!

                 

                Now Scanning...

                    Scan Result --> No trojan or viruses found!

                Scan Finished

                 

                 

                Press any key to exit.

                 

                 

                I'll give Stinger a try and hope that that can do something. I know it's tantamount to heresy, but I downloaded AVG too It found a few infections, but like MalwareBytes, their removal had no effect on system performance.

                Thankfully I can browse the internet fine on Firefox (I'm posting from the affected computer at the moment), but IE just refuses to load anything Java related.

                • 5. Re: Cannot reinstall McAfee - Blank installer
                  exbrit

                  Have you installed any new  Fonts?  They can cause this behaviour.

                   

                   

                   

                  Message was edited by: Ex_Brit on 15/09/12 10:56:54 EDT AM
                  • 6. Re: Cannot reinstall McAfee - Blank installer

                    Nope, only the system's preinstalled fonts. Stinger didn't find anything. I ran a full scan with AVG and MalwareBytes overnight, again both found several threats but nothing severe. Removed them, but it's still the same.

                    I have the XP reinstallation disk, but it's literally just XP Home, before even SP1. I dread the updating process. I'm going to try downloading some of Microsoft's "Fix it" programs to see if they can find anything wrong. The fact that scripting is working fine in Firefox/Chrome and not IE doesn't really warrant an OS reinstall, in my opinion. But having paid for McAfee I want to use it!

                    • 7. Re: Cannot reinstall McAfee - Blank installer
                      exbrit

                      AVG?  That's another antivirus.  You should never have 2 installed and that feasibly could be the reason for the strange behaviour.   There are tools that are recommended linked in my signature below, last link see under '3rd Party Tools'.

                       

                      Apart from what's been checked so far all I can suggest is to contact Technical Support and escalate it if necessary.  Linked under Useful Links at the top of this page.

                      • 8. Re: Cannot reinstall McAfee - Blank installer

                        I only installed AVG following my unsucessful attempts to reinstall McAfee though, I never had the 2 installed at the same time. I would uninstall it but I don't like potentially leaving the computer vulnerable. I've contacted Tech Support and I'm waiting on a reply at the moment.

                        From similar problems reported, seemingly the following is a fix; Start -> Run -> and type "regsvr32 jscript.dll"

                        But all I get from that is:

                         

                        ---------------------------

                        RegSvr32

                        ---------------------------

                        DllRegisterServer in jscript.dll failed.

                        Return code was: 0x80004005

                        ---------------------------

                        OK  

                        ---------------------------

                        • 9. Re: Cannot reinstall McAfee - Blank installer
                          exbrit

                          OK re: AVG, I quite understand and that's fine.  Regarding that error I think it happens if you've run the Command Prompt at regular level, it needs to run as an Adminstrator.

                           

                          Locate Command Prompt in Start/All Programs/Accessories and right-click and 'Run as' then choose the Administrator and enter any password if asked, if one is applicable of courese, otherwise leave the password blank.

                           

                          (I'm going by memory, sorry as it's been a while since I had a full XP system up and running.)

                           

                          Message was edited by: Ex_Brit on 15/09/12 3:50:44 EDT PM