3 Replies Latest reply on Aug 22, 2012 8:23 AM by bostjanc

    Update DAT on particular machine gives me an error: unable to find valid repository

    bostjanc

      Greetings!

       

      Trying to update a windows 7 x64 client thru epo or manually from client. I receieve an error that mcafee is unable to find valid a valid repository.

      -Reinstalling VSE 8.8 with latest patch and Mcafee agent 4.6 with latest patch did not helped.

      -Cleaning tool for Mcafee did not help, although I did not rebooted the machine after I have put VSE and AGENT again on this machine

      -I am able to wake up agent, but it does not do product update of DAT files, version stays on 1111.0000

       

      We ain't using proxy server for this machine.

       

      Any other suggestion?

        • 1. Re: Update DAT on particular machine gives me an error: unable to find valid repository

          Could be many causes.

           

          Being a Win 7 machine, try looking in C:\Users\All Users\McAfee\Common Framework\db\ at the agent_ file. Should have more details about why it's failing.

           

          Other things I'd suggest are:

          - corrupt repository list (install frame package again using the /force switch), permission problems on the machine, a repository that hasn't completed replicating, or the agent policy applied to the machine for repositories may have nothing enabled.

          • 2. Re: Update DAT on particular machine gives me an error: unable to find valid repository
            bostjanc

            one question. Opening agent log thru EPO is this the same log as a log on local machine: C:\Users\All Users\McAfee\Common Framework\db\ ?

            • 3. Re: Update DAT on particular machine gives me an error: unable to find valid repository
              bostjanc

              This are error messages from that client, anything useful to determine the root of the problem?

               

              2012-08-22 14:45:36.643 I #6060 UpdEvents Generating update event:EventId=2402:Severity=0:ProductId=EPOAGENT3000:Locale=0424:UpdateType=N/A :UpdateError=26:NewVersion=N/A:DateTime=N/A

               

              2012-08-22 14:16:25.152 E #288 Logging addAgentInfoToLog GUID query error 2

              2012-08-22 14:16:27.768 E #8072 Logging addAgentInfoToLog GUID query error 2

              2012-08-22 14:19:25.326 E #9348 Sched <<--CSchedule::ModifyTask hr=0x8000001b : Task is not found

              2012-08-22 14:19:25.326 E #9348 Sched <<--CSchedule::DeleteTask hr=0x8000001b : Task is not found

              2012-08-22 14:19:25.327 E #9348 Sched <<--CSchedule::GetTask hr=0x8000001b : Task is not found

              2012-08-22 14:19:29.104 E #9488 Sched <<--IsSWInstalled hr=-1011(0xfffffc0d)

              2012-08-22 14:20:15.464 E #12232 Sched <<--CSchedule::ModifyTask hr=0x8000001b : Task is not found

              2012-08-22 14:20:29.077 E #12232 Sched <<--CSchedule::ModifyTask hr=0x8000001b : Task is not found

              2012-08-22 14:20:59.079 E #12232 Sched <<--CSchedule::ModifyTask hr=0x8000001b : Task is not found

              2012-08-22 14:21:29.083 E #12232 Sched <<--CSchedule::ModifyTask hr=0x8000001b : Task is not found

              2012-08-22 14:21:32.613 E #11740 Logging drop 1 [\\.\mailslot\VSECMA-{F00D5AF3-C2CF-46D2-B04D-97755259EB40}] file not found

               

              2012-08-22 14:45:36.642 I #3720 MueEep Invoking events withEventId " 0" Severity " 0" Productid " EPOAGENT3000" Locale " 0424" UpdateType " N/A" UpdateError " 26" New Version " N/A" Date Time " N/A" Script Id" 5432"

               

              2012-08-22 14:45:36.640 E #3720 imsite   The naInet library returned an error. [Parent error: NaInet library returned code == -10]

               

              2012-08-22 14:45:36.494 E #3720 creposi   Download is allowed from the McAfee repositories but error condition found. Error code:-2. Error message:

              2012-08-22 14:45:36.495 I #3720 naInet HTTP Session initialized

              2012-08-22 14:45:36.495 I #3720 imsite  Download to: C:\Windows\TEMP\SiteStat.xml

              2012-08-22 14:45:36.495 I #3720 imsite  Download from: (McAfeeHttp) SiteStat.xml

              2012-08-22 14:45:36.574 I #3720 naInet Open URL: http://update.nai.com:80/Products/CommonUpdater/SiteStat.xml

              2012-08-22 14:45:36.638 E #3720 imsite Error trace:

              2012-08-22 14:45:36.638 E #3720 Thread  [Main thread]->

              2012-08-22 14:45:36.639 E #3720 SessMgr  [initializeScript]->

              2012-08-22 14:45:36.639 E #3720 creposi  [setNextRepositoryToUse]->

              2012-08-22 14:45:36.639 E #3720 creposi  [Candidate McAfeeHttp: testing]->

              2012-08-22 14:45:36.639 E #3720 creposi  [downloadFile,SiteStat.xml,C:\Windows\TEMP]->

              2012-08-22 14:45:36.639 E #3720 imsite  [downloadFile,SiteStat.xml,,C:\Windows\TEMP,1]->

              2012-08-22 14:45:36.639 E #3720 imsite   NaInet library returned code == -10

               

              2012-08-22 14:45:33.109 E #3720 RcFile  [LoadLibrary,0424/MueRes_InUse.dll]->

              2012-08-22 14:45:33.109 E #3720 RcFile   error 126: The specified module could not be found.

               

              2012-08-22 14:19:37.689 E #6464 RcFile Error trace:

              2012-08-22 14:19:37.689 E #6464 Thread  [Main thread]->

              2012-08-22 14:19:37.690 E #6464 SessMgr  [initialize]->

              2012-08-22 14:19:37.690 E #6464 SessMgr  [loadResources]->

              2012-08-22 14:19:37.690 E #6464 SessMgr  [loadResourceFile]->

              2012-08-22 14:19:37.690 E #6464 RcFile  [LoadLibrary,0424/MueRes_InUse.dll]->

              2012-08-22 14:19:37.690 E #6464 RcFile   error 126: The specified module could not be found.