1 2 Previous Next 10 Replies Latest reply on Jun 14, 2013 11:44 AM by drumik

    Endpoint Encryption PC6.2 fails to install

      I can successfully deploy this to a Windows 7 64bit client but the first 32 bit client fails.

      I get no messages from EPO other than "failed".  I see some errors in the mfeepe but to be honest I don't know what any of it means.  I'm new to McAfee and so far I've found the documentation lacking.  Anyways I'm hoping someone can help, here is part of the log from where I tried to pushg EE again this am:

      2012-08-15 11:41:33,994 INFO    EpoPlugin                            collectProperties: dispatching disk list to AgentHandler

      2012-08-15 11:41:36,351 INFO    EpoPlugin                            enforcePolicy: new policy store created (session 1344976049).

      2012-08-15 11:41:40,563 INFO    EpoPlugin                            enforcePolicy: Waiting for OptIn users (i.e. non-default UBP users) before enforcing policy.

      2012-08-15 11:41:41,172 INFO    EpoState                             == Start of policy enforcement ==

      2012-08-15 11:41:41,172 INFO    EpoPlugin                            enforceUserPolicy: Dispatching enforce policy event.

      2012-08-15 11:41:41,172 INFO    MfeEpeStatusService                  Policy enforcement has started

      2012-08-15 11:41:41,218 INFO    EpoPlugin                            policyHandler: handling EnforcePolicy event

      2012-08-15 11:41:41,312 INFO    EpoPlugin                            userHandler: handling AddLocalDomainUsers event

      2012-08-15 11:41:41,406 INFO    DomainUsers                          Found new (unprocessed) local domain user: \\bc\grusse

      2012-08-15 11:41:41,406 INFO    EpoPlugin                            userHandler: dispatching EPOAddDomainUsers event to McAfee Agent

      2012-08-15 11:41:41,406 INFO    EpoPlugin                            userHandler: Note, press Send Events button in McAfee Agent to hasten delivery (see KB78165).

      2012-08-15 11:41:41,811 INFO    MfeEpeStatusService                  Creating Event to request data for local domain users

      2012-08-15 11:41:44,151 INFO    EpoPlugin                            enforcePolicy: Policy Enforcement is already in progress, skipping this one.

      2012-08-15 11:41:44,448 INFO    EpoPlugin                            enforcePolicy: Policy Enforcement is already in progress, skipping this one.

      2012-08-15 11:42:05,327 INFO    EpoPlugin                            enforcePolicy: Policy Enforcement is already in progress, skipping this one.

      2012-08-15 11:42:05,468 INFO    EpoPlugin                            enforcePolicy: Policy Enforcement is already in progress, skipping this one.

      2012-08-15 11:46:48,483 INFO    EpoPlugin                            userHandler: handling AddLocalDomainUsers response

      2012-08-15 11:46:48,483 INFO    MfeEpeStatusService                  Received data for local domain users

      2012-08-15 11:46:48,483 INFO    EpoPlugin                            userHandler: local user (C9B8A51F878F5544A13A6EB3D07AFE56) already assigned.

      2012-08-15 11:46:48,483 INFO    EpoPlugin                            userHandler: dispatching GetAllUsers event to AgentHandler

      2012-08-15 11:46:48,530 INFO    EpoPlugin                            userHandler: Note, press Send Events button in McAfee Agent to hasten delivery (see KB78165).

      2012-08-15 11:46:48,608 INFO    MfeEpeStatusService                  Creating Event to request data for assigned users

      2012-08-15 11:47:06,441 INFO    EpoPlugin                            enforcePolicy: Policy Enforcement is already in progress, skipping this one.

      2012-08-15 11:47:06,519 INFO    EpoPlugin                            enforcePolicy: Policy Enforcement is already in progress, skipping this one.

      2012-08-15 11:51:39,614 INFO    EpoPlugin                            userHandler: handling GetAllUsers response

      2012-08-15 11:51:39,723 INFO    MfeEpeStatusService                  Received data for assigned users

      2012-08-15 11:51:39,848 INFO    MfeEpeCoreEncryptionPlugin           --- Activation Begins ---

      2012-08-15 11:51:39,848 INFO    MfeEpeStatusService                  Activation has started

      2012-08-15 11:51:39,848 INFO    MfeEpeStatusService                  Searching available Encryption Providers

      2012-08-15 11:51:39,864 INFO    MfeEpeCoreEncryptionPlugin           Size of provider order list in policy is 2

      2012-08-15 11:51:39,864 WARNING MfeEpeCoreEncryptionPlugin           [0xEE010001] No providers installed

      2012-08-15 11:51:39,895 WARNING MfeEpeCoreEncryptionPlugin           [0xEE010001] No providers installed

      2012-08-15 11:51:39,973 INFO    EpoPlugin                            epoAudit: dispatching audits to AgentHandler

      2012-08-15 11:51:40,129 ERROR   EpoPlugin                            userHandler: failed to process batched user data response: [0xEE010001] [0xEE010001] No providers installed

      2012-08-15 11:51:40,129 INFO    EpoState                             == End of policy enforcement ==

      2012-08-15 11:51:40,129 ERROR   MfeEpeStatusService                  Failed to process a batch of user data received

      2012-08-15 11:51:40,129 INFO    MfeEpeStatusService                  Policy enforcement has completed

      2012-08-15 11:51:40,145 INFO    EpoPlugin                            userHandler: handling GetAllUsers response

      2012-08-15 11:51:40,145 INFO    MfeEpeStatusService                  Received data for assigned users

      2012-08-15 11:51:40,160 ERROR   EpoPlugin                            userHandler: failed to process batched user data response: [0xEE000006] No policy store

      2012-08-15 11:51:40,160 INFO    EpoState                             == End of policy enforcement ==

      2012-08-15 11:51:40,192 ERROR   MfeEpeStatusService                  Failed to process a batch of user data received

      2012-08-15 11:51:40,192 INFO    MfeEpeStatusService                  Policy enforcement has completed

      2012-08-15 11:51:40,192 INFO    EpoPlugin                            userHandler: handling GetAllUsers response

      2012-08-15 11:51:40,192 ERROR   EpoPlugin                            userHandler: failed to process batched user data response: [0xEE000006] No policy store

      2012-08-15 11:51:40,192 INFO    EpoState                             == End of policy enforcement ==

      2012-08-15 11:51:40,192 INFO    MfeEpeStatusService                  Received data for assigned users

      2012-08-15 11:51:40,192 ERROR   MfeEpeStatusService                  Failed to process a batch of user data received

      2012-08-15 11:51:40,192 INFO    MfeEpeStatusService                  Policy enforcement has completed

      2012-08-15 11:52:07,290 INFO    EpoPlugin                            enforcePolicy: No policy enforcement required (nothing has changed), waiting until next ASCI.

      2012-08-15 11:57:08,055 INFO    EpoPlugin                            enforcePolicy: No policy enforcement required (nothing has changed), waiting until next ASCI.

      2012-08-15 12:02:08,936 INFO    EpoPlugin                            enforcePolicy: No policy enforcement required (nothing has changed), waiting until next ASCI.

      2012-08-15 12:07:16,495 INFO    EpoPlugin                            enforcePolicy: No policy enforcement required (nothing has changed), waiting until next ASCI.

        • 1. Re: Endpoint Encryption PC6.2 fails to install
          dwebb

          Looks like only the McAfee Endpoint Encryption Agent is installed on the client.  You need to ensure that the McAfee Endpoint Encryption for PC package is installed as well.


          Please see the Product Guide, Page 15 onwards.

           

          Please also come back to this forum with comments on the documentation, if you have any.


          Thanks!  And hope this helps.

          • 2. Re: Endpoint Encryption PC6.2 fails to install

            I know the Agent is installed, what do you mean install the Endpoint Encryption package?  That is exactly what failed and what I need help with?

            • 3. Re: Endpoint Encryption PC6.2 fails to install
              dwebb

              Can you attach a screenshot of your ePO client deployment task for the EEPC components please?

              • 4. Re: Endpoint Encryption PC6.2 fails to install

                This?  Like I mentioned it has worked flawlessly on Win7 64bit clients.

                ePolicy Orchestrator 4.6.jpg

                • 5. Re: Endpoint Encryption PC6.2 fails to install

                  Where'd ya go?

                  Anyway if this helps it's an HP Mini210.  Freshly loaded windows 7 Pro with none of the HP tools installed.  Clean slate so to speak.

                  But this is what I mean about documentation, I guess I should add logging as well, how can it Fail and not tell you why?

                  What is a policy store?  What does not providers installed mean? I was hoping someone who works at Mcafee would know because I can't find the information anywhere else......

                   

                  Hate to vent but getting this software running has been an excersize in frustration.

                  • 6. Re: Endpoint Encryption PC6.2 fails to install
                    dwebb

                    The deployment task looks fine, so I'm not sure why it's not installed correctly.

                     

                    The "no providers installed" means that the endpoint encryption agent thinks that the EEPC component is not installed and no encryption providers are present.  This is either because the EEPC package failed to install, or it did install and the providers are not referenced correctly in the registry.

                     

                    Can you go to c:\program files\McAfee and check to see whether you've got both an Agent and a PC folder?

                    • 7. Re: Endpoint Encryption PC6.2 fails to install

                      I have a "Common Framework" and an "Endpoint Encryption Agent" folder in that location.

                      The EEPC does fail that is in the log, I need to find out why? 

                      Is there a seperate package or something that I need to check in for Win7 32 bit? 

                      • 8. Re: Endpoint Encryption PC6.2 fails to install
                        dwebb

                        The deployment task you have should install both the Endpoint Encryption Agent and the EEPC package.  This would give you 2 folders in Program Files\McAfee, one for EE Agent and one for EEPC.  You appear to be missing the folder "Endpoint Encryption for PC V6" under Program Files\Mcafee which ties in with the failure to install you mentioned earlier.

                         

                        What you could do is this:

                         

                        1) open up the EEPC.zip package and extract the MfeEEPc32.msi

                        2) copy it to the offending machine

                        3) open an administrative command prompt

                        4) install the MSI using msiexec /l*v log.log /i MfeEEPc32.msi

                        5) attach the log.log file to this post and I'll have a look to see if there's anything obvious.

                        • 9. Re: Endpoint Encryption PC6.2 fails to install

                          Oh just so there is some closure here, I'm thinking it had to be the BIOS on those minis, many other Encryption providers have them on a blacklist or DO NOT ENCRYPT list.

                          1 2 Previous Next